Bug 136783 - FILEOPEN: PPTX: Error reading file importing file with table
Summary: FILEOPEN: PPTX: Error reading file importing file with table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2020-09-15 16:22 UTC by Xisco Faulí
Modified: 2021-06-14 11:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-09-15 16:22:45 UTC
Steps to reproduce:
1. open attachment 139337 [details] from bug 115209

-> Read Error. Error reading file

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 6f1e02c96b887750f974c187a82ecd6236e6a435
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-09-15 16:24:08 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=99dff69b561a8fe2d9437e6aa67a9581a6666f41

author	Gülşah Köse <gulsah.kose@collabora.com>	2020-08-10 10:04:51 +0300
committer	Gülşah Köse <gulsah.kose@collabora.com>	2020-08-10 23:51:39 +0200
commit 99dff69b561a8fe2d9437e6aa67a9581a6666f41 (patch)
tree 11baa67101340214ba81f75253ac30b88cb66d84
parent 386add495b3d8b7816a521bb28c5f48fc243bc99 (diff)
tdf#133015 Fix table position during import multicol textbox.

Bisected with: bibisect-linux64-7.1

Adding Cc: to Gülşah Köse
Comment 2 Justin L 2021-01-16 13:26:29 UTC Comment hidden (no-value)
Comment 3 Justin L 2021-01-16 13:50:28 UTC
simple solution is
- sal_Int32 nColumnSize = mvTableGrid.size();
+ sal_Int32 nColumnSize = std::min(tableRow.getTableCells().size(), mvTableGrid.size());

However, my guess is that using mvTableGrid.size() is wrong.

I wanted to make a minimized test, but round-tripping this file in Word 2010 "fixes" the problem. (I see that is also noted in bug 115209 where they also attempted a minimized file with attachment 153755 [details].)

So then should we also mark this as "NOTOURBUG"? I assume this comes from slide 6 since I get debug output with tableproperties.cxx:149: ::pushToPropSet rows[6] columns[1] grid[3]

However, since a bandaid fix is simple, I'll propose http://gerrit.libreoffice.org/c/core/+/109438 and suggest that bug 133015 probably needs to be revisited and get a better fix than using grid size.

Since our unique document's size is very large, I'm not including a unit test.
Comment 4 Gerald Pfeifer 2021-06-10 12:14:56 UTC
This was fixed by the commits related to bug#118458.

Verified with

Version: 7.2.0.0.alpha1+ / LibreOffice Community
Build ID: b6a30a9db00f92eec7387a577321d65d47ff4af5
CPU threads: 8; OS: Linux 5.12; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-06-08_21:15:20
Comment 5 Xisco Faulí 2021-06-10 14:56:16 UTC
(In reply to Gerald Pfeifer from comment #4)
> This was fixed by the commits related to bug#118458.
> 
> Verified with
> 
> Version: 7.2.0.0.alpha1+ / LibreOffice Community
> Build ID: b6a30a9db00f92eec7387a577321d65d47ff4af5
> CPU threads: 8; OS: Linux 5.12; UI render: default; VCL: gtk3
> Locale: en-US (en_US.UTF-8); UI: en-US
> TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time:
> 2021-06-08_21:15:20

Indeed, fixed by 

https://cgit.freedesktop.org/libreoffice/core/commit/?id=486a11ad6fdae1714200229462b69f328be06b5a

thor	Mike Kaganski <mike.kaganski@collabora.com>	2021-06-05 00:19:06 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2021-06-08 14:51:57 +0200
commit 486a11ad6fdae1714200229462b69f328be06b5a (patch)
tree 592469c652c8919cc1e864d20ea10f5d5b8b167a
parent d0a1616ccad0dd5f5a02c1b0204f537b57d0b4b5 (diff)
editengine-columns: PPTX support (tdf#118458)