Download it now!
Bug 136836 - EMF import from PPTX: visual problems with large image
Summary: EMF import from PPTX: visual problems with large image
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords: perf
: 114187 119662 124133 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-17 07:48 UTC by Miklos Vajna
Modified: 2020-10-12 09:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Reproducer document (3.72 MB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2020-09-17 07:48 UTC, Miklos Vajna
Details
How it looks in Impress (86.04 KB, image/png)
2020-09-17 07:49 UTC, Miklos Vajna
Details
How it looks in PowerPoint (93.40 KB, image/png)
2020-09-17 07:50 UTC, Miklos Vajna
Details
Improved Impress output: better, but blurry (157.36 KB, image/png)
2020-09-18 10:57 UTC, Miklos Vajna
Details
Better, non-blurry result. (176.54 KB, image/png)
2020-09-21 07:37 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2020-09-17 07:48:43 UTC
Created attachment 165605 [details]
Reproducer document

Steps to reproduce:

1) open the attached pptx

2) compare the result (visually) with powerpoint

Expected result: something similar is shown

Actual result: powerpoint shows a series of servers, libreoffice shows what is closer to an abstract painting :)
Comment 1 Miklos Vajna 2020-09-17 07:49:36 UTC
Created attachment 165606 [details]
How it looks in Impress
Comment 2 Miklos Vajna 2020-09-17 07:50:34 UTC
Created attachment 165607 [details]
How it looks in PowerPoint
Comment 3 Miklos Vajna 2020-09-17 07:55:09 UTC
Second problem: the EMF is very slow to open. An optimized master build gives:

$ time OOO_EXIT_POST_STARTUP=1 ./soffice.bin --nologo scratch.pptx 
real    2m2,153s
Comment 4 Commit Notification 2020-09-17 15:22:13 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d75c5b38911557173c54a78f42ff220ab3918573

tdf#136836 emfio: speed up import of EMF import when the orig PDF is available

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Miklos Vajna 2020-09-17 15:32:46 UTC
Performance is now OK and the result is also close to correct, but more blurry than possible. I keep the bug open till I resolve that piece.
Comment 6 Miklos Vajna 2020-09-18 10:57:23 UTC
Created attachment 165657 [details]
Improved Impress output: better, but blurry

Just to save it somewhere, I attach the current state (better, but blurry result).
Comment 7 Commit Notification 2020-09-18 19:25:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/01024ee24c6e89044c68051f6fd5f1264905e90c

[API CHANGE] tdf#136836 emfio: set size hint on inner PDF if used as shape fill

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Miklos Vajna 2020-09-21 07:37:29 UTC
Created attachment 165709 [details]
Better, non-blurry result.
Comment 9 Miklos Vajna 2020-09-21 07:38:12 UTC
This now looks OK to me, visually and performance-wise.
Comment 10 Commit Notification 2020-09-21 12:00:14 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/f1494915d40f4bdb3e25bd35427ba7b773b91838

tdf#136836 emfio: speed up import of EMF import when the orig PDF is available

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2020-09-21 12:01:24 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/69842afcab0c5043c3c554493dd92d58c2bb02af

[API CHANGE] tdf#136836 emfio: set size hint on inner PDF if used as shape fill

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2020-09-21 14:13:12 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 121771e37f7e2de41cd5643475861062bf25627b
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

besides, the document opens in a few seconds, very nice!!

@Miklos, thanks for fixing this issue!
Comment 13 Timur 2020-09-22 07:15:49 UTC
*** Bug 124133 has been marked as a duplicate of this bug. ***
Comment 14 Timur 2020-09-22 07:23:44 UTC
*** Bug 114187 has been marked as a duplicate of this bug. ***
Comment 15 Timur 2020-09-22 07:34:04 UTC
*** Bug 119662 has been marked as a duplicate of this bug. ***
Comment 16 Timur 2020-09-22 08:26:23 UTC
Miklos, you did a great work with this. 
Please see attachment 165752 [details] and attachment 165754 [details] from bug 119662, if you would also work on these or you can add some explanation there, to open a new bugs.