Bug 137152 - Element bounding boxes not visible if presentation saved as PPTX
Summary: Element bounding boxes not visible if presentation saved as PPTX
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: PPTX-Textbox
  Show dependency treegraph
 
Reported: 2020-09-30 08:27 UTC by Mihai Vasiliu
Modified: 2021-06-02 20:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
This is a demo presentation to open and see that there are no boundry boxes visible (20.59 KB, application/zip)
2020-09-30 14:25 UTC, Mihai Vasiliu
Details
A newly inserted slides default shape from slide layout (60.08 KB, image/png)
2021-01-22 12:58 UTC, NISZ LibreOffice Team
Details
A shape after loading the example file (70.92 KB, image/png)
2021-01-22 12:59 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Vasiliu 2020-09-30 08:27:48 UTC
If we open a PPTX presentation or create a new presentation, save it as PPTX and reopen, all the bounding boxes on the elements of the slide are missing/invisible.

By bounding box I refer to the blue border that appears on the edges of text boxes when editing the text inside them to make them easy to grab, handle, resize etc.

This occurs even if we open an existing PPTX or if we create a new one and save as PPTX.

ODP format is not affected and works fine, bounding boxes are visible. Only PPTX are affected.
Comment 1 Xisco Faulí 2020-09-30 12:23:23 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 2 Mihai Vasiliu 2020-09-30 14:25:36 UTC
Created attachment 165983 [details]
This is a demo presentation to open and see that there are no boundry boxes visible
Comment 3 NISZ LibreOffice Team 2021-01-22 12:58:31 UTC
Created attachment 169088 [details]
A newly inserted slides default shape from slide layout
Comment 4 NISZ LibreOffice Team 2021-01-22 12:59:57 UTC
Created attachment 169089 [details]
A shape after loading the example file

Looks like these are two, slightly different shape objects before saving as PPTX and after.

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 86c8c775bbefe333d684e12c99855a3c1de68051
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: CL
Comment 5 NISZ LibreOffice Team 2021-01-22 13:00:46 UTC
Setting to NEW, although this may be just a consequence of the PPTX conversion.
Comment 6 Commit Notification 2021-04-29 08:49:37 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b6b02e0b4c9d739836e1f61a886ea45b01e6696e

tdf#111903 tdf#137152 PPTX export: fix placeholders

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.