Bug 111903 - FILESAVE: PPT, PPTX: Placeholder text lost upon roundtrip
Summary: FILESAVE: PPT, PPTX: Placeholder text lost upon roundtrip
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ppt, filter:pptx
Depends on:
Blocks: PPTX PPT
  Show dependency treegraph
 
Reported: 2017-08-19 01:08 UTC by Aron Budea
Modified: 2018-10-23 21:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample PPTX with no text (29.53 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2017-08-19 01:08 UTC, Aron Budea
Details
Sample PPT with no text (84.50 KB, application/vnd.ms-powerpoint)
2017-08-19 01:09 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2017-08-19 01:08:26 UTC
Created attachment 135650 [details]
Sample PPTX with no text

- Roundtrip the attached "empty" PPT and PPTX samples in Impress.
- Open the resulting files either in Impress or PowerPoint.

=> The placeholder text boxes are empty (they can't even be selected in Impress). Since they're there when the files are first opened, this is an export issue.

Observed using LO 5.4.0.3 & 4.0.0.3 / Windows 7.
Using the older version results in other issues as well that are gone by now. Possibly the issue with placeholder texts being lost during import was fixed in bug 103792.

The PPT shows additional oddities upon opening, those will be reported in a different ticket.
Comment 1 Aron Budea 2017-08-19 01:09:10 UTC
Created attachment 135651 [details]
Sample PPT with no text
Comment 2 Xisco Faulí 2017-08-19 12:31:19 UTC
Confirmed in

Version: 6.0.0.0.alpha0+
Build ID: a19dc104ec008f0bb44676d63d4764c6d7442a0d
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 QA Administrators 2018-10-22 02:48:47 UTC Comment hidden (obsolete)
Comment 4 Aron Budea 2018-10-23 21:53:06 UTC
Still occurs with 6.2 alpha1 / Windows 7.