Bug 57181 - FILESAVE as pptx: slide names replaced by default names
Summary: FILESAVE as pptx: slide names replaced by default names
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords: dataLoss, filter:pptx
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2012-11-16 07:31 UTC by Rainer Bielefeld Retired
Modified: 2021-06-09 09:00 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-16 07:31:02 UTC
I found that problem during my research for "Bug 49646 - FILEOPEN .pptx in notes view: note and sheet contents shown outside sheet area at top left", problm is reproducible with Attachment 61765 [details]

Steps how to reproduce with parallel installation of Master "LOdev  4.0.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: a2b3ee)]"  {tinderbox: @6, pull time 2012-11-13 06:07:28} on German WIN7 Home Premium (64bit) with separate /4 User Profile for Master Branch:

1. Open new Presentation from LibO Start center
2. Rename first slide to "My Name" after right click on slide in slides pane
3. Close / reopen
   Bug: Slide now shows default name "Slide 1" instead of "My Name"

Already reproducible with LibO 3.3.3, seems that never workked correctly.

Because names are shown correctly when I open att. of Bug 49646 I am sure that it's a FILESAVE problem.

Data loss, so "major"
Comment 1 A (Andy) 2012-11-17 17:23:58 UTC Comment hidden (obsolete)
Comment 2 Rainer Bielefeld Retired 2012-11-17 17:56:31 UTC Comment hidden (obsolete)
Comment 3 Rob Snelders 2012-11-19 22:04:30 UTC
Confirmed with 3.7.0.0-alpha on Ubuntu 12.04 x86_64
Comment 4 A (Andy) 2012-11-22 21:34:12 UTC
(In reply to comment #1)
> not reproducible with 3.6.3.2

Windows 7 - 64Bit
Comment 5 ign_christian 2013-06-03 13:20:59 UTC
It seems getting worst..after doing steps on comment 0 all slides name reset to Slide 1, Slide 2, Slide 3, and so on.

Tested on LO 4.0.4.1 (Win7 32bit)
Comment 6 QA Administrators 2015-03-16 23:57:19 UTC Comment hidden (obsolete)
Comment 7 Jean-Baptiste Faure 2015-03-29 17:20:56 UTC
Still reproducible with LibreOffice 4.4.3.0.0+ built at home under Ubuntu 14.10 x86-64

Workaround: use OpenDocument format (.odp)

Best regards. JBF
Comment 8 tommy27 2016-04-16 07:25:46 UTC Comment hidden (obsolete)
Comment 9 Jean-Baptiste Faure 2016-05-08 06:40:47 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2017-05-22 13:40:55 UTC Comment hidden (obsolete)
Comment 11 Jean-Baptiste Faure 2017-07-23 20:31:58 UTC
Still reproducible with LO 5.4.1.0.0+ built at home under Ubuntu 16.04 x86-64. 

Best regards. JBF
Comment 12 Roman Kuznetsov 2018-09-24 19:58:01 UTC
still repro in

Version: 6.2.0.0.alpha0+
Build ID: 1aa37aa6bee19099b57555a6d839992b054aa405
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-23_10:17:54
Locale: ru-RU (ru_RU); Calc: threaded
Comment 13 Buovjaga 2019-09-23 14:28:19 UTC
Still repro

Version: 6.4.0.0.alpha0+ (x64)
Build ID: e1b51d4588b4b39592bb94dd5bb90de5e04d061e
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-23_09:16:11
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded
Comment 14 i_harshit 2020-06-20 12:12:51 UTC
Still getting reproduced in:

Version: 6.4.4.2 (x64)
Build ID: 3d775be2011f3886db32dfd395a6a6d1ca2630ff
CPU threads: 8; OS: Windows 10.0 Build 18362; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 15 Gabor Kelemen (allotropia) 2021-06-02 20:44:54 UTC
Recently this got better after:

https://git.libreoffice.org/core/+/b6b02e0b4c9d739836e1f61a886ea45b01e6696e

author	Attila Bakos (NISZ) <bakos.attilakaroly@nisz.hu>	Tue Apr 20 13:02:44 2021 +0200
committer	László Németh <nemeth@numbertext.org>	Thu Apr 29 10:48:27 2021 +0200

tdf#111903 tdf#137152 PPTX export: fix placeholders

Now changed slide titles survive the roundtrip. 
Also previously the Outline view got completely empty after roundtrip, now that also survives.

Thanks Attila for solving this as well :)

Note: PPTX does not really store the slide title, that's a LO-thing. Actually the Title boxes content is shown here and in the Navigator/Outline view as well. When modifying any of these, these are not all synchronized in the editor, but after PPTX roundtrip they are.
Comment 16 Timur 2021-06-03 08:29:25 UTC
When opening 47-slide MSO Attachment 61765 [details], in LO 7.2+ I see Slide 1, Objectives,.., Slide 6, Estimation,.., Slide 9, Slide 10,..
Slide 1 name is not read from OO. Slide 6 is a consequence of being the same as of slide 5, change in bug 103347 (solved by renaming same name to Slide X and not to Existing Slide Name (1)).

If saved as PPTX and reopen in LO, Slide 1 name is proper, Slide X remain, but renamed slide is not remembered. In MSO all names are proper (renamed slide still shown as original). 
So I don't see this fixed. 
If it is, please explain.

As for Importance, I set Low-Normal, because as explained this is LO-only feature.

Note that MSO asks to repair PPTX coming from LO-saved Attachment 61765 [details] (another issue, seems not regression).
Comment 17 NISZ LibreOffice Team 2021-06-03 13:49:27 UTC
Ah, so many different issues still... this file if inspected more closely, could also be a treasure trove of "improvement opportunities".

(In reply to Timur from comment #16)
> When opening 47-slide MSO Attachment 61765 [details], in LO 7.2+ I see Slide
> 1, Objectives,.., Slide 6, Estimation,.., Slide 9, Slide 10,..
> Slide 1 name is not read from OO. 

Indeed! But that's a separate pre-existing fileopen issue.
I'll file a new bug for that.

Long (64 char+) slide names are also turned into "Slide N" format, instead of being truncated a bit + numbered; like on the last two slides.
I'll file a new bug about this as well.

Finally there are slides without a Title box, I think for those the default Slide N is viable.
For example in PP the Custom Slide Show dialog refers to the slides by their Title box contents and slides without any Title box appear as Slide N even in PP, such as slide 13, 18, 36, 42 in this example file. 

> Slide 6 is a consequence of being the same
> as of slide 5, change in bug 103347 (solved by renaming same name to Slide X
> and not to Existing Slide Name (1)).
> 

I think we should change that.

> If saved as PPTX and reopen in LO, Slide 1 name is proper, Slide X remain,
> but renamed slide is not remembered. In MSO all names are proper (renamed
> slide still shown as original). 

How did you rename it?
Using the Rename Slide box does not retain the new content, but changing the actual slide title in the editor works after reload and fills the name in the Rename Slide box and Navigator as well.

Since slide name is generated from the Title placeholders in case of PPTX, I think this is as far as we can go. Unless we want to start to explore options to disable the Rename Slide functionality upon opening a PPTX file.

> So I don't see this fixed. 
> If it is, please explain.
> 

This bug was about the view of the LO-saved PPTX in LO, which improved dramatically compared to the former complete loss of generated contents in the Navigator and also in the Overview view.

But there is still some room for improvement, thanks for noticing :).

> As for Importance, I set Low-Normal, because as explained this is LO-only
> feature.
> 
> Note that MSO asks to repair PPTX coming from LO-saved Attachment 61765 [details]
> [details] (another issue, seems not regression).

I can't reproduce this issue anymore. The example file when saved with todays nightly opens fine in my PP 2019:

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 3b57ebb445df8a2bc3d916ea79f8af45e20e4e62
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

However it was indeed repaired if I saved it with 7.1.0.
Comment 18 Timur 2021-06-04 10:53:34 UTC
(In reply to NISZ LibreOffice Team from comment #17)
Thanks for all. 
> How did you rename it?
> Using the Rename Slide box does not retain the new content, but changing the
> actual slide title in the editor works after reload and fills the name in
> the Rename Slide box and Navigator as well.

I used right-click rename, as in Comment 0.
Maybe with that this bug should be NotOutBug or WontFix.
Comment 19 Timur 2021-06-08 07:50:16 UTC
I'm closing as WontFix. If someone can explain better, feel free to mark.