Download it now!
Bug 137248 - Calc - AutoCalculate malfunction, always F9 (ReCalculate) necessary
Summary: Calc - AutoCalculate malfunction, always F9 (ReCalculate) necessary
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All All
: high critical
Assignee: Eike Rathke
URL:
Whiteboard: target:7.1.0 target:7.0.3
Keywords: bibisected, bisected, regression
: 137060 137275 137415 137467 137493 137515 137518 137521 137540 137552 137557 137565 137599 137600 137606 137659 137706 137775 137784 137797 137817 137843 137895 137927 137941 137946 138080 138161 138166 138415 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-10-04 18:13 UTC by Viktor
Modified: 2020-11-23 05:36 UTC (History)
40 users (show)

See Also:
Crash report or crash signature:


Attachments
Demo File from Screenshot (19.11 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-10-04 18:15 UTC, Viktor
Details
Screenshot (25.29 KB, image/png)
2020-10-04 18:15 UTC, Viktor
Details
Testcase "Reproduce-Bug-137248.ods" File (as per comment) (8.80 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-10-05 13:53 UTC, Uwe Auer
Details
Bibisect log (2.75 KB, text/plain)
2020-10-06 20:35 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Viktor 2020-10-04 18:13:53 UTC
Description:
Problem: Since 7.0.2.x Calc has a problem with the automatic ReCalculation if contents/values are changed.
Is there a new setting somewhere that can cause this?

In the settings I have already deactivated the automatic recalculation and reactivated it again incl. restarting LO or the PC. 


See also ASK Libre Post: https://ask.libreoffice.org/de/question/269302/calc-automatische-berechnung-geht-nicht-mehr/




Actual Results:
critical, because not automatically recalculated

Expected Results:
as in previous version, that all formulas (with activated function) are also reliably recalculated.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.0.2.2 (x64) Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994 CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win Locale: de-DE (de_DE); UI: de-DE
Calc: CL

also

Version: 7.1.0.0.alpha0+ (x64)
Build ID: f266feaebea39668392e3a3830e20e4670344658
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL
Comment 1 Viktor 2020-10-04 18:15:15 UTC
Created attachment 166068 [details]
Demo File from Screenshot
Comment 2 Viktor 2020-10-04 18:15:50 UTC
Created attachment 166069 [details]
Screenshot
Comment 3 Telesto 2020-10-05 07:11:12 UTC
Thanks for reporting

It's working fine on MacOS
Version: 7.0.0.2
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 4 Viktor 2020-10-05 09:16:36 UTC
(In reply to Telesto from comment #3)
> Thanks for reporting
> 
> It's working fine on MacOS
> Version: 7.0.0.2
> Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
> CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
> Locale: nl-NL (nl_NL.UTF-8); UI: en-US
> Calc: threaded

you're right.
it seems to be only from version 7.0.2.x and higher
Comment 5 Uwe Auer 2020-10-05 13:51:11 UTC
Reproduced on:

Version: 7.0.2.2, Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 8; OS: Linux 5.3; UI render: default; VCL: kf5
Locale: en-US (en_US.UTF-8); UI: en-US, Calc: threaded

Steps to reproduce.
 - Add a new value into cell B1 of the attached file
 - Check value of cell B4

Result: Value of cell B4 doesn't change automatically, while B2 and B3 recalculate
Expected Result: B4 autocalculates

Reset user profile: Yes
Comment 6 Uwe Auer 2020-10-05 13:53:36 UTC
Created attachment 166090 [details]
Testcase "Reproduce-Bug-137248.ods" File (as per comment)
Comment 7 Telesto 2020-10-05 15:39:13 UTC
(In reply to Uwe Auer from comment #6)
> Created attachment 166090 [details]
> Testcase "Reproduce-Bug-137248.ods" File (as per comment)

Repro
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 7f16cabf00daa30e9284d2fb2494bd341352c25e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

fine in
Version: 7.0.0.0.beta1+ (x64)
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 8 Ming Hua 2020-10-05 21:10:49 UTC
*** Bug 137275 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2020-10-06 20:35:21 UTC
Created attachment 166136 [details]
Bibisect log

Bisected to:
author	Luboš Luňák <l.lunak@collabora.com>	2020-09-04 15:51:07 +0200
committer	Luboš Luňák <l.lunak@collabora.com>	2020-09-10 11:15:47 +0200
commit	4f36f2ccab6286ec09480caea602c0fa19195736 (patch)
tree	0d3156c2f322983fa30d3a6f4600be5102e2718e
parent	3f620e74aa00e34f773d97e9480a6532d9e8863e (diff)
detect if a cell still needs interpreting after Interpret()
https://bugs.documentfoundation.org/attachment.cgi?id=51878
after hard-recalc asserts because of not having cell dependencies
non-dirty for threaded calculation. This is because Interpret()
actually sometimes returns without computing a value for the cell,
e.g. when it backs out because of a need to do iteration.
This is handled when Interpret() is called from InterpretTail(),
but ScDependantsCalculator does not handle this and considers
all cells interpreted, unless it detected a problem.
We've already fixed a number of such bugs, and given that there
are still problematic corner cases after all this time, add code
simply detecting this generic problem and avoiding threading
in that case, with a SAL_WARN. This does not fix the problem
itself, but at least now it's handled.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4f36f2ccab6286ec09480caea602c0fa19195736
Comment 10 Telesto 2020-10-06 20:36:12 UTC
Adding CC: to Luboš Luňák
Comment 11 Telesto 2020-10-08 06:18:52 UTC
*** Bug 137312 has been marked as a duplicate of this bug. ***
Comment 12 Ming Hua 2020-10-12 10:25:49 UTC
*** Bug 137415 has been marked as a duplicate of this bug. ***
Comment 13 Eike Rathke 2020-10-13 19:26:01 UTC
This actually is a repaint problem, Pgdn and PgUp or Shift+Ctrl+R to redraw the grid displays the recalculated value. The commit mentioned somewhere forgets to (re)set a changed flag, a debug version in terminal displays

sc/source/core/data/column4.cxx:1695: Internal error, cell 2!R3C3 failed running Interpret(), not allowing threading

so it hits exactly that changed code.
Comment 14 Eike Rathke 2020-10-13 21:13:40 UTC
Taking.
Comment 15 Eike Rathke 2020-10-13 21:16:35 UTC
Or the dirty cell is interpreted during the next repaint.. however..
Comment 16 Commit Notification 2020-10-14 09:21:20 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/59f86333f3fce091177d1cfb9363aa81686aa497

Resolves: tdf#137248 Fix wrong condition breaking non-group interpret

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Eike Rathke 2020-10-14 09:21:48 UTC
Pending review https://gerrit.libreoffice.org/c/core/+/104289 for 7-0
Comment 18 VLB 2020-10-14 14:34:56 UTC
Will this issue also be resolved for 7.0. *?
Comment 19 Uwe Auer 2020-10-14 17:35:14 UTC
*** Bug 137467 has been marked as a duplicate of this bug. ***
Comment 20 Telesto 2020-10-14 17:40:54 UTC
(In reply to VLB from comment #18)
> Will this issue also be resolved for 7.0. *?

Of course ;-). That's the essence of comment 17
Comment 21 Commit Notification 2020-10-15 07:56:24 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/701008631ee257b4c7714ac9e2689c5ecc45bff8

Resolves: tdf#137248 Fix wrong condition breaking non-group interpret

It will be available in 7.0.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Mike Kaganski 2020-10-16 07:35:10 UTC
*** Bug 137518 has been marked as a duplicate of this bug. ***
Comment 23 Mike Kaganski 2020-10-16 07:35:18 UTC
*** Bug 137515 has been marked as a duplicate of this bug. ***
Comment 24 Mike Kaganski 2020-10-16 07:35:37 UTC
*** Bug 137521 has been marked as a duplicate of this bug. ***
Comment 25 Aron Budea 2020-10-17 15:16:51 UTC
*** Bug 137557 has been marked as a duplicate of this bug. ***
Comment 26 Aron Budea 2020-10-17 15:21:26 UTC
*** Bug 137552 has been marked as a duplicate of this bug. ***
Comment 27 Aron Budea 2020-10-17 16:15:57 UTC
*** Bug 137557 has been marked as a duplicate of this bug. ***
Comment 28 Aron Budea 2020-10-17 18:13:00 UTC
*** Bug 137540 has been marked as a duplicate of this bug. ***
Comment 29 Aron Budea 2020-10-17 18:15:11 UTC
*** Bug 137493 has been marked as a duplicate of this bug. ***
Comment 30 Aron Budea 2020-10-17 18:16:42 UTC
*** Bug 137060 has been marked as a duplicate of this bug. ***
Comment 31 andristf 2020-10-19 10:54:55 UTC
Downloaded 7.0.3 Build b6be59636a142f98970d39aadff8445e1d0c39b7
This fixed my problem with not automatically updating some cells.
Many thanks
Comment 32 Stefan_Lange_KA@T-Online.de 2020-10-19 11:11:13 UTC
see comment 4 of bug 137060 (succesful test with LOdev 7.0.3 and LOdev 7.1.0): The problem is solved by the patch!
Comment 33 Xisco Faulí 2020-10-19 14:27:57 UTC
Setting to VERIFIED
Comment 34 m.a.riosv 2020-10-19 17:45:03 UTC
*** Bug 137600 has been marked as a duplicate of this bug. ***
Comment 35 Eike Rathke 2020-10-19 17:54:01 UTC
*** Bug 137599 has been marked as a duplicate of this bug. ***
Comment 36 Ming Hua 2020-10-20 04:53:02 UTC
*** Bug 137606 has been marked as a duplicate of this bug. ***
Comment 37 Xisco Faulí 2020-10-21 15:39:40 UTC
*** Bug 137659 has been marked as a duplicate of this bug. ***
Comment 38 Xisco Faulí 2020-10-22 14:19:25 UTC
*** Bug 137565 has been marked as a duplicate of this bug. ***
Comment 39 Eike Rathke 2020-10-23 13:16:23 UTC
*** Bug 137706 has been marked as a duplicate of this bug. ***
Comment 40 Viktor 2020-10-23 16:52:20 UTC
the failure seems to be fixed for me, thx a lot ☺
AutoCalc is working for me. will do some more test under different scenarios.
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Tested under:
Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬▬
Comment 41 Buovjaga 2020-10-25 06:12:36 UTC
*** Bug 125052 has been marked as a duplicate of this bug. ***
Comment 42 Ming Hua 2020-10-26 18:34:21 UTC
*** Bug 137775 has been marked as a duplicate of this bug. ***
Comment 43 Ming Hua 2020-10-27 06:09:55 UTC
*** Bug 137784 has been marked as a duplicate of this bug. ***
Comment 44 Xisco Faulí 2020-10-27 12:31:01 UTC
*** Bug 137797 has been marked as a duplicate of this bug. ***
Comment 45 Uwe Auer 2020-10-28 12:38:48 UTC
*** Bug 137817 has been marked as a duplicate of this bug. ***
Comment 46 Mike Kaganski 2020-10-29 04:32:30 UTC
*** Bug 137843 has been marked as a duplicate of this bug. ***
Comment 47 Uwe Auer 2020-10-31 10:19:48 UTC
*** Bug 137895 has been marked as a duplicate of this bug. ***
Comment 48 kchingx 2020-10-31 10:32:10 UTC
how can this be a duplicate when it is not working on libre 7.0.2.2?
it was working on 7.0.1 upon upgrade it did not work anymore.
so do i downgrade?
Comment 49 Viktor 2020-10-31 10:58:43 UTC
(In reply to kchingx from comment #48)
> how can this be a duplicate when it is not working on libre 7.0.2.2?
> it was working on 7.0.1 upon upgrade it did not work anymore.
> so do i downgrade?

upgrade to newest Version 7.0.3.1 and check your scenario again.
If the BUG is still present you can give a feedback again please.
Comment 50 Uwe Auer 2020-10-31 11:01:30 UTC
(In reply to kchingx from comment #48)
> how can this be a duplicate when it is not working on libre 7.0.2.2?
> it was working on 7.0.1 upon upgrade it did not work anymore.
> so do i downgrade?


**Your** bug report at https://bugs.documentfoundation.org/show_bug.cgi?id=137895 is a duplicate report of this one, because this one already describes what you reported once more and if you carefully read this report, you'll notice that 7.0.3 (which is already released) will fix the bug and hence your problem reported in your report.
Comment 51 Ming Hua 2020-11-02 09:00:31 UTC
*** Bug 137927 has been marked as a duplicate of this bug. ***
Comment 52 Aron Budea 2020-11-02 17:26:52 UTC
*** Bug 137941 has been marked as a duplicate of this bug. ***
Comment 53 Xisco Faulí 2020-11-02 20:49:10 UTC
*** Bug 137946 has been marked as a duplicate of this bug. ***
Comment 54 m.a.riosv 2020-11-11 08:55:07 UTC
*** Bug 138080 has been marked as a duplicate of this bug. ***
Comment 55 m.a.riosv 2020-11-12 13:06:27 UTC
*** Bug 138161 has been marked as a duplicate of this bug. ***
Comment 56 Uwe Auer 2020-11-12 17:57:22 UTC
*** Bug 138166 has been marked as a duplicate of this bug. ***
Comment 57 Ming Hua 2020-11-23 05:36:40 UTC
*** Bug 138415 has been marked as a duplicate of this bug. ***