Bug 138186 - FILEOPEN XLSX Bar chart X axis labels not wide enough to be readable
Summary: FILEOPEN XLSX Bar chart X axis labels not wide enough to be readable
Status: RESOLVED DUPLICATE of bug 138184
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard:
Keywords: bibisected, bisected
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-11-13 12:37 UTC by NISZ LibreOffice Team
Modified: 2020-11-17 09:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the original document side by side in Excel and Calc 6.4 (110.33 KB, image/png)
2020-11-13 12:37 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-11-13 12:37:39 UTC
Created attachment 167270 [details]
Screenshot of the original document side by side in Excel and Calc 6.4

attachment #167267 [details] contains a bar chart with long X axis labels. 
When opened in Calc the area for axis labels is very narrow and the labels do not fit.

Steps to reproduce:
    1. Open attachment #167267 [details] from bug #138184 in LO 7.0

Actual results:
Area for axis labels is very narrow see attachment #167268 [details] from bug #138184 

Expected results:
Readable axis labels in a wide enough area.

LibreOffice details:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

In 6.4 the labels were flowing out of the chart area. Now they don’t flow out, but they are only partially visible.

Additional Information: 

Bibisected using bibisect-win64-7.0 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=7c300296dd727990455449b19b111b9fc49eadad 
author	Balazs Varga <balazs.varga991@gmail.com>	2020-03-02 13:55:35 +0100
committer	László Németh <nemeth@numbertext.org>	2020-03-09 11:57:29 +0100
tdf#131060 tdf#117088 chart view: fix missing or truncated axis labels

Adding CC to: Balázs Varga
Comment 1 Balázs Varga 2020-11-17 09:22:34 UTC
I saw this in the chart XML:

<c:plotArea>
      <c:layout>
        <c:manualLayout>
          <c:layoutTarget val="inner" />
          <c:xMode val="edge" />
          <c:yMode val="edge" />
          <c:x val="2.253060741751408E-2" />
          <c:y val="7.1028129547703697E-2" />
          <c:w val="0.91217699669462815" />
          <c:h val="0.84074036823592335" />
        </c:manualLayout>
      </c:layout>

We display the chart plot area, according these values as required by the OOXML standard.

<c:x val="2.253060741751408E-2" /> (X position of left corner of plot area)
<c:h val="0.84074036823592335" /> (width of plot area)

However, the MSO "lies" and display the plot area nicer, by ignoring the own XML.
Comment 2 Balázs Varga 2020-11-17 09:24:57 UTC

*** This bug has been marked as a duplicate of bug 138184 ***