Bug 138194 - FILEOPEN XLSX Rotated X axis labels are not wrapped
Summary: FILEOPEN XLSX Rotated X axis labels are not wrapped
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Tünde Tóth
URL:
Whiteboard: target:7.2.0 target:7.1.0.0.beta2
Keywords:
: 135757 (view as bug list)
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2020-11-13 14:24 UTC by NISZ LibreOffice Team
Modified: 2021-02-23 15:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file from Excel (20.49 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2020-11-13 14:24 UTC, NISZ LibreOffice Team
Details
Screenshot of the original document side by side in Excel and Calc (130.04 KB, image/png)
2020-11-13 14:25 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-11-13 14:24:47 UTC
Created attachment 167275 [details]
Example file from Excel

Attached file contains simple bar charts with long data labels, rotated to 0 – 90 – 270 degrees in Excel.
When opened the long labels are not broken into multiple lines and flow out of the charts area.

Steps to reproduce:
    1. Open attached file

Actual results:
Axis labels flow out of the chart area.

Expected results:
Axis labels are broken to multiple lines and fit inside the chart area.

LibreOffice details:
Version: 7.1.0.0.alpha1+ (x64)
Build ID: 693553210828538680408832157faad9654758c8
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Also happens in:
Version: 6.3.0.4 (x86)
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

Version: 6.0.0.3
Build ID: 64a0f66915f38c6217de274f0aa8e15618924765
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: en-US (hu_HU); Calc: CL

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: hu-HU (hu_HU)

Verzió: 4.1.0.4
Build az.: 89ea49ddacd9aa532507cbf852f2bb22b1ace28
Comment 1 NISZ LibreOffice Team 2020-11-13 14:25:07 UTC
Created attachment 167276 [details]
Screenshot of the original document side by side in Excel and Calc
Comment 2 Commit Notification 2020-11-24 09:46:18 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/21620f9d2f50e66dffc45a5afb539edb8d54434c

tdf#138194 Chart OOXML import: set text break to true

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2020-11-24 14:02:01 UTC
Tünde Tóth committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/189a12a1d4d96b8656bd1a0588e1bb7ddd167f40

tdf#138194 Chart OOXML import: set text break to true

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Tünde Tóth 2020-11-27 09:49:05 UTC
*** Bug 135757 has been marked as a duplicate of this bug. ***
Comment 5 NISZ LibreOffice Team 2020-12-30 10:40:37 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 368c56144aab5794c39d5bc2082d9b3d6d7cebdb
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded

Thanks for fixing!