Bug 138247 - Calc UI: Make the comment UI more consistent
Summary: Calc UI: Make the comment UI more consistent
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2020-11-15 23:48 UTC by Muhammad Rivan
Modified: 2021-02-15 16:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots of Calc and Impress (253.95 KB, application/zip)
2020-11-15 23:48 UTC, Muhammad Rivan
Details
LO Calc Comment Mockup (4.03 MB, video/mp4)
2020-12-30 03:15 UTC, Muhammad Rivan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Muhammad Rivan 2020-11-15 23:48:18 UTC
Created attachment 167324 [details]
Screenshots of Calc and Impress

The Calc comment discoverability is not good. Newcomers will normally show/hide a comment by clicking a comment overlay button, not by right-clicking and find the hide/show menu. It would be great if Calc use Impress comment UI to make the discoverability of this feature better and make the UI is consistent with other LibreOffice apps
Comment 1 Roman Kuznetsov 2020-11-16 23:17:37 UTC
Calc has different workflow than Impress. How many hours did you work in Calc?
In Impress you can insert a comment in any place of the slide and then you can move comment's marker to any place of the slide, but in Calc you insert a comment into specific cell and you cannot move it to another cell (without some workaround)

-1 from me
Comment 2 Muhammad Rivan 2020-11-16 23:50:12 UTC
The overlay "button" alone doesn't have to be moveable/draggable, which means the position is fixed. The shape of it also doesn't have to be the same as the overlay comment "button" of Impress.

Let's focus on UX. Make the UX more consistent and discoverable.
Comment 3 Heiko Tietze 2020-11-17 09:09:51 UTC
(In reply to Muhammad Rivan from comment #2)
> Let's focus on UX. Make the UX more consistent and discoverable.

I can follow Roman's argument, comments in Draw/Impress needs to be placed with coordinates while Calc is cell- and Writer word-based. What exactly do you want to be consistent?
Comment 4 Muhammad Rivan 2020-12-30 03:15:03 UTC
Created attachment 168565 [details]
LO Calc Comment Mockup

Hi! I managed to make a mockup about this :)
Comment 5 QA Administrators 2020-12-31 03:48:19 UTC Comment hidden (obsolete)
Comment 6 Heiko Tietze 2021-01-12 10:30:49 UTC
Summary is a bit misleading. You don't seek for consistency with other modules but a) dislike the disappearing of empty comments and b) the way how comments are shown.

For a) we have bug 73446 and bug 134825 (but see also 83575). If we keep empty comments you need to introduce a method to delete, for example per context menu- and many users will complain about the two additional clicks. Or per small close button on top right, which might annoy people with small screens. Regarding b) you run into the same trouble with this "large" comment button. And consider a large sheet with many comments where your big button significantly adds clutter. Or two adjacent cells with comments... 

But I agree with the issues. We could introduce options and make the application a it responsive where large screens show bigger controls.
Comment 7 Heiko Tietze 2021-02-11 14:50:54 UTC
From the design meeting

   + disappearing comments is by design, see other tickets
   + check View > Comments to make them always visible
(this might solve the main concerns)
   + acting like a shape allows for easy moving
   + comments in post-it style look good but lack the option
     to move, take a lot of space making it hard to comment 
     adjacent cells

I recommend to resolve WF but keep it for a while to get more opinions.