Bug 138465 - FILEOPEN DOCX Formula appears squashed until touched
Summary: FILEOPEN DOCX Formula appears squashed until touched
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:docx, regression
: 141204 (view as bug list)
Depends on:
Blocks: DOCX-OLE-Objects
  Show dependency treegraph
 
Reported: 2020-11-24 16:07 UTC by NISZ LibreOffice Team
Modified: 2021-03-23 17:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the original document side by side in Word and Writer (140.33 KB, image/png)
2020-11-24 16:07 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2020-11-24 16:07:11 UTC
Created attachment 167540 [details]
Screenshot of the original document side by side in Word and Writer

Attachment #108105 [details] from bug #85230 started to show some of the equations vertically squashed.
Opening the equations for editing and closing them unchanged restores their original height.

Steps to reproduce:
    1. Open attachment #108105 [details] 
    2. Look at the equations marked by (3) (5)

Actual results:
Vertically squashed.

Expected results:
Normal height.

LibreOffice details:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: f313e27fb7f2d42247407e26e16f264e30f87ca5
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL

Not yet in:
Version: 7.0.0.3 (x64)
Build ID: 8061b3e9204bef6b321a21033174034a5e2ea88e
CPU szálak: 4; OS: Windows 6.3 Build 9600; Felületmegjelenítés: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: CL

Additional Information: 

Bibisected using bibisect-win64-7.1 to:
URL: https://cgit.freedesktop.org/libreoffice/core/commit/?id=636d16efe45a55c1a5a7a451c46fbb8618bf0393

author
Attila Bakos <bakos.attilakaroly@nisz.hu> Thu Aug 13 16:37:58 2020 +0200 
committer
László Németh <nemeth@numbertext.org> Thu Aug 27 11:29:51 2020 +0200 

tdf#135653 OOXML import: fix OLE background color

Adding CC to:  Attila Bakos
Comment 1 V Stuart Foote 2020-11-24 18:08:28 UTC
Confrim on Windows 10 64-bit (2004) with
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 9c355a82881d8e13d6bc732e13b28d62962bf245
CPU threads: 4; OS: Windows 10.0 Build 19041; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

However, once the DOCX has been opened, and the formulas 'touched' (open the OLE to allow sm to parse) a round trip back through OOXML/Office 365 no longer has the issue.

So this seems to me *just* an import filter issue in parsing the Office Math MarkUp Language (OMML) into our MathML compliant StarMath.
Comment 2 László Németh 2021-02-25 15:19:39 UTC

*** This bug has been marked as a duplicate of bug 136570 ***
Comment 3 NISZ LibreOffice Team 2021-03-09 09:28:30 UTC
Verified in:

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 72841008bf422dfd8553240b3a78f0474d03523c
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded Jumbo
Comment 4 Juha 2021-03-23 17:00:21 UTC
*** Bug 141204 has been marked as a duplicate of this bug. ***