Bug 136570 - FILEOPEN: OLE objects containing links to other documents are blurred
Summary: FILEOPEN: OLE objects containing links to other documents are blurred
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0 target:7.1.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks: SoftEdgeFallout
  Show dependency treegraph
 
Reported: 2020-09-08 12:27 UTC by Xisco Faulí
Modified: 2021-03-09 16:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
How it looks in LibreOffice 7.1 master (14.68 KB, image/png)
2020-09-08 12:27 UTC, Xisco Faulí
Details
How it should look like (14.55 KB, image/png)
2020-09-08 12:27 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2020-09-08 12:27:06 UTC
Created attachment 165269 [details]
How it looks in LibreOffice 7.1 master

Steps to reproduce:
1. Open attachment 42154 [details] from bug 33237

-> The text in the OLE object is blurred. See screenshot

Reproduced in

Version: 7.1.0.0.alpha0+
Build ID: 6b2eff7d69c6e14d89dd33eaa58c01d82c541266
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2020-09-08 12:27:28 UTC
Created attachment 165270 [details]
How it should look like
Comment 2 Xisco Faulí 2020-09-08 12:28:27 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=bf021c369f2306ee507da9bd3cc4cd10ac5d234c

author	Mike Kaganski <mike.kaganski@collabora.com>	2020-08-13 18:12:37 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2020-08-14 01:00:04 +0200
commit	bf021c369f2306ee507da9bd3cc4cd10ac5d234c (patch)
tree	a3dc2552801cfe31cb524c6f375980eaa48e844b
parent	56d5531373cf0588e02c254ea8ffa00221c8342b (diff)
tdf#135500: always use transparent and clear content vdev in impBufferDevice

Bisected with: bibisect-linux64-7.1

Adding Cc: to Mike Kaganski
Comment 3 Mike Kaganski 2020-09-09 10:36:20 UTC
For myself: There was also https://git.libreoffice.org/core/+/636d16efe45a55c1a5a7a451c46fbb8618bf0393 for tdf#135653 in between, that changed the scale at which the OLE pictogram is shown. I'd say it's a regression - it introduced scaling to originally pixel-perfect image...
Comment 4 Xisco Faulí 2020-09-09 16:50:18 UTC
attachment 74427 [details] from bug 60491 is also affected by this issue
Comment 5 Gabor Kelemen 2020-09-24 17:35:43 UTC
I just bibisected this on 7.1 repo and it points to:

https://git.libreoffice.org/core/+/636d16efe45a55c1a5a7a451c46fbb8618bf0393

@Attila could you please take a look?
Comment 6 László Németh 2021-02-25 15:19:39 UTC
*** Bug 138465 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2021-02-25 15:24:48 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ca7855c24af858f52a11a593761ee9e6b9d6ba79

tdf#136570 OOXML import: fix height of OLE objects

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-03-01 11:59:02 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/2b20826a6a5d06a9e47c90918375a40465567716

tdf#136570 OOXML import: fix height of OLE objects

It will be available in 7.1.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2021-03-02 10:40:52 UTC
Hi Attila,
I do confirm the problem with the OLE objects' size is fixed in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 94283af977246c70dbed4452d197b003d8bb14b9
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Do you also plan to fix the blurred text? otherwise you should unassign from this bug
Comment 10 Attila Bakos (NISZ) 2021-03-02 11:35:40 UTC
Hello Xisco! 

Thank you for confirming the fix about the size. Well, I don' plan in now maybe later, so rather unassign myself.
Comment 11 Xisco Faulí 2021-03-09 16:18:55 UTC
This issue is fixed by

author  Luboš Luňák <l.lunak@collabora.com>     2021-03-04 15:35:44 +0100
committer       Luboš Luňák <l.lunak@collabora.com>     2021-03-08 13:46:36
+0100
commit  6b8c157a0b4f37a09fdbf656919b2df06a3abc3e (patch)
tree    52451b3b5152511cb4fb68a2f09867bc9db85592
parent  db2e9619397f1e53232824a649b5ad0ba3dd368a (diff)
make RenderMaskPrimitive2DPixel() clip using clipping (tdf#140797)