Bug 138471 - Clicking "Page Margins" button sets left and right margins to 0
Summary: Clicking "Page Margins" button sets left and right margins to 0
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.1.0.0.beta2 target:7.2.0 tar...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-24 21:47 UTC by Eric Carlson
Modified: 2020-12-02 10:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Carlson 2020-11-24 21:47:46 UTC
Description:
When in the Tabbed user interface, clicking the "Page Margins" button under the Layout tab immediately sets the left and right margins to 0.

Steps to Reproduce:
1. Enable Tabbed user interface
2. Click on the Layout tab
3. Click on Page Margins

Actual Results:
Left and right margins are changed to 0.

Expected Results:
All margins should retain their current values until the user overwrites them.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Ubuntu package version: 1:7.0.2-ubuntu1
UI Render: default; VCL: gtk3
Comment 1 Justin L 2020-11-28 19:17:17 UTC
Using bibisect-linux-64-7.0, I reproduced this and narrowed it down to
bibisect commit 3f190bd8a811e2b913bf2f2017c6222544762276
author	Caolán McNamara on 2020-05-22 22:01:01 +0200
commit	ec11b7330fab72dc56d847c7c3691fddbb18096e
Related: tdf#133189 values not updated when units changed

However, I can't reproduce in bibisect-linux-7.1, not even on "oldest". So not sure exactly what is going on here. It might already be fixed.
Comment 2 Justin L 2020-11-30 06:23:39 UTC
I couldn't find any connection
-no further changes in sw/source/uibase/sidebar/PageFormatPanel.cxx.
-no other bug reports tied to ec11b7330fab72dc56d847c7c3691fddbb18096e
-no bug reports linked to bug 133189.

AFAIK from bibisect-linux-64-7.0, it has not been fixed in 7.0.x yet, so I'm CC'ing Caolán.
Comment 3 Caolán McNamara 2020-12-01 13:00:45 UTC
I had difficultly reproducing this initially. Because if I click on "page margins" I get a drop down menu with some options and 4 spinbuttons that show the current margins. In my case I had 2 cm, 2 cm, 2 cm, 2 cm.

but if I set my locale to en_US.UTF-8 then I can reproduce it.
Comment 4 Commit Notification 2020-12-02 08:45:21 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/73cebb561737947511ff489891e61b1e1f8f7b0e

tdf#138471 wrong adjustment used for spinbutton

It will be available in 7.1.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2020-12-02 08:45:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b99771a0bf090fd58b14d03dc998d3a9cf201719

tdf#138471 wrong adjustment used for spinbutton

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Caolán McNamara 2020-12-02 08:47:19 UTC
fixed in master and 7-1, backport to 7-0 in gerrit
Comment 7 Commit Notification 2020-12-02 10:27:03 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/e86ec6f77756045a4f8147f006018da93b70b159

tdf#138471 wrong adjustment used for spinbutton

It will be available in 7.0.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.