Bug 138785 - Empty frames after deleting an image and (auto-saving the file) (track changes involved)
Summary: Empty frames after deleting an image and (auto-saving the file) (track change...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.0.beta1+
Hardware: All All
: high major
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.2.0 target:7.1.3
Keywords: bibisected, bisected, regression
: 135096 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-12-09 19:04 UTC by Telesto
Modified: 2021-04-27 06:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2020-12-09 19:04:45 UTC
Description:
Empty frames after deleting an image and (auto-saving the file) (track changes involved)

Steps to Reproduce:
1. Open attachment 165730 [details]
2. Scroll through the document.. all images present
3. Delete the image on the first page
4. File save As - Type a file name
5. Scroll through the file.. empty frames

Likely a duplicate.. as I have reported number of those.. 

Actual Results:
Empty frames

Expected Results:
No so


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.0.0.alpha0+ (x64)
Build ID: 796c7f612603490dda9277ced0f6ab3cce3bc116
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2020-12-09 19:09:27 UTC
Also in
Version: 7.1.0.0.beta1+ (x64)
Build ID: f9fab4203c1aa0b9a3f27ce2713b6d5addc7df19
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: nl-NL
Calc: CL

Not in
Version: 7.0.0.0.beta1+ (x64)
Build ID: 2891e91a513520d68ea2b8c59c14335861a15253
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 2 Xisco Faulí 2020-12-10 12:46:42 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b9ef71476fd70bc13f50ebe80390e0730d1b7afb

author	Michael Stahl <Michael.Stahl@cib.de>	2020-11-13 20:52:28 +0100
committer	Michael Stahl <michael.stahl@cib.de>	2020-11-16 16:51:19 +0100
commit	b9ef71476fd70bc13f50ebe80390e0730d1b7afb (patch)
tree	de2c044f51addf5a7ccc32f0d3289db919d5b19e
parent	094ee3955ee81e1bc631d50cc216cbb17a777839 (diff)
tdf#134298 sw: layout: remove left-over page frame without content

Bisected with: bibisect-linux64-7.1

Adding Cc: to Michael Stahl
Comment 3 Telesto 2020-12-12 22:23:52 UTC
Kind of in dubio about the proper proceeding... kind of dislike this going into 7.0.4.2

OTOH 7.0.4.2 already RC2 stage.. and doing RC3 only reverting the commit in question worth it? People slightly moving to 7.0 I assume.

Luckily not my call
Comment 4 Telesto 2020-12-14 09:19:07 UTC
*** Bug 135096 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2021-04-20 13:20:50 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e656cf2a71e738c282abcd0d610e724b955f274a

tdf#138785 sw: fix mis-positioned as-char flys when deleting empty page

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Stahl (allotropia) 2021-04-22 16:54:13 UTC
the images were all one page above where they should be

fixed on master
Comment 7 Commit Notification 2021-04-23 15:04:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-1":

https://git.libreoffice.org/core/commit/c79b92edfb5e650fff76688998cf4f0bbd08d2a4

tdf#138785 sw: fix mis-positioned as-char flys when deleting empty page

It will be available in 7.1.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Xisco Faulí 2021-04-26 15:26:33 UTC
Verified in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 5366811e24532ae0f6b124a2eb85021b59d47f4b
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Michael Stahl, thanks for fixing this issue!!
Comment 9 Commit Notification 2021-04-27 06:54:49 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-1-3":

https://git.libreoffice.org/core/commit/6d86a908eb08d39236d700b2797c66ff7ae4a78a

tdf#138785 sw: fix mis-positioned as-char flys when deleting empty page

It will be available in 7.1.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.