Bug 138792 - Feature request in the properties dialogue to allow XMP or Dublin Core attributes to be entered and then exported to PDF
Summary: Feature request in the properties dialogue to allow XMP or Dublin Core attrib...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Sarper Akdemir (allotropia)
URL: https://www.pdfa.org/wp-content/until...
Whiteboard: target:24.2.0 target:24.8.0
Keywords: accessibility
: 157455 (view as bug list)
Depends on:
Blocks: PDF-Accessibility
  Show dependency treegraph
 
Reported: 2020-12-10 08:15 UTC by juergenkohler23
Modified: 2024-02-29 13:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file with a bunch of properties filled (28.56 KB, application/vnd.oasis.opendocument.text)
2023-01-11 10:29 UTC, Gabor Kelemen (allotropia)
Details
The example file exported to PDF (30.21 KB, application/pdf)
2023-01-11 10:30 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the PDF in PDF Metadata Editor and the original file in Writer (73.46 KB, image/png)
2023-01-11 10:47 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the PDF in PDF Metadata Editor and the original file in Writer - PDF tab (53.23 KB, image/png)
2023-01-11 10:53 UTC, Gabor Kelemen (allotropia)
Details
Screenshot of the PDF in PDF Metadata Editor and the original file in Writer - DC tab (69.29 KB, image/png)
2023-01-11 12:11 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description juergenkohler23 2020-12-10 08:15:37 UTC
Description:
In order to ensure the accessibility of PDF documents, it is necessary to be able to edit corresponding XMP metadata; e.g. add a PDF/UA label and add the title in the XMP data.

Steps to Reproduce:
-

Actual Results:
It is not possible to edit XMP metadata attributes.

Expected Results:
It is possible to edit XMP metadata attributes.


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 Regina Henschel 2020-12-25 23:45:01 UTC
I have added this to bug 139007 "[META] PDF accessibility".

It is a valid enhancement request.

On ODF file format this is likely related to bug 30709.
Comment 2 Samuel Mehrbrodt (allotropia) 2022-11-21 09:03:22 UTC
The properties from File->Properties are already exported to PDF as metadata.
Can you name some specific properties which are missing?
Comment 3 Samuel Mehrbrodt (allotropia) 2022-11-21 09:35:13 UTC
> add a PDF/UA label

PAC reports we already add this label.
Comment 4 László Németh 2022-11-21 10:40:38 UTC
Likely this is about extra metadata, i.e. XMP PDF, XMP Dublin Core and XMP Rights metadata, as implemented in PDF Metadata Editor (http://broken-by.me/pdf-metadata-editor/).
Comment 5 Gabor Kelemen (allotropia) 2023-01-11 10:29:33 UTC
Created attachment 184579 [details]
Example file with a bunch of properties filled
Comment 6 Gabor Kelemen (allotropia) 2023-01-11 10:30:03 UTC
Created attachment 184580 [details]
The example file exported to PDF

from recent master
Comment 7 Gabor Kelemen (allotropia) 2023-01-11 10:47:54 UTC
Created attachment 184582 [details]
Screenshot of the PDF in PDF Metadata Editor and the original file in Writer

The standard file describes the following Basic XMP properties:

xmp:CreateDate 
xmp:CreatorTool
xmp:MetadataDate
xmp:ModifyDate

According to the Metadata Editor tool, some of these are already exported:
CreatorTool -> Writer, correct
CreateDate -> 10:38, incorrect: this value is should be the Modified date in the Properties dialog
ModifyDate -> Not exported
MetadataDate -> Not exported, standard says: 
The date and time that any metadata for
this resource was last changed. It should
be the same as or more recent than
xmp:ModifyDate.

So probably the greater of "Modified date" and "Last printed" in LO.

No need to add new UI fields for covering this, export needs to be changed.
Comment 8 Gabor Kelemen (allotropia) 2023-01-11 10:53:38 UTC
Created attachment 184586 [details]
Screenshot of the PDF in PDF Metadata Editor and the original file in Writer - PDF tab

Next the standard defines "Adobe PDF Schema" properties:

pdf:Keywords
pdf:PDFVersion
pdf:Producer

According to the Metadata Editor tool:

Keywords: exported properly
Producer: LibreOffice 7.5 is correct
PDFVersion: missing. The standard says:
The PDF file version
(for example: 1.0, 1.3,
and so on).

No need to add new UI to cover these, only the PDFVersion needs to be exported.
Comment 9 Gabor Kelemen (allotropia) 2023-01-11 12:11:52 UTC
Created attachment 184587 [details]
Screenshot of the PDF in PDF Metadata Editor and the original file in Writer - DC tab

The standard defines the list of Dublin Core attributes:

dc:contributor
dc:coverage
dc:creator
dc:date
dc:description
dc:format
dc:identifier
dc:language
dc:publisher
dc:relation
dc:rights
dc:source
dc:subject
dc:title
dc:type

Of these the Title, Description and Creators fields are already filled according to the Metadata Editor.

For the other 12 DC attributes (11 if we suppose dc:format can be filled automatically) we should probably add new UI, ODF storage and XMP:DC export functionality.
Comment 10 Gabor Kelemen (allotropia) 2023-01-11 12:15:16 UTC
Setting to NEW, needed info was provided.
Comment 11 Commit Notification 2023-09-04 18:53:53 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/07ac61f2c67020ad2941462ea7081f06495bcb92

tdf#138792: PDF export: fix date of xmp:CreateDate

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2023-09-04 18:53:55 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/7803c5749365c6dca6583708c14d6229c9659572

tdf#138792: PDF export: export metadata xmp:ModifyDate, xmp:MetadataDate

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2023-09-04 18:53:57 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a45f72b8122d3bb4c0d5ac4252cf7e5a25d52291

tdf#138792: PDF export: export metadata pdf:PDFVersion

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2023-09-04 18:55:00 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/0deea02b1da1001fa497dc5afa5e43207af491d5

tdf#138792: PDF export: add batch of dublin core attributes

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2023-09-04 18:55:02 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b273a0c1527193e21fbd0ccbc23853205f90056b

tdf#138792: PDF export: export metadata dc:format

It will be available in 24.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Stéphane Guillou (stragu) 2023-10-10 12:17:18 UTC
*** Bug 157455 has been marked as a duplicate of this bug. ***
Comment 17 Commit Notification 2024-01-23 12:45:44 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3a20c691ab1d6a16ad0fc144926b22c098552be4

tdf#138792: PDF export: export metadata dc:date

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.