Bug 138930 - EDITING: Comments cannot be resolved in Word 2007-365 format Writer files
Summary: EDITING: Comments cannot be resolved in Word 2007-365 format Writer files
Status: RESOLVED DUPLICATE of bug 122222
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.0.3.1 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-15 09:26 UTC by Federico Kereki
Modified: 2021-04-13 06:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A Word 2007-365 file with comments that cannot be resolved (19.16 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-12-15 09:27 UTC, Federico Kereki
Details
An ODT file with comments that can be resolved (11.87 KB, application/vnd.oasis.opendocument.text)
2020-12-15 09:31 UTC, Federico Kereki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Kereki 2020-12-15 09:26:02 UTC
Description:
I have a Word 2007-365 file. I can edit it with LibreOffice writer, but if I mark comments as RESOLVED and I save the file, if you load it again later, comments are still unresolved. 

Steps to Reproduce:
1.Open the attached document
2.Mark any of the comments as RESOLVED
3.Save the document
4.Close the file
5.Open the file again

Actual Results:
After step 5, the comments will appear as unresolved again.

Expected Results:
The comments should appear as resolved.


Reproducible: Always


User Profile Reset: No



Additional Info:
This happens only with Word format files. If the original file is an ODT, then comments are marked as resolved, and do work perfectly well. If the original file is Word, in that case comments cannot be marked as resolved.
Comment 1 Federico Kereki 2020-12-15 09:27:29 UTC
Created attachment 168184 [details]
A Word 2007-365 file with comments that cannot be resolved

If you resolve the comments in this file, save it, close it, and reopen it, the comments will still appear as unresolved.
Comment 2 Federico Kereki 2020-12-15 09:31:16 UTC
Created attachment 168185 [details]
An ODT file with comments that can be resolved

If you resolve the comments in this file, save it, close it, open it again, the comments will be unresolved.
Comment 3 Federico Kereki 2020-12-15 09:33:03 UTC
ERRATA: in the ODT file, if you reopen it, comments will be RESOLVED, correctly.
Comment 4 mulla.tasanim 2020-12-15 16:42:45 UTC
Thank you for reporting the bug.

ODT file set the status resolved correctly where as word format file loses status resolved after saving it

I can confirm that the bug is present in,

Version: 7.0.3.1 (x64)
Build ID: d7547858d014d4cf69878db179d326fc3483e082
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Version: 7.2.0.0.alpha0+ (x64)
Build ID: 761a672d62df1891b9f4f367a499b220ab2b33fa
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 5 Buovjaga 2020-12-16 19:02:45 UTC

*** This bug has been marked as a duplicate of bug 134265 ***
Comment 6 Mike Kaganski 2021-04-13 06:23:32 UTC

*** This bug has been marked as a duplicate of bug 122222 ***