Bug 122222 - FILEOPEN DOCX The comment marked as done property is lost in Writer
Summary: FILEOPEN DOCX The comment marked as done property is lost in Writer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Mike Kaganski
URL:
Whiteboard: target:7.2.0
Keywords:
: 134265 137053 138930 143608 (view as bug list)
Depends on:
Blocks: DOCX-Comments
  Show dependency treegraph
 
Reported: 2018-12-20 12:41 UTC by NISZ LibreOffice Team
Modified: 2021-07-30 09:02 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of the original document side by side in Word and Writer. (64.67 KB, image/png)
2018-12-20 12:43 UTC, NISZ LibreOffice Team
Details
Example file from Word (19.37 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-12-20 12:43 UTC, NISZ LibreOffice Team
Details
The original file saved by Writer (14.32 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-12-20 12:44 UTC, NISZ LibreOffice Team
Details
xml file extracted from the example docx (1.24 KB, text/xml)
2018-12-20 14:15 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2018-12-20 12:41:23 UTC
Description:
The marked comment as done created with Microsoft Word 2013 is editable when the document is opened in LibreOffice Writer.

Steps to Reproduce:
    1. Create a new document in Microsoft Word 2013.
    2. Insert a comment.
    3. Right-click the comment.
    4. Click Mark Comment Done.
    5. Save the file as DOCX.
    6. Open the same file in LibreOffice Writer.
    7. Compare the original file opened in Word and Writer.

Actual Results:
The comment is editable.

Expected Results:
The comment shouldn’t be modified.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 NISZ LibreOffice Team 2018-12-20 12:43:33 UTC
Created attachment 147696 [details]
Screenshot of the original document side by side in Word and Writer.
Comment 2 NISZ LibreOffice Team 2018-12-20 12:43:53 UTC
Created attachment 147697 [details]
Example file from Word
Comment 3 NISZ LibreOffice Team 2018-12-20 12:44:15 UTC
Created attachment 147698 [details]
The original file saved by Writer
Comment 4 Dieter 2018-12-20 13:13:00 UTC
I confirm the described behaviour with

Version: 6.3.0.0.alpha0+ (x64)
Build ID: ffa5b8a82eab18041bbee4d6914892b82c7801d3
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-12-19_03:24:54
Locale: en-US (de_DE); UI-Language: en-US
Calc: threaded

but I can also edit that comment in MS Word. So for me NAB. 

There is also a request for mark comments as resolved in writer (bug 119228)
Comment 5 Gabor Kelemen 2018-12-20 14:12:14 UTC
(In reply to Dieter Praas from comment #4)
> 
> but I can also edit that comment in MS Word. So for me NAB. 
> 
My team misunderstood the problem a bit, sorry. Of course it's editable, just visually collapsed to two lines and greyed out.

> There is also a request for mark comments as resolved in writer (bug 119228)

Feature-wise this is partially a duplicate of that. 
We can keep this open for OOXML interop. 
There is at least an attribute saved in docx that we throw away when opening files.
Comment 6 Gabor Kelemen 2018-12-20 14:15:31 UTC
Created attachment 147712 [details]
xml file extracted from the example docx

Seems like there is a separate XML in the docx storing the "Done" information about the comment:
<w15:commentEx w15:paraId="008D8BB2" w15:done="1"/>
Comment 7 Dieter 2018-12-20 14:25:44 UTC
(In reply to Gabor Kelemen from comment #5)
> We can keep this open for OOXML interop. 
> There is at least an attribute saved in docx that we throw away when opening
> files.

O. K. for me. If you adjust the bug summary I can confirm the bug.
Comment 8 Xisco Faulí 2019-01-16 22:07:39 UTC
Also reproduced in

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)
Comment 9 Mike Kaganski 2021-04-13 06:20:54 UTC
https://gerrit.libreoffice.org/c/core/+/114023
Comment 10 Mike Kaganski 2021-04-13 06:23:10 UTC
*** Bug 134265 has been marked as a duplicate of this bug. ***
Comment 11 Mike Kaganski 2021-04-13 06:23:26 UTC
*** Bug 137053 has been marked as a duplicate of this bug. ***
Comment 12 Mike Kaganski 2021-04-13 06:23:32 UTC
*** Bug 138930 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2021-04-16 16:41:48 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e61caf4d2719ebf5f696df39c41497a452c9d606

tdf#122222: add DOCX export of resolved comments as "done"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-04-16 16:42:59 UTC
Mike Kaganski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d8c0b63355af6caf3f0145dd1c10a93d63134a88

tdf#122222: add DOCX import of resolved comments as "done"

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Mike Kaganski 2021-04-17 11:20:19 UTC
So this new feature (support for Word 2013+ extended comment attribute) will be available in the next v.7.2.
Comment 16 BogdanB 2021-05-11 04:59:42 UTC
I verified now this bug, the difference now is that the cooment appears as Resolved. BUT in the desciption of this bug is "Actual Results: The comment is editable." And the comment is editable even it is resolved. Should the solved comments to be still editable?

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: d4f116d9576453f5974eb63db37a33c59ac53bc9
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded

I am not sure to mark this as verified (as appearing in the comment as Resolved) or NOT (based on the fact that resolved comments are still editable).
Comment 17 Mike Kaganski 2021-05-11 05:23:49 UTC
(In reply to BogdanB from comment #16)

tdf#119228 was the request to implement a core feature of resolving comments, with one of the goals being matching related Word feature. This one uses the function introduced there; so any mismatch in functionality of the core feature compared to Word should be a separate *core* issue (not the one related to import/export), related to the implementation of tdf#119228.
Comment 18 NISZ LibreOffice Team 2021-05-11 06:09:24 UTC
(In reply to BogdanB from comment #16)
> I verified now this bug, the difference now is that the cooment appears as
> Resolved. BUT in the desciption of this bug is "Actual Results: The comment
> is editable." And the comment is editable even it is resolved. Should the
> solved comments to be still editable?
> 

See comment #5 about this question.

This bug can be set as verified, thanks Mike for solving it!
Comment 19 BogdanB 2021-05-11 07:22:54 UTC
verified in 
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: d4f116d9576453f5974eb63db37a33c59ac53bc9
CPU threads: 4; OS: Linux 5.8; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 20 Timur 2021-07-30 09:02:42 UTC
*** Bug 143608 has been marked as a duplicate of this bug. ***