Bug 139377 - AutoCorrect in LO-Writer changes as from version 7.0.4.1 forcibly “daß” (traditional German spelling rules) to “dass” (reformed German spelling rules)
Summary: AutoCorrect in LO-Writer changes as from version 7.0.4.1 forcibly “daß” (trad...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
7.0.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-01-03 00:14 UTC by Dirk W.
Modified: 2021-02-27 10:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
How to find daß -> dass autocorrect entry (17.31 KB, image/png)
2021-01-03 15:54 UTC, Ming Hua
Details
Replacement table without “daß” (407.45 KB, image/jpeg)
2021-01-03 16:23 UTC, Dirk W.
Details
German autocorrect file without "daß" replacement into "dass" (18.43 KB, application/zip)
2021-01-03 20:45 UTC, Julien Nabet
Details
folder contents dict-de (821.96 KB, image/jpeg)
2021-01-14 12:16 UTC, Dirk W.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk W. 2021-01-03 00:14:03 UTC
Description:
Since version 7.0.4.1, the AutoCorrect function forcibly changes (traditional) “daß” to (reformed) “dass”, which makes writing a text in traditional German spelling quite difficult, because the conjunction “daß” occurs very often in German.

This function is superfluous, because a writer of the reformed spelling uses “dass” anyway (and does not need the superfluous “AutoCorrect”), while the writer in the traditional spelling is very annoyed by the forced “AutoCorrect” and is hindered in his writing flow not a little, because he must constantly use the “Undo: Typing” function.

Please note: The traditional German spelling is still valid, and is still used by some publishers (and writers). Only for public authorities the reformed spelling is mandatory.

Please remove this unnecessary forced auto-correction again!!! Nobody needs it, unless (German) LO programmers want to “nudge” German LO-Writer-users to the reformed spelling. But that would be unethical and would have nothing to do with well programmed software (which I consider LibreOffice to be).

Steps to Reproduce:
see “Description”

Actual Results:
see “Description”

Expected Results:
“daß” remains “daß” while writing and does not change to “dass” after using the space bar


Reproducible: Always


User Profile Reset: Yes



Additional Info:
see “Description”
Comment 1 Ming Hua 2021-01-03 00:47:52 UTC
This was intentional, see bug 131510.

The decision was not made by LO programmers, but by German users of LO.  Apparently some users need it.  People who like traditional German spelling can always delete this autocorrect entry or turn off autocorrect completely, nothing is *forced*.

IMO => NOTABUG/WONTFIX.
Comment 2 Julien Nabet 2021-01-03 09:38:02 UTC
Dirk W.: I understand you, I must recognize reforming spelling is a PITA, in France we had the same things in 1990. Personally, I prefer the French spelling before the reform and dislike the new one.
Badfully, I suppose the change won't be reverted and it's a pity it's not possible to choose the spelling. You've got only the workaround proposed by Ming but this same workaround could have been done for those who prefer "dass".
Comment 3 Telesto 2021-01-03 10:53:47 UTC
Addition to comment 1 (detailed instructions)
Tools -> Autocorrect -> Autocorrect options -> Replacement and exceptions (set to german)

Replace list, search for daß -> replace by dass (and remove the item)
Comment 4 Telesto 2021-01-03 10:57:26 UTC
Putting this to NAB, if someone prefers WONTFIX or WFM, also fine. If there is still an objection or another proposal, please revert to unconfirmed.
Comment 5 Dirk W. 2021-01-03 15:17:35 UTC
@Telesto: I object for the following reasons:

1. Under Tools -> AutoCorrect -> AutoCorrect Options…, there is no “‘daß’ -> ‘dass’” in the exceptions list, which could be deleted. I had suspected such an entry at first and wanted to delete it (before I reported this bug). This – and I stick with “forced” – autocorrection is invisible or buried deeper in the system – where only programmers have access.

2. - and here I mainly address Ming Hua – NOBODY needs this function – neither those who use the reformed spelling (because they immediately type “dass”) nor those who prefer the traditional spelling resp. the latter hinders the writing flow considerably by the forced autocorrection. Ming Hua writes: “Apparently some users need it”, and I say, no, not one single user needs it and it cannot be turned off separately. The only way is to go to Tools -> AutoCorrect -> AutoCorrect Options… -> Options (tab) and uncheck “Use replacement table” resp. “[T] AutorCorrect while typing”. However, this also removes all other replacements that one might like to have, respectively this is not an optimal solution for something that – I repeat – NOBODY needs.

I implore the programmer (or programmers) who added this new “feature” to remove it again. Please!!!
Comment 6 Julien Nabet 2021-01-03 15:22:09 UTC
Thorsten/Eike: I found https://wiki.documentfoundation.org/Language/LocalMailingLists#German but do you know where it's possible to find the discussion about this?
Also, any thoughts here?
Comment 7 Dirk W. 2021-01-03 15:48:19 UTC
Thank you @Julien! (I once lived in France for a time in order to be able to homeschool my children, or rather to escape compulsory German education. During this time I became firmly convinced that the French are in fact the most tolerant and naturally friendly people in the world. Although I love my homeland – the Odenwald – I really miss the French.)

Small addendum: That there are still many writers in Germany who prefer the traditional spelling can also be seen from the fact that the extension “German Spellchecker (de-DE-1901” a) exists and b) is maintained very meticulously and elaborately:
https://extensions.libreoffice.org/en/extensions/show/german-de-de-1901-old-spelling-dictionaries
Comment 8 Ming Hua 2021-01-03 15:54:35 UTC
Created attachment 168644 [details]
How to find daß -> dass autocorrect entry

(In reply to Dirk W. from comment #5)
> 1. Under Tools -> AutoCorrect -> AutoCorrect Options…, there is no “‘daß’ ->
> ‘dass’” in the exceptions list, which could be deleted. I had suspected such
> an entry at first and wanted to delete it (before I reported this bug). This
> – and I stick with “forced” – autocorrection is invisible or buried deeper
> in the system – where only programmers have access.
As Telesto has detailed in comment 3, you need to choose German as language in the AutoCorrect Options dialog first (only needed if your LO locale is not already German), then scroll down to find the daß -> dass entry, see screenshot.  It's not *buried* at all.  If you can't find such entry in your system after following the detailed instructions, then it's another bug and should be fixed.

> 2. - and here I mainly address Ming Hua – NOBODY needs this function
> [...]
> Ming Hua writes: “Apparently some users need it”, and I say, no, not one
> single user needs it and it cannot be turned off separately.
I don't speak German and have no horse in this race.  But IMO ignoring the reporter and commenter in bug 131510 (even if we don't have access to the possible discussion on the mailing list) and insisting that "nobody needs this" is not a productive way of communication.
Comment 9 Thorsten Behrens (allotropia) 2021-01-03 16:10:51 UTC
Agree with Ming Hua, won't fix due to bug 131510.

The workaround from https://bugs.documentfoundation.org/show_bug.cgi?id=139377#c1 seems quite a sensible solution for this (eminently unsolvable) quandary.
Comment 10 Dirk W. 2021-01-03 16:23:45 UTC
Created attachment 168646 [details]
Replacement table without “daß”
Comment 11 Dirk W. 2021-01-03 16:24:14 UTC
@Ming Hua: I have looked at your picture and I am surprised that you have a “daß”. This is not the case with me (see attachment).

I have looked at the discussion Bug 131510 - Old Replacement in german language. The statement of Thorsten Behrens (CIB), “‘dass’ is no longer correct.” is definitely wrong:

“To clarify, I say again: The official rules are initially binding only for the schools and the authorities. Beyond that, everyone can write how he wants and how he thinks he will be understood. Accordingly, anyone who continues to use the old spelling rules is not writing incorrectly, but traditionally. The new spelling rules will set an example.”
https://www.kmk.org/presse/pressearchiv/mitteilung/neuregelung-der-deutschen-rechtschreibung-ab-01august-wirksam.html

As I said in my initial description: Both spellings – traditional as well as reformed – are still valid. And: I maintain that NOBODY needs this change requested by Thorsten Behrens, even if it has been implemented in the meantime. WHY supposedly the change desired by Thorsten Behrens is needed is not clear from the discussion in Bug 131510, perhaps Thorsten Behrens can comment on this again.

So please undo the patch, because a) nobody needs it and b) it only hinders those who stick to the traditional spelling.
Comment 12 Telesto 2021-01-03 16:28:48 UTC Comment hidden (off-topic)
Comment 13 Dirk W. 2021-01-03 16:47:54 UTC
Thorsten Behren’s patch is based on the (false) assumption that “daß” is no longer valid, which is why this patch is required. But since the assumption is wrong, there is no more necessity.

Therefore: This patch – which in reality is not necessary at all – is not needed by anyone and only hinders those who stick to the traditional spelling.

Cui bono?
Comment 14 Telesto 2021-01-03 17:30:23 UTC
(In reply to Dirk W. from comment #13)
> Thorsten Behren’s patch is based on the (false) assumption that “daß” is no
> longer valid, which is why this patch is required. But since the assumption
> is wrong, there is no more necessity.

My previously commit drifted off a little. The original situation was an auto-replacement for dßs by daß. Probably someone decided there was a need for this (assumed this being needed, instead of superfluous as Dirk W. states)

The replacement table has been adjusted to a new standard. While the old “daß” not finally gone out of fashion. So now the replacement will be off left/or right.

Removal from the list would end the debate, but functionally will be lost. Apparently assumed to be needed (by the maintainer of the replacement list). With the assumption that 'Auto-Correct' a mistyped word automatically - with explicit consent to enable this feature - being the right thing to do (aside from spell checker).

I personally not a big fan of auto-correct replacement tables. It includes the discussion why something is added to the list, or not, or how it's replaced. There are likely more 'dubious' items in the German replacement list (or maybe in those of other languages).

And I'm seeing this matter - or any entry of the replacement table - as a topic not belonging to 'LibreOffice'. It's topic for the maintainer of the dictionary/ replacement list, IMHO.

Which can be seen as another reason to turn the feature off by default. As LibreOffice now indirectly supporting linguistic changes (and forcing them upon the user using auto-correct). LibreOffice would have clean hands if the user enabled the feature themselves.

But that's my logic.. seen from a more global perspective.. (in some sense a hijack).. feel free to mark this off-topic.
Comment 15 Dirk W. 2021-01-03 17:48:34 UTC
Telesto has circled the problem very nicely resp. rather brought it to the point:

> Which can be seen as another reason to turn the feature off by
> default. As LibreOffice now indirectly supporting linguistic changes
> (and forcing them upon the user using auto-correct). LibreOffice
> would have clean hands if the user enabled the feature themselves.

The user must be able to decide for himself whether he wants “that” automatically corrected to “dass” or not. This possibility can only be provided by the programmers. If this possibility is denied, as it is in the current build, then the programmers go beyond their underlying mandate and get their hands “dirty”.

I supplicate Thomas Behrens to reverse this patch. Please.
Comment 16 Dirk W. 2021-01-03 17:50:21 UTC
Telesto has circled the problem very nicely resp. rather brought it to the point:

> Which can be seen as another reason to turn the feature off by
> default. As LibreOffice now indirectly supporting linguistic changes
> (and forcing them upon the user using auto-correct). LibreOffice
> would have clean hands if the user enabled the feature themselves.

The user must be able to decide for himself whether he wants “daß” automatically corrected to “dass” or not. This possibility can only be provided by the programmers. If this possibility is denied, as it is in the current build, then the programmers go beyond their underlying mandate and get their hands “dirty”.

I supplicate Thomas Behrens to reverse this patch. Please.
Comment 17 Telesto 2021-01-03 18:56:38 UTC
(In reply to Dirk W. from comment #16)
> The user must be able to decide for himself whether he wants “daß”
> automatically corrected to “dass” or not.
True

> This possibility can only be provided by the programmers. 


I assume the list being part of dictionary (which maintained by someone). Doesn't need to be a 'programmer' in strict sense. Don't need actual coding skills 
The replacement list can be also changed (items added, removed, replaced) by a user (no actual for a programmer)

> If this possibility is denied, as it is in the current build, then the programmers go beyond their underlying mandate and get their hands “dirty”.

You hands get dirty in all cases, if you ask me. 
* Doing nothing. So leaving "dßa" replaced by 'dass' might be seen as wrong. For those who type daß while wanting dass in any variant (so including dßa). 

* By actively changing it to replacing. "dßa" by "dass". which started the whole thing. Which makes the additions (daß to dass and "dssa" to "dass" somewhat necessary

* By removing the replacement. Now you get complains it's not replaced anymore.


But well I'm not really happy with pre-defined replacement lists enabled by default. If a replacement list chosen and activated by the user, and the users makes use of a pre-defined list of someone else.. it's the risk he/she is taking.. If result not desired, you don't use that list or modify it.

The choice is kind of arbitrary. But that will be the case in any constellation.
That's why I personally want to throw this at the user. So everything is done with 'consent' of the user. If the final outcome not desired, not we can throw our hands in the air. 

You don't have much benefit by that, as the issue for you remains the same (if you turn on the replacement table). But 'we' don't get our hands dirty.. as the user picked a replacement list (in principle everybody could build one) 

The only downside is that people who do use auto-correct replacement table actively by default be surprised it not being activated. But a menu item could solve this.. 

And maybe label replacement and auto correct.. of finding different name for the feature. I don't associate auto-correct with 'replacement' or auto-complete. Only in hindsight.. But well different topic :P
Comment 18 Telesto 2021-01-03 19:58:18 UTC
Adding UX for some input and a decision; but that's my take. If it doesn't belong at UX please rectify
Comment 19 Dirk W. 2021-01-03 19:58:42 UTC
The problem is, among other things, that the forced change from “daß” to “dass” cannot be undone via the Replace-list.

Exactly this “effect” seems to have been the goal of the patch.

A normal user like me cannot get rid of this special autocorrection from “daß” to “dass”. (I already tried to enter “dass” -> “daß” in the Replace-list, but this substitution was not taken over). The user has only the possibility to do completely without such a list – whether original or modified afterwards. And just to be able to switch off this unnecessary autocorrection from “daß” to “dass”, having to do without the complete Replace-list right away, simply cannot be the “side effect” of a patch that is not necessary anyway.

So what is the purpose of this patch, if it can neither be switched off nor is needed, but instead considerably hinders the users of traditional spelling?
Comment 20 Thorsten Behrens (allotropia) 2021-01-03 20:02:17 UTC
Dirk, please don't reopen this bug again.

We can't make everyone happy here, so we go with what schools, pupils & the majority of Germans will need. There's no académie française in Germany, but there's the defacto standard, and that one is very unambiguous about 'daß': https://www.duden.de/sprachwissen/sprachratgeber/das-oder-dass

Telesto's musings about the defaults (and autocorrect in general) are worth discussing in the UX project, but not in scope for this very narrowly phrased bug report.
Comment 21 Ming Hua 2021-01-03 20:10:56 UTC
Dear Dirk,

(In reply to Dirk W. from comment #11)
> @Ming Hua: I have looked at your picture and I am surprised that you have a
> “daß”. This is not the case with me (see attachment).
My suggestion to you is to concentrate on solving this problem so that you can easily remove the daß -> dass entry for you own installation, instead of trying to revert the patch for everyone.

Meanwhile as a mere QA person who doesn't speak German, I think I've done everything I can here and don't want to be dragged into long discussion about German spelling or AutoCorrect feature.  Un-CCing myself.
Comment 22 Julien Nabet 2021-01-03 20:27:26 UTC
(In reply to Thorsten Behrens (allotropia) from comment #20)
> Dirk, please don't reopen this bug again.
> 
> We can't make everyone happy here, so we go with what schools, pupils & the
> majority of Germans will need. There's no académie française in Germany, but
> there's the defacto standard, and that one is very unambiguous about 'daß':
> https://www.duden.de/sprachwissen/sprachratgeber/das-oder-dass
...
I'm not German native but reading initial description tdf#131510, it seems the goal was just to replace:
- autocorrect dßa -> daß
by
- autocorrect dßa -> dass

but your patch also added the problematic (at least here):
<block-list:block block-list:abbreviated-name="daß" block-list:name="dass"/>
(in addition to:
<block-list:block block-list:abbreviated-name="dssa" block-list:name="dass"/>)

What about just removing 
<block-list:block block-list:abbreviated-name="daß" block-list:name="dass"/>
?
so tdf#131510 is still ok and this one will be ok too?

Those who want to replace traditional German by the other one can just add this line since the ones who want to keep traditional German can't remove it.
Comment 23 Dirk W. 2021-01-03 20:36:17 UTC
@Thorsten: OK, already alone, because you express yourself so politely, I leave the bug state on "RESOLVED WONTFIX". The quote from the Duden is of course heavy artillery, but their statement – even if it comes from the Duden editors – that “since then the spelling *daß is no longer correct” is misleading, because the spelling of daß/dass has nothing to do with “correctness” but “validity”, and valid are just still both spellings, even if the reformed spelling is binding in schools and administrations.

But maybe Julian’s hint/tip is the right one (which I can’t judge, because I know very little or nothing about programming).
Comment 24 Thorsten Behrens (allotropia) 2021-01-03 20:40:15 UTC
(In reply to Julien Nabet from comment #22)
> I'm not German native but reading initial description tdf#131510, it seems
> the goal was just to replace:
> - autocorrect dßa -> daß
> by
> - autocorrect dßa -> dass
> 

Yes - so it fixes a spelling mistake ("daß") and a key sequence problem ("dßa"). Not having the daß -> dass fixup in is then massively inconsistent.

Look at the contents of extras/source/autocorr/lang/de/DocumentList.xml - the idea here is to correct common mistakes on the fly.

We can debate the usefulness and scope of autocorrects, but not for this one narrow change. That's for the UX project.

Discussing the change per se (dass or daß) needs to happen in the original bug report, better even on the German project list https://de.libreoffice.org/get-help/mailing-lists/ as its a language / localisation issue.

Un-Cc-ing myself and ux-discuss. Let's move this discussion where it belongs (I'm listening on all three mentioned venues).
Comment 25 Julien Nabet 2021-01-03 20:45:58 UTC
Created attachment 168648 [details]
German autocorrect file without "daß" replacement into "dass"

Here's a workaround.
- exit LO
- find acor_de.dat in your "autocorrect" directory (on Windows, it's <LO directory program>/share/autocorrect) + make rename it acor_de.dat.bak
- Retrieve the file attached and put it in the same <LO directory program>/share/autocorrect
- Restart LO
It should be ok.

At least on my pc, it doesn't replace anymore "daß" by "dass".

Just for information, these dat files are in fact zip files.
I just renamed it in zip, unzipped and in DocumentList.xml, I removed the corresponding xml then rezipped the whole structure of files and renamed into dat.
Comment 26 Telesto 2021-01-03 20:48:12 UTC
Comment 25 should work 

However the dialog should work too, as far I know:
Select the item “daß under replace and “dass” under with & hit delete button at the Right should work to remove the auto-correction

Adding new entry typing 'wrong spelled word at the left. Replace with at the right and press NEW..

Not noticing any issue with it.. 

Not sure how will it's goes with actually applying.. if a restart is needed or not (should ideally not be the case)
Comment 27 Julien Nabet 2021-01-03 20:49:11 UTC
It can't be "FIXED" status since there's no patch to fix this. Some would consider this as "NOTABUG" but if WONTFIX was ok, let's put it back to this then.
Comment 28 Julien Nabet 2021-01-03 21:01:08 UTC
(In reply to Telesto from comment #26)
> Comment 25 should work 
> 
> However the dialog should work too, as far I know:
> Select the item “daß under replace and “dass” under with & hit delete button
> at the Right should work to remove the auto-correction
> 
> Adding new entry typing 'wrong spelled word at the left. Replace with at the
> right and press NEW..
> 
> Not noticing any issue with it.. 
> 
> Not sure how will it's goes with actually applying.. if a restart is needed
> or not (should ideally not be the case)

I gave it a try it doesn't work even after a restart.
I see a file brand new acor_de-DE.dat (which after having checked by unzipping etc. doesn't contain the deleted replacement) in "user/autocorr" in addition to the original acord_de-DE.dat in share/autocorr but it seems it isn't used.
Comment 29 Telesto 2021-01-03 21:40:02 UTC
(In reply to Julien Nabet from comment #28)
> I gave it a try it doesn't work even after a restart.
> I see a file brand new acor_de-DE.dat (which after having checked by
> unzipping etc. doesn't contain the deleted replacement) in "user/autocorr"
> in addition to the original acord_de-DE.dat in share/autocorr but it seems
> it isn't used.

I will check tomorrow.. but doesn't sound right. I assume you tested this on Linux. And Dirk appears to be using Linux, based on screenshots also.

Maybe related to bug 137908?
Comment 30 Dirk W. 2021-01-03 21:41:33 UTC
So I copied Julian’s acor_de.dat once into the folder C:\Program Files\LibreOffice\share\autocorr, set the check mark again under “Use replacement table” resp. “[T] AutorCorrect while typing” – and lo and behold: Everything is good again, “daß” remains “daß”.

Maybe this helps the programmers, I will use Julian’s acor_de.dat in the future until the thing with “daß” works also without Julian’s acor_de.dat.

Many, many thanks, Julian!!!
Comment 31 Telesto 2021-01-04 09:27:37 UTC
(In reply to Telesto from comment #29)
> (In reply to Julien Nabet from comment #28)
> > I gave it a try it doesn't work even after a restart.
> > I see a file brand new acor_de-DE.dat (which after having checked by
> > unzipping etc. doesn't contain the deleted replacement) in "user/autocorr"
> > in addition to the original acord_de-DE.dat in share/autocorr but it seems
> > it isn't used.

You're right.. and I somehow missed it :-(. Anyhow it's quite a broken. At least the 'delete item' finally being deleted after restart in 4.4.7.2. But even that isn't the case anymore.

I think I have had the same issue with 'auto-complete'. Anyhow opened a report for it.. 

Dirk W. Sorry for giving you non-working steps for your replacement issue. This is un-expected stack up of bugs. However should have known better; not the first time  you want to solve A and you encounter B
Comment 32 Dirk W. 2021-01-04 13:14:46 UTC
@Telesto
> Sorry for…

That’s okay. I’m happy if my report helped to find another bug elsewhere and by the fact that I can now enjoy the possession of Julian’s acor_de.dat, which at least solved my problem for the time being, everything is fine.

@all: Thank you very much for your attention and time spent on this bug report.
Comment 33 sophie 2021-01-04 13:32:55 UTC
(In reply to Julien Nabet from comment #2)
> Dirk W.: I understand you, I must recognize reforming spelling is a PITA, in
> France we had the same things in 1990. Personally, I prefer the French
> spelling before the reform and dislike the new one.
> Badfully, I suppose the change won't be reverted and it's a pity it's not
> possible to choose the spelling. You've got only the workaround proposed by
> Ming but this same workaround could have been done for those who prefer
> "dass".

Just to clarify and for information, with Grammalecte, you have the option to choose which spellchecker you want to use (and then the spelling), between Classical and 1990 reform or both of them. See screenshots on https://grammalecte.net/
Comment 34 Dirk W. 2021-01-04 16:08:52 UTC
@sophie (offtopic)

I have looked at the given page, downloaded the extension Grammalecte-fr-v2.0.0.oxt and installed it on a trial basis.

I must say that I am very fond of this extension. There is also an extension for LO-Writer for traditional German spelling (see comment 7), but the French extension is much more comprehensive and comfortable than the German one.

I can only say, “Hats off!” For a long time in my life, I thought the Germans were the engineers par excellence (and they used to be – the emphasis is on “used to be”). But when I lived in France (and read French children’s books with my kids) I realized that the French were responsible for countless inventions.

One could say: the Germans’ inventions were characterized primarily by ingenuity and precision, while the French inventions were simply smart and immensely practical. From my time in France, I remember most clearly the Géoportail site (https://www.geoportail.gouv.fr/), which is similarly incredible to the above extension. You can add countless details to the map – right down to the cadastral areas – and visually the maps are very pleasing. (It was similar with the IGN maps we used for walking.) In Germany, the maps of the state offices are visually much worse – and, above all, very flawed. Digital information about areas is spread over countless pages, which are also cumbersome to use.

Many things have gone wrong in Germany – the most serious mental devastation was caused by the “reform pedagogy” starting in the 70s, so that today we can’t even build an airport sensibly. “Reformed” spelling, by the way, is a side branch of “reform pedagogy”. The “reformers” (especially 68ers) were not really concerned with simplified spelling, but with “freeing” people from the supposedly “repressive” character of spelling at the time, “equalizing” society etc. The spelling reform was really forced on the Germans – and (illegitimate) coercion is the means of choice par excellence, by means of which (especially left-wing) ideologues have been operating for over 100 years (100 million dead can’t be wrong).

If Julien didn’t know about this extension yet, I’m happy for him that he can use it now, when he has missed such a one for a long time.
Comment 35 Eike Rathke 2021-01-13 15:30:08 UTC
(In reply to Dirk W. from comment #7)
> Small addendum: That there are still many writers in Germany who prefer the
> traditional spelling can also be seen from the fact that the extension
> “German Spellchecker (de-DE-1901” a) exists and b) is maintained very
> meticulously and elaborately:
> https://extensions.libreoffice.org/en/extensions/show/german-de-de-1901-old-
> spelling-dictionaries

Unfortunately that extension abuses the de-DE language tag, forcing users to remove existing new spelling dictionaries, instead of the proper de-DE-1901 language tag to coexist with de-DE. See the comment I added to that extension page and how to fix before installation.
Comment 36 Dirk W. 2021-01-14 12:16:11 UTC
Created attachment 168878 [details]
folder contents dict-de
Comment 37 Dirk W. 2021-01-14 12:17:13 UTC
Hello Eike,

thank you very much for your comment. I have also looked at your recent comment about the extension “German Spellchecker (de-DE-1901)”.

I am not sure if I have understood you correctly. Should the user in any case – even if he doesn’t want to use both dictionaries resp. only the Old Spelling dictionary – make sure that both dictionaries coexist or only if he really wants to use both dictionaries?

For example, I only want to use the Old Spelling dictionary, and I actually delete all files under C:\Program Files\LibreOffice\share\extensions\dict-de after reinstalling LO-Writer and copy the Old Spelling files I saved sometime back there (see “folder contents dict-de”).

I don’t remember why I go this way, I only know that often after a reinstallation of LO-Writer the Hyphenation… of words didn’t work with the extension “German Spellchecker (de-DE-1901)”. At some point I found out the way described before as practicable and I am very happy with it. As I said, I don’t want to use the New Spelling dictionary.

If you are of the opinion that it would be advisable in any case to let both dictionaries exist in “peaceful” coexistence, then I feared problems both under Tools\Language and the Options…. Somehow there’s always muddle with the two dictionaries. And since I only want to use the one with the old spelling anyway, I am very happy with my “solution”.
Comment 38 Dirk W. 2021-01-15 11:06:13 UTC
Addendum:

I tried to comprehend what I had actually done in the past. I had looked at the data structure of the dictionary in the new as well as in the old spelling. Then I renamed the dictionary files de_DE_OLDSPELL.aff plus de_DE_OLDSPELL.dic to de_DE_frami.aff plus de_DE_frami.dic and copied these renamed files (as well as the files of the dictionary of the old spelling with the same name) to C:\Program Files\LibreOffice\share\extensions\dict-de (resp. the existing files of the New Spelling dictionary) to lead LO-Writer to believe in a “normal” dictionary. This way, hyphenation also works, and I can be 100% sure that LO-Writer uses only the Old Spelling dictionary.

I know, this is all rather complicated, and the LibreOffice programmers are certainly not to be envied that they have to deal with two German spellings and four German language areas.