Bug 139395 - Writer Paragraph Style dialog is too tall: OK/Cancel buttons are not visible
Summary: Writer Paragraph Style dialog is too tall: OK/Cancel buttons are not visible
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.0.0.0.alpha1+
Hardware: All Linux (All)
: medium normal
Assignee: Heiko Tietze
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, needsUXEval, regression
Depends on:
Blocks: GTK3-Dialog-High
  Show dependency treegraph
 
Reported: 2021-01-04 09:01 UTC by Kevin Suo
Modified: 2022-01-15 12:30 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot: bad after commit 5202771939da66ac85ca3221d69e7e5f5cca8da7 (110.60 KB, image/png)
2021-01-04 09:09 UTC, Kevin Suo
Details
screenshot: good before commit 5202771939da66ac85ca3221d69e7e5f5cca8da7 (115.23 KB, image/png)
2021-01-04 09:10 UTC, Kevin Suo
Details
paragraph style in gtk3 (78.12 KB, image/png)
2021-01-04 10:12 UTC, paulo g.
Details
Screenshot with new layout (53.21 KB, image/png)
2021-11-26 11:57 UTC, Heiko Tietze
Details
Screenshot #2 (42.60 KB, image/png)
2021-11-26 15:37 UTC, Heiko Tietze
Details
for me, before (62.98 KB, image/png)
2022-01-14 12:57 UTC, Caolán McNamara
Details
how it looks after (99.48 KB, image/png)
2022-01-14 12:58 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2021-01-04 09:01:20 UTC
Steps to Reproduce:
1. Click any paragraph style from the sidebar;
2. Right-click and click "Modify".

Current Result:
Dialog is is too tall: OK/Cancel buttons are not visible.

Expected:
OK/Cancel buttons are not visible.

Fedora 32, Gnome 3.36.8, Wayland.
1366*768 laptop display.
Comment 1 Kevin Suo 2021-01-04 09:06:16 UTC
Bisected to the following commit:

author Miklos Vajna <vmiklos@collabora.com>	2020-05-25 21:03:56 +0200
committer Miklos Vajna <vmiklos@collabora.com>	2020-05-26 10:20:19 +0200
commit	5202771939da66ac85ca3221d69e7e5f5cca8da7

tdf#130456 sw: enable semi-transparent text for char style dialog 

That commit added SVX_ENABLE_CHAR_TRANSPARENCY on this dialog. With this control, the dialog grows taller and thus the OK/Cancel buttons are not visible on small displays.

A solution may be putting the "Transparency" control to the right of "Font Color".
Comment 2 Kevin Suo 2021-01-04 09:07:33 UTC
Adding Miklos Vajna to cc: would you please take a look? Thanks.
Comment 3 Kevin Suo 2021-01-04 09:09:09 UTC
Created attachment 168657 [details]
screenshot: bad after commit 5202771939da66ac85ca3221d69e7e5f5cca8da7
Comment 4 Kevin Suo 2021-01-04 09:10:33 UTC
Created attachment 168658 [details]
screenshot: good before commit 5202771939da66ac85ca3221d69e7e5f5cca8da7
Comment 5 paulo g. 2021-01-04 10:12:51 UTC
Created attachment 168659 [details]
paragraph style in gtk3
Comment 6 Kevin Suo 2021-01-04 11:11:08 UTC
(In reply to paulo g. from comment #5)
paulo g: Do you know which commit has fixed this issue?
Comment 7 Kevin Suo 2021-01-04 11:13:42 UTC
Also, the version field should be the earliest libreoffice version this bug appears, not the version you have tested to have fixed this issue.

You may not reproduce this this on your machine if you have a larger display, but this issue may still exists on small displays like a laptop.
Comment 8 Kevin Suo 2021-01-04 13:56:19 UTC
Set back to unconfirmed.
Comment 9 Buovjaga 2021-11-25 15:58:17 UTC
Font effects tab has the Transparency option below Font color, but maybe it could be positioned next to it. Anyway, we are breaking our promise of 1024x768 resolution minimum.

Arch Linux 64-bit
Version: 7.3.0.0.alpha1+ / LibreOffice Community
Build ID: 8c66455df8f6a26c314290f252bedbc19db6b327
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 25 November 2021
Comment 10 Heiko Tietze 2021-11-26 10:54:32 UTC
HIG [1] says: "Dialogs should work with a size of 800x600 pixels..." In my system with kf5 VCL the dialog takes 839x690px so we need to save a few pixels.

Version: 7.2.2.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (en_US.UTF-8); UI: en-US
7.2.2-4
Calc: threaded

[1] https://wiki.documentfoundation.org/Design/Guidelines/PropertyDialog
Comment 11 Heiko Tietze 2021-11-26 11:57:09 UTC
Created attachment 176518 [details]
Screenshot with new layout

Using master/7.4 I get 972x599px for gtk3 (depends on theming as well) and 846*690 in case of native kf5.

Moving the spinbox does not solve the issue since two controls follow underneath Relief: Emphasis Mark and Position (no idea under what circumstances those are shown).
Comment 12 Heiko Tietze 2021-11-26 11:59:33 UTC
(In reply to Heiko Tietze from comment #11)
> (no idea under what circumstances those are shown).

In case of CTL/CJK (tools > options > language: Asia/Complex).
Comment 13 Heiko Tietze 2021-11-26 12:03:12 UTC
Moving position to the right of Emphasis would save a few pixels but the Font tab takes a lot of space with CJK and CTL enabled. So still 690px for me.

Trying to move controls next to the labels (not below as today)...
Comment 14 Heiko Tietze 2021-11-26 15:37:04 UTC
Created attachment 176527 [details]
Screenshot #2

(In reply to Heiko Tietze from comment #13)
> Trying to move controls next to the labels (not below as today)...

Still no luck
Comment 15 V Stuart Foote 2022-01-13 14:50:51 UTC
Seems like playing whack-o-mole with these dialog heights with gtk3 backend.

Caolán fixed bug 139332 by reducing height (row count of dialog); Daiwanshu fixed bug 128176 by enabling vertical scrollbar for the OT Features. See also bug 146675 affects the Customize dialog on Wayland w gtk3 backend.

What are you thinking here Heiko? Seems more than a cosmetic issue in that the gtk3 (and gtk4?) buttons are sized differently; the other vcl backends seem unaffected.
Comment 16 Heiko Tietze 2022-01-14 09:53:02 UTC
The dialog is badly sized in case CTL/CJK languages are enabled. My patch solves this by moving the languages into tabs. Asked in the CTL/CJK Telegram channel about opinions and while it was necessary in the past to have different fonts this is not necessary anymore with Noto, for example. But that's off-topic here.

Gtk3/4 sized buttons will always be an issue as long we don't start the development from scratch with Qt. Challenge for UX is to find good places for controls. And I doubt there is a final state.
Comment 17 Caolán McNamara 2022-01-14 11:08:46 UTC
The original report was just because of the additional line, the reporter was happy before that extra line was added. So I don't know why just putting the new widget in the free space in the first line isn't good enough?
Comment 18 Heiko Tietze 2022-01-14 12:08:04 UTC
(In reply to Caolán McNamara from comment #17)
> The original report was just because of the additional line, the reporter
> was happy before that extra line was added. So I don't know why just putting
> the new widget in the free space in the first line isn't good enough?

Moving one control has not much effect. Please check with CTL/CJK enabled in tools > options.
Comment 19 Caolán McNamara 2022-01-14 12:57:30 UTC
Created attachment 177546 [details]
for me, before
Comment 20 Caolán McNamara 2022-01-14 12:58:24 UTC
Created attachment 177547 [details]
how it looks after

for me on a default fedora install (similar to the original reporter I think) it just about squeaks in under the 768 size with the minimal change.
Comment 21 Commit Notification 2022-01-15 12:30:02 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d73602dc51aa8829fc88e5e67e2b0c4da6b8f715

Resolves tdf#139395 - Redesign of font name and effects pages

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.