Bug 139906 - Mail merge creates empty fields.
Summary: Mail merge creates empty fields.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Gülşah Köse
URL:
Whiteboard: target:7.2.0
Keywords:
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2021-01-25 12:25 UTC by Gülşah Köse
Modified: 2021-04-15 22:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
simple.ods (don't forget to change email column) (21.75 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-01-25 12:26 UTC, Gülşah Köse
Details
simple.odt (10.37 KB, application/vnd.oasis.opendocument.text)
2021-01-25 12:26 UTC, Gülşah Köse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gülşah Köse 2021-01-25 12:25:35 UTC
Description:
When we try to use a registered database (a data source we add it into LibreOffice before), fields are returned empty.

Steps to Reproduce:
Warning: Change simple.ods email column with your email. Otherwise I'll get all the mails.

0.Fill your mail merge config and test settings (Writer->Tools->Options->LibreOffice Writer->Mail Merge Email)
1. Open simple.odt (Don't forget to change mail column)
2. Edit->Exchange Database
3. Browse and add simple.ods
4. Select "test" sheet to define
5. Press ok
6. Close LibreOffice
7. Open LibreOffice again
8. Open simple.odt again
9. View->Data sources
10. Select simple->Tables->test sheet
11. Start mail merge wizard (Tool->Mail Merge wizard or Envelope icon)
12. Select "Use current document" and Next
13. Select "Email message" and Next
14. Click "Select the address list" Select test sheet and Finish
15. Click "Send email messages" button
16. Select To : Email
17. Subject: "xxx"
18. Send as: PDF 
19. Click "Send Documents"
20. Open the mail you got. And open simple.pdf

Actual Results:
Dear,
bla bla bla

Expected Results:
Dear Gülşah,
bla bla bla


Reproducible: Always


User Profile Reset: No



Additional Info:
Not PDF specific bug, result is same for all type.
If you clean registered databases, close and open LibreOffice and use fresh database the problem disappears. Problem appears when we try to use old databases.
Comment 1 Gülşah Köse 2021-01-25 12:26:19 UTC
Created attachment 169132 [details]
simple.ods (don't forget to change email column)
Comment 2 Gülşah Köse 2021-01-25 12:26:46 UTC
Created attachment 169133 [details]
simple.odt
Comment 3 Raji 2021-02-25 11:52:50 UTC
Hello Gulash,

Thanks for reporting the bug.
I am trying to reproduce this bug, but for me in step 9.view->DataSource, 
My LibreOffice Crashes.
I tried many times but still no change in result for me. so unfortunately I can't reproduce the bug.

Version: 7.1.0.3 (x64) / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Windows 10.0 Build 19041; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL


I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' .
Comment 4 Gülşah Köse 2021-02-25 12:59:30 UTC
Hi Raji,

Still reproducible for me. Any chance to share the backtrace of the crash. Maybe it gives an idea.
Comment 5 QA Administrators 2021-02-26 04:11:51 UTC Comment hidden (obsolete)
Comment 6 Timur 2021-03-23 16:19:03 UTC
Funny.. Gülşah  reported it and after waiting to be confirmed, just decided to fix it and solve the issue of confirmation :) 

In QA defense, this bug was inspiration to me to triage a couple of other mail merge bugs. Finally ,fed up with making sample each time, I proposed bug 140885.
Comment 7 Gülşah Köse 2021-03-23 16:27:36 UTC
@Timur actually the bug is very obvious to me :) But for someone else, I know it's not easy to repeat a 20-step. I detected the problem and close to the solution.

Thanks..
Comment 8 Commit Notification 2021-04-02 12:11:04 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e64dc07ca8300a997d6d3eebfc3e198ae55d290d

tdf#139906 Show warning message when data source is not avaible.

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-04-02 12:11:15 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d7d487875246ba00d5be7e4fb0fd82b78fea5205

tdf#139906 Prevent to use the Mail Merge wizard without data source.

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2021-04-15 22:01:28 UTC
Gülşah Köse committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a809b2ab2553e946431699d9d7ac3f6209cbdd6b

tdf#139906  Add an option to change data source from mail merge wizard dialog.

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.