Download it now!
Bug 140852 - FILEOPEN PPTX: text box shows as half the width (and with an extra bullet)
Summary: FILEOPEN PPTX: text box shows as half the width (and with an extra bullet)
Status: RESOLVED DUPLICATE of bug 118458
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.2.2 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, implementationError
Depends on:
Blocks:
 
Reported: 2021-03-07 09:56 UTC by Gerald Pfeifer
Modified: 2021-06-09 12:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample slide (in PPTX format) (48.61 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2021-03-07 09:56 UTC, Gerald Pfeifer
Details
Visual comparison Office 365 vs LibreOffice 7.2 (267.26 KB, image/png)
2021-03-07 09:57 UTC, Gerald Pfeifer
Details
How it looks in LibreOffice 6.4 (270.90 KB, image/png)
2021-03-07 09:59 UTC, Gerald Pfeifer
Details
The example file in PP and Impress nightly (73.62 KB, image/png)
2021-06-09 11:58 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gerald Pfeifer 2021-03-07 09:56:33 UTC
Created attachment 170291 [details]
Sample slide (in PPTX format)

Comparing the sample slide in Office 365/Impress and LibreOffice I 
observe two key differences:

 - LibreOffice renders the contents of the text box as a bullet list,
   adding a bullet point at the beginning

 - LibreOffice shows the text box as half the width


Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: f66a479225b35e9f1fd3621eef7496462088308a
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-03-05_09:50:07
Calc: threaded
Comment 1 Gerald Pfeifer 2021-03-07 09:57:28 UTC
Created attachment 170293 [details]
Visual comparison Office 365 vs LibreOffice 7.2
Comment 2 Gerald Pfeifer 2021-03-07 09:59:58 UTC
Created attachment 170294 [details]
How it looks in LibreOffice 6.4
Comment 3 Gerald Pfeifer 2021-03-07 10:02:11 UTC Comment hidden (obsolete)
Comment 4 Gerald Pfeifer 2021-03-07 10:05:20 UTC
This appears to be somewhat of a regression, somewhere between 6.4 and 7.0:

LibreOffice Version: 6.4.8.0.0+
Build ID: 99b065ec31d032fc08ab14f66430dac4fef904a5
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-4, Time: 2020-10-08_08:57:08
Locale: en-US (en_US.UTF-8); UI-Language: en-US

...renders that text box as desired in terms of full width (alas
still with the bullet), though it does include an additional,
undesired textbox which was addressed with version 7.0.
Comment 5 Timur 2021-03-09 07:53:29 UTC
This bug is about half width of text box. Repro 7.2+.
I bibisected in 7.0 and culprit is fix in bug 133015. There are more commits there (with different regressions) and this one is 8faf8... Inherit numCol...
Comment 6 Timur 2021-03-09 08:20:18 UTC
As for bullet, it's also a regression, looks the same one and even cause of all this, so be kept here. 

Bullet wasn't three in 6.2 oldest and all was correct, but 6.2 master has no proper text at all, just text from master slide. 

Change in 6.3 bibisect wasn't quite correct for this bug example, text appeared but with bullet and master text. Seems that it wasn't bug report related fix, but general fix by Noel.
Comment 7 Timur 2021-03-09 08:32:47 UTC
Bisect 6.2: from all good text to nothing (master text)
commit e775b2f2dc93b3cefecae169623c0d4b2afc1160
Date:   Fri Sep 21 13:51:26 2018 +0200
    source sha:aef569ed83a3ccc02639e5b2a1c7cc131ba262fc
    prev  source sha:356db87a6b622722d0d04ee3e17730a96865770a
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=356db87a6b622722d0d04ee3e17730a96865770a..aef569ed83a3ccc02639e5b2a1c7cc131ba262fc
author	Miklos Vajna <vmiklos@collabora.co.uk>	2018-09-21 11:50:57 +0200
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2018-09-21 13:30:20 +0200
commit	aef569ed83a3ccc02639e5b2a1c7cc131ba262fc (patch)
tree	90bf85cdf5359ec5e300000d396cd13d33e924fb
parent	356db87a6b622722d0d04ee3e17730a96865770a (diff)
tdf#120028 PPTX import: map shapes with multiple columns to table shapes
Longer term the core Impress shape has to be improved so that it can have text in multiple columns.
Shorter term, map text with multiple columns to table shapes, that gives correct layout in many cases and requires changes to the import filter only.

Bisect 6.3: from nothing to text with bullet and master text 
commit e00da6fa3b75565ddcbdb995774101bbd0c373cb
Date:   Wed May 8 14:47:04 2019 +0200
    source sha:d0119ff7f2c68aa05286bd303128f3a69c6bbd6a
    prev source sha:5218ca22b472a80969a715e38d7cb8d052be4b6a
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=5218ca22b472a80969a715e38d7cb8d052be4b6a..d0119ff7f2c68aa05286bd303128f3a69c6bbd6a
author	Noel Grandin <noelgrandin@gmail.com>	2019-05-06 11:33:41 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2019-05-08 12:42:53 +0200
commit	d0119ff7f2c68aa05286bd303128f3a69c6bbd6a (patch)
tree	80fc2e52ceb8446997348eda9186cbdfcd247298
parent	5218ca22b472a80969a715e38d7cb8d052be4b6a (diff)
improve tools::Rectangle->basegfx::B2?Rectangle conversion
Improve the conversion method to do something reasonable with empty Rectangle.
Use the conversion method in more places.

Bisect 7.0: from text with bullet and master text to half-size text with bullet 
commit 240b633f8831d18e8a4df2beb2a6704246e21e76
Date:   Wed Sep 2 03:53:36 2020 +0200
    source sha:8faf8f173fe75bfa27b615db0ea177941a775724
    prev source sha:30646d95555db67cca8902a1a456f57dfdc9c30b
https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=30646d95555db67cca8902a1a456f57dfdc9c30b..8faf8f173fe75bfa27b615db0ea177941a775724
author	Gülşah Köse <gulsah.kose@collabora.com>	2020-08-08 00:34:37 +0300
committer	Xisco Fauli <xiscofauli@libreoffice.org>	2020-09-01 18:00:44 +0200
commit	8faf8f173fe75bfa27b615db0ea177941a775724 (patch)
tree	a2a366a9f213aa27c2af8dd0129ea68e472a852b
parent	30646d95555db67cca8902a1a456f57dfdc9c30b (diff)
tdf#133015 Inherit numCol from placeholder.

I raise importance because this is not a single document but a series of changes that didn't fix the first regression. 
Adding Miklos to CC, please see.
Comment 8 Miklos Vajna 2021-03-17 15:45:04 UTC
I think this is essentially a duplication of bug 140022, which is about proper core support for multi-column shape text. Let's get back to this bug once that one is resolved.
Comment 9 NISZ LibreOffice Team 2021-06-09 11:58:27 UTC
Created attachment 172730 [details]
The example file in PP and Impress nightly
Comment 10 NISZ LibreOffice Team 2021-06-09 12:01:14 UTC
This looks good in todays nightly, no more two columns layout using table and extra bullet:

Version: 7.2.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 31ed81ea71a20ec119805f66a42f99b3f80d2dc5
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: el-GR (hu_HU); UI: en-US
Calc: CL

*** This bug has been marked as a duplicate of bug 118458 ***