Download it now!
Bug 141550 - FILEOPEN: Incorrect position of textbox
Summary: FILEOPEN: Incorrect position of textbox
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Attila Bakos (NISZ)
URL:
Whiteboard: target:7.2.0
Keywords: bibisected, bisected, regression
: 143136 (view as bug list)
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2021-04-07 19:55 UTC by Xisco Faulí
Modified: 2021-07-07 13:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison MSO 2010 and LibreOffice 7.2 master (10.81 KB, image/png)
2021-04-07 19:55 UTC, Xisco Faulí
Details
another file affected (50.38 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-04-07 20:04 UTC, Xisco Faulí
Details
Screenshot of one more affected file (221.01 KB, image/png)
2021-04-12 13:52 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2021-04-07 19:55:54 UTC
Created attachment 171021 [details]
Comparison MSO 2010 and LibreOffice 7.2 master

Steps to reproduce:
1. Open attachment 98963 [details] from bug 78651

-> At the bottom of the first page there is a textbox with the number page, it's completely aligned to the right. there should be some spacing instead. See comparison image

Reproduced in

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: c47ad11f8c2e917adebbd5d7b3a3ef6cc4b3e670
CPU threads: 4; OS: Linux 5.7; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2021-04-07 19:57:30 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=ff321dd36554d25f0817903becf4598065e0a194

author	Attila Bakos (NISZ) <bakos.attilakaroly@nisz.hu>	2021-03-09 16:32:27 +0100
committer	László Németh <nemeth@numbertext.org>	2021-03-29 11:33:52 +0200
commit	ff321dd36554d25f0817903becf4598065e0a194 (patch)
tree	e7d348490b7b3040abb99d69af3b6a24108e1139
parent	3d844a131d7d2d2c82d865d17ad7657c7e8a185c (diff)
tdf#140828 sw textbox: fix AS_CHAR regression

Bisected with: bibisect-linux64-7.2

Adding Cc: to Attila Bakos
Comment 2 Xisco Faulí 2021-04-07 20:01:09 UTC
attachment 106227 [details] from bug 83496 is also affected by this issue. the text 'At vero eos et accusam' is shifted to the right
Comment 3 Xisco Faulí 2021-04-07 20:04:57 UTC
Created attachment 171022 [details]
another file affected
Comment 4 NISZ LibreOffice Team 2021-04-12 13:52:54 UTC
Created attachment 171124 [details]
Screenshot of one more affected file

attachment 129243 [details] from bug 104353 is also affected, text boxes go a few cm to the right.
Comment 5 Commit Notification 2021-04-19 08:45:35 UTC
Attila Bakos (NISZ) committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/cb965f2cf6d68c284ccbd8a9635abfdfcc0538ca

tdf#141550 tdf#141557 tdf#140975 sw: fix textbox crash

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 NISZ LibreOffice Team 2021-05-05 15:24:53 UTC
Verified in: 

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ef78c7d93e4f170ac7a7f0307a8305052524eb53
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
Locale: ug-CN (hu_HU); UI: hu-HU
Calc: threaded
Comment 7 NISZ LibreOffice Team 2021-07-07 13:53:40 UTC
*** Bug 143136 has been marked as a duplicate of this bug. ***