Bug 141607 - FILEOPEN XLSX Cell background colour missing (patternFill)
Summary: FILEOPEN XLSX Cell background colour missing (patternFill)
Status: RESOLVED DUPLICATE of bug 31205
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: Calc-Styles XLSX
  Show dependency treegraph
 
Reported: 2021-04-10 13:14 UTC by Buovjaga
Modified: 2022-04-25 13:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Blue invoice template (1.18 MB, application/vnd.openxmlformats-officedocument.spreadsheetml.template)
2021-04-10 13:14 UTC, Buovjaga
Details
PDF exported from MSO 2013 (178.56 KB, application/pdf)
2021-04-10 13:14 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2021-04-10 13:14:04 UTC
Created attachment 171082 [details]
Blue invoice template

Note: the confirming of this report is reserved for triagers in training, so if you are a veteran, please skip :)

1. Open attached XLTX template
2. Compare with the attached PDF

Notice that the gray cell backgrounds in the Item Description / Amount section are missing.

Examining the styles.xml we see

<tableStyles count="1" defaultTableStyle="TableStyleMedium2" defaultPivotStyle="PivotStyleLight16">
    <tableStyle name="Business Table" pivot="0" count="3" xr9:uid="{00000000-0011-0000-FFFF-FFFF00000000}">
        <tableStyleElement type="wholeTable" dxfId="6"/>
        <tableStyleElement type="headerRow" dxfId="5"/>
        <tableStyleElement type="secondRowStripe" dxfId="4"/>
    </tableStyle>
</tableStyles>

Explanation: dxfId (Formatting Id) 	Zero-based index to a dxf record in the dxfs collection, specifying differential formatting to use with this Table or PivotTable style element.
https://docs.microsoft.com/en-us/dotnet/api/documentformat.openxml.spreadsheet.tablestyleelement?view=openxml-2.8.1

So our gray cell style should be secondRowStripe. It points to the dxf with the zero-based index of 4. Thus, in styles.xml we find it inside the <dxfs count="7"> element as

<dxf>
    <fill>
        <patternFill>
            <bgColor theme="0" tint="-4.9989318521683403E-2"/>
        </patternFill>
    </fill>
</dxf>

Note: other issues in the same template are already reported. Missing borders is bug 141588 while missing gradient background depends on bug 49177.

Arch Linux 64-bit
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: 3b6408988487c886adc5415f7050f9da13d2e16b
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 8 April 2021
Comment 1 Buovjaga 2021-04-10 13:14:32 UTC
Created attachment 171083 [details]
PDF exported from MSO 2013
Comment 2 psidiumcode 2021-04-11 18:46:11 UTC
Confirmed that the table Item Description / Amount cells do not have the gray background on the XLTX template.

Version: 7.1.2.2 / LibreOffice Community
Build ID: 8a45595d069ef5570103caea1b71cc9d82b2aae4
CPU threads: 2; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-US (en_FI.UTF-8); UI: en-US
Calc: threaded

Confirmed also with version:

Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: d0b4719ca3d4608bcb7431dbeb097146dd5a5127
CPU threads: 2; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-US (en_FI.UTF-8); UI: en-US
Calc: threaded
Comment 3 Roman Kuznetsov 2022-04-25 07:55:02 UTC
dupe of bug 70384?
Comment 4 Buovjaga 2022-04-25 13:14:49 UTC
I found a Calc bug, sorry for not thinking last year

*** This bug has been marked as a duplicate of bug 31205 ***