Bug 142519 - Cannot set Impress comment directionality
Summary: Cannot set Impress comment directionality
Status: RESOLVED DUPLICATE of bug 62932
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.0.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: RTL-UI
  Show dependency treegraph
 
Reported: 2021-05-27 05:18 UTC by Khalil
Modified: 2021-11-29 11:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Khalil 2021-05-27 05:18:53 UTC
Description:
After inserting comment in impress slide the language direction LTR/RTL can't be changed.

Steps to Reproduce:
1.Open new impress file and insert comment in the slide
2.change language direction from LTR to RTL
3.the text direction is not changed and text direction icons are not active

Actual Results:
text direction is not changing from LTR to RTL. Also icons are not active.

Expected Results:
text direction should be changed from LTR to RTL.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.0.6.2
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Eleonora Govallo 2021-08-11 10:26:32 UTC
Hello! Could you please clarify how you change language direction from LTR to RTL, by which menu or dialog?
Comment 2 Khalil 2021-08-17 05:12:10 UTC
(In reply to Eleonora Govallo from comment #1)
> Hello! Could you please clarify how you change language direction from LTR
> to RTL, by which menu or dialog?

I'm using standard Toolbar, Text formatting.
I tried also Tabbed Toolbar.
Can't also change direction through Character side Toolbar.
Comment 3 Eleonora Govallo 2021-08-17 18:29:20 UTC
I don't understand how exactly you change text direction in Impress. I know how it to change it in Calc (Menu "sheet"=> Right-toLeft) But how can i make it in Impress?
Comment 4 Khalil 2021-09-06 09:42:56 UTC
(In reply to Eleonora Govallo from comment #3)
> I don't understand how exactly you change text direction in Impress. I know
> how it to change it in Calc (Menu "sheet"=> Right-toLeft) But how can i make
> it in Impress?


You need first to activate "Complex text layout" through "Tools" then "Options" then "Language Settings" then "Languages".
Comment 5 QA Administrators 2021-09-07 03:51:08 UTC Comment hidden (obsolete)
Comment 6 Eyal Rozenberg 2021-11-12 17:13:24 UTC
Confirmed with:

Version: 7.3.0.0.alpha0+ / LibreOffice Community
Build ID: c998691e22ceda15c89d55cf7005201f0392dadb
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_IL); UI: en-US
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2021-10-14_11:54:20


But I'm pretty sure it's always been like this...

Impress comments don't seem to take "Drawing Styles" - which is reasonable, but it also means that the ability to set their direction would require special UI; and that UI does not exist anywhere.
Comment 7 Heiko Tietze 2021-11-29 11:55:37 UTC
I think it's still difficult to follow for LTR people. I can enter "Hello World" where World starts left of Hello in case of RTL. It's of course shown in LTR finally. But the point is that switching from LTR to RTL works well for paragraphs. 

Though it's not possible to set the text direction for comments. Which is a duplicate of bug 62932.

*** This bug has been marked as a duplicate of bug 62932 ***