Bug 143593 - create a search box to filter "recent files" in the LO interface
Summary: create a search box to filter "recent files" in the LO interface
Status: RESOLVED DUPLICATE of bug 80934
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Recent-Document-List Start-Center
  Show dependency treegraph
 
Reported: 2021-07-28 18:24 UTC by Aleix
Modified: 2021-08-09 13:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleix 2021-07-28 18:24:41 UTC
Hi, 
it would save much time if there was a way to filter and search between the "recent files" or "recent documents" that show when you open LO. 

"Recent files" are traditionally listed as thumbnails, but it is hard to find the ones I need. I have about +100 files because I work in several projects simultaneously, so it is tedious to find the exact file in the thumbnails but it is also tedious to go to the corresponding folder to open it :-/

Since we are at it, it would also be very nice to be able to choose between the current thumbnail view and a detailed list view, where you would have, e.g., the full name of each file and its corresponding working directory.

Of course, this is just a suggestion, LO is great!
Thanks for the hard work of the developers!
Best
Aleix
Comment 1 V Stuart Foote 2021-07-29 12:33:46 UTC
Pinning a document on MRU or StartCenter is open as bug 38742

Displaying the MRU as other than document thumbnails was bug 95739 and dupes, deemed a => WF

So adjusting this issue to be only a "way to filter and search" content on the MRU; and would expect it should be available both on initial launch from the StartCenter but also at any time via the "Recent Documents" menu list, and not limited to the StartCenter UI.
Comment 2 Heiko Tietze 2021-08-09 13:40:43 UTC
Set to WF in bug 72671 but duplicate at bug 80934 (in discussion).

*** This bug has been marked as a duplicate of bug 80934 ***