Bug 144060 - Writer process hangs sometimes on macOS 11.4 on MacBook Air M1 (Intel version, Zotero uninstalled)
Summary: Writer process hangs sometimes on macOS 11.4 on MacBook Air M1 (Intel version...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected) rc
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2021-08-24 16:35 UTC by David W. Snow
Modified: 2023-07-22 03:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

The file that hangs some times. (1.29 MB, application/vnd.oasis.opendocument.text)
2021-08-25 14:33 UTC, David W. Snow
Big File (3.71 MB, application/vnd.oasis.opendocument.text)
2022-05-23 21:48 UTC, David Snow

Note You need to log in before you can comment on or make changes to this bug.
Description David W. Snow 2021-08-24 16:35:32 UTC
LibreOffice version

I have an 80 page LibreOffice Writer file that occasionally hangs and I have to kill the process. I am running macOS 11.4 on an 8GB 2020 MacBook Air with Apple Silicon.  I am not using any Java, macros, etc., and have reset the profile.

I do not have this problem running the Intel x86 version.

What information can I provide that will help you troubleshoot this?
Comment 1 steve 2021-08-25 08:37:53 UTC
Thanks for the report. So the problem is isolated to this single writer file or are all writer files affected? If isolated to single file, providing a sanitized version of the file would be crucial to reproduce and fix the problem.

Could be worth updating macOS to 11.5.2 as with Apples poor documentation or rather non-existing changelog it is really hard to tell which macOS bugs were fixed in the meantime and see if the problem is persisting then.
Comment 2 Alex Thurgood 2021-08-25 14:13:40 UTC
Given that the M1 MacbookPro I have seemingly randomly crashes completely and reboots, irrespective of the application I'm using (but usually when there's a lot of swapping to disk or file re-indexation going on), this might not be a LibreOffice problem per se.

I haven't seen any hangs with LO Writer like the original poster describes though, but I don't have many 80 page documents.

@David : what does the document contain ? Just text, or loads of images, or tables, or references ?

The difficulty will be nailing down what triggers the hang.
Comment 3 David W. Snow 2021-08-25 14:30:53 UTC
The file is an 80-page template for a technical book. It is mostly text using several named styles. There are only 4 images, 1 table other than TOC, LOF, etc.

This is the primary file I am working on, so all hangs have been on this file.

If your M1 mac hangs and crashes, then your Apple Silicon experience is different than mine. In the 5 months that I have been using mine, I have had no OS crashes and LibreOffice never hung using the x86 LibreOffice image, except when LanguageTools was being used. No other app (native or x86) has hung. Even Windows for ARM runs nicely under Parallels! 

I will attach the file to the report.
Comment 4 David W. Snow 2021-08-25 14:33:54 UTC
Created attachment 174533 [details]
The file that hangs some times.

Has hung 4 times since I switched to the Apple Silicon version 2 days ago.
Comment 5 David W. Snow 2021-08-25 14:35:08 UTC Comment hidden (obsolete)
Comment 6 Alex Thurgood 2021-08-25 15:12:03 UTC Comment hidden (obsolete)
Comment 7 Alex Thurgood 2021-08-26 08:44:30 UTC
@David : so far, moving around in the document, playing with various bits hasn't yet caused a crash for me.

I do note that the document contains a fairly large number of custom styles (paragraph, character, and page). Whether any one of these in particular causes an issue, I really don't know.

I also see what appear to be references to Zotero. Are you using Zotero at the same time ?

Additionally, are you using LanguageTool ?

Any Java-based extensions or tools that require LO to instantiate a JVM are potentially fragile and might possibly lead to crashing.

Unfortunately, as yet, I'm still none the wiser.

When LO hangs and you kill it, do you get an Apple Stack Trace window asking you to report the application to Apple ? If so, it might be worthwhile copying the output of that display to a text file and uploading it as an attachment to this bug report.
Comment 8 David W. Snow 2021-08-27 17:33:14 UTC
Zotero isn't running.  I only have it running when I am working with references.

No Java tools or LanguageTools. In fact, Preferences/Advanced is greyed-out and you can't select a Java JVM!

The next time it hangs, I will try to get a stack trace.

I switched back to the Apple Silicon version and edited it for 2 hours today. It didn't hang once, but it did crash while I was adjusting the page sizes. It was on the 9th page-size adjustment--- not every time. That was the only crash. 

When I exited out of one file, the other two open files required recovery. So they must have also crashed---but I got no notice.

I will continue to backup regularly and use the Apple Silicon version while trying to capture what I was doing when it hangs or crashes next.
Comment 9 QA Administrators 2021-08-28 03:54:56 UTC Comment hidden (obsolete)
Comment 10 Alex Thurgood 2021-08-28 07:10:57 UTC Comment hidden (obsolete)
Comment 11 Alex Thurgood 2022-03-02 12:05:02 UTC
(In reply to Alex Thurgood from comment #10)
> @David
> The Arm version contains no Java functionality support whatsoever, so
> anything that might attempt to instantiate such functionality could
> potentially cause a crash. This is the case even if you're not directly
> using a given extension.

The above comment is now obsolete, the Arm version of LO now supports Oracle JDK 17.
Comment 12 Julien Nabet 2022-05-21 12:37:25 UTC
Just for the test, if you completely uninstall Zotero, do you still have hangs?
Also do you stick to Apple Silicon version of LO or did you revert to Intel version?

I ask all this because it seems there might be several dups:
- tdf#149016
- tdf#149101
- tdf#149202
- tdf#149210
Comment 13 David Snow 2022-05-23 17:10:12 UTC
The report is 9 months old.  I do not remember the exact conditions.
I am currently several versions of LO later. I now only use the Intel vesion on my 2020 MacBook Air M1, since it hangs much less frequently than in Apple Silicon one does. I have removed Zotero.
Comment 14 Julien Nabet 2022-05-23 17:18:37 UTC
I changed the title and hardware since you switched back to Intel LO.

About the remaining hangs, there may be several causes:
- network printer
- network disk
- accessibility stuff enabled
You can give a try first at https://wiki.documentfoundation.org/QA/FirstSteps.

Finally does it hang at random or on some specific actions or on specific documents?
Comment 15 David Snow 2022-05-23 17:30:01 UTC
No network printers, no network disks. Accessability enabled.
Comment 16 Julien Nabet 2022-05-23 17:52:53 UTC
Ok so not network related.

If possible, you can try to disable accessibility just for some time, eg if the hang happens at least once per day, try to disable accessibility during 2 days (of course if it still hangs with the same frequency, you can stop the test and re-enable accessibility).

You can also try to get a stacktrace or any debug info (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#macOS:_How_to_get_debug_information) it could help too.
Comment 17 David Snow 2022-05-23 21:47:12 UTC
I just went back fixing typos in my 80 page document on the Intel version of In 15 minutes of simple editing it hung!

I have a recent profile, no Zotero, no languagetools. Java= AdoptOpenJDK 11.0.11, but nothing uses Java that I know of.

I'll attach the file. MacOS was 12.4 and it DID NOT offer me a chance for a crash dump or I would have attached it.
Comment 18 David Snow 2022-05-23 21:48:44 UTC
Created attachment 180320 [details]
Big File
Comment 19 Julien Nabet 2022-05-24 07:03:02 UTC
Did you try with accessibility disabled?

If it can help, here's an old questionnaire from Alex about this which is about crash but could perhaps apply to hangs:
1) Do you have any accessibility features enabled? Apple’s accessibility
features like “VoiceOver” or “Enable access for assistive devices”, which get
enabled in “System Preferences > Universal Access”, are known to cause many crashes and freezes in LibreOffice. So please try to disable any accessibility features, then check if the problem is still reproducible.

2) Do you have installed any window management/user interface utilities/apps/control panels/extensions for Mac OS X like
   * AquaSnap                * BetterSnapTool
   * BetterTouchTool         * Breeze
   * Cinch                   * Divvy
   * DoublePane              * Flexiglass
   * HyperDock               * iSnap
   * Moom                    * RightZoom
   * ShiftIt                 * SizeUp
   * SizeWell                * Spectacle
   * Stay                    * TileWindows
   * WindowTidy              * Flavours (from flavours.interacto.net)
... or something similar?

And/or do you use any mouse cursor/pointer utility, i.e. some little application or control panel etc. which animates or replaces etc. the mouse curser/pointer, like
   * LazyMouse?

And/or do you use any special software which could be related to accessibility stuff, e.g. a screen reader, screen magnifier, speech recognition software,
a text-to-speech (dictation) application, or similar?

All these and many similar utilities rely heavily on Mac OS accessibility features and therefore can cause LibreOffice to crash or freeze. So please check if you have installed any utility of this kind and try to disable it
(or to add LibreOffice to the list of excluded applications for the utility,
if there is such a thing).

There are other leads to think about:
- fonts: some specific ones give some rendering pbs to LO.
- comments: you can make a backup and remove all the comments to try

1 thing you can try, above all if your file is several years old, is to copy the whole content and paste it in a brand new odt file.
Indeed, with the years some bugs may have been fixed but their effects may have remained in your file.
Comment 20 David Snow 2022-05-24 15:04:54 UTC
1. I had “Preferences | Keyboard | Dictation” enabled because I tried it, but don’t use it. I turned it OFF. I do have enabled macOS’ text to speech enabled as it is a good way to catch grammar errors.  NO other accessibility features are enabled.

2. No windows management apps installed.

3. No mouse utilities installed. My Logitech mouse looks like an Apple mouse without the gestures and much longer battery life ;=}

4. While I am sure that my systems has fonts installed by other apps such as Affinity Photo. In my LibreOffice documents I only use those that ship with LO with on exception Google Handlee cursive font. The Headings and text are Noto Sans and Noto Serif.

5. I do have several comments in this document. I will create a test version and remove all comments and edit the hell out of the test document.

6. I just copied and pasted the old document into a new one. There had been 1242 revisions of the old document.

I’ll do some testing and re-comment in a few days
Comment 21 David Snow 2022-05-24 17:41:24 UTC
Your idea of copying the whole document and pasting it into a new one has some bad consequences!  Page sizes and margins are not copied for all page types!
I do not know what else is randomly lost in the process. Since I only 6 page styles this won't take too long to fix. But locating any other parameters that get lost might take a while ;=}
Comment 22 Julien Nabet 2022-05-25 21:13:44 UTC
(In reply to David Snow from comment #21)
> Your idea of copying the whole document and pasting it into a new one has
> some bad consequences!  Page sizes and margins are not copied for all page
> types!
> I do not know what else is randomly lost in the process. Since I only 6 page
> styles this won't take too long to fix. But locating any other parameters
> that get lost might take a while ;=}

I understand but perhaps there's something buggy in the styles in the original file.
Just for curiosity, even if you won't use it, do you also have hangs with the new file?
Comment 23 Alex Thurgood 2022-05-27 14:49:10 UTC
(In reply to David Snow from comment #20)
> 1. I had “Preferences | Keyboard | Dictation” enabled because I tried it,
> but don’t use it. I turned it OFF. I do have enabled macOS’ text to speech
> enabled as it is a good way to catch grammar errors.  NO other accessibility
> features are enabled.

Please try turning off that accessibility feature (text-to-speech) and report back whether the document still causes a crash.
Comment 24 David Snow 2022-05-29 16:31:23 UTC
Turning Off text-to-speech had no noticeable effect. Still crashes randomly when editing.  I still have maybe 20 comments in the file and I don't want yo use them.
Comment 25 Alex Thurgood 2022-12-22 08:52:19 UTC
@David : please try with a 7.5beta pre-release, or a daily developer 7.6alpha build and report back.
Comment 26 QA Administrators 2023-06-21 03:13:56 UTC Comment hidden (obsolete)
Comment 27 QA Administrators 2023-07-22 03:18:09 UTC
Dear David W. Snow,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team