Bug 144410 - UI Autofilter dropdown does not indicate that color filtering options are submenus
Summary: UI Autofilter dropdown does not indicate that color filtering options are sub...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.3.0.0.beta2 target:7.4.0 tar...
Keywords:
: 144808 (view as bug list)
Depends on:
Blocks: AutoFilter-Color
  Show dependency treegraph
 
Reported: 2021-09-09 12:55 UTC by NISZ LibreOffice Team
Modified: 2021-12-13 19:06 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot of the autofilter dropdown in Calc (8.12 KB, image/png)
2021-09-09 12:55 UTC, NISZ LibreOffice Team
Details
screenshot of fix on Ubuntu (15.65 KB, image/png)
2021-11-29 07:19 UTC, Adolfo Jayme Barrientos
Details
video (311.62 KB, video/mp4)
2021-12-02 20:18 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-09-09 12:55:36 UTC
Created attachment 174928 [details]
Screenshot of the autofilter dropdown in Calc

When there are colored cells and text in a spreadsheet and an autofilter is added to a column, it is now possible to filter for those colors in a submenu of the autofilter.
However the dropdown menu does not indicate that these color selectors would appear as a submenu, like the main menu does.
This feels somewhat confusing and counter-intuitive.

Steps to reproduce:
    1. Open attachment 173241 [details] from bug 142965
    2. Open the autofilter dropdown in column A

Actual results:
The “Text color” and “Background color” items don’t have a right pointing arrow that would indicate they have a submenu, which they in fact have one.

Expected results:
The Text color and Background color items should have a right pointing arrow, like submenus in the main menu have.
See also attachment 173056 [details] for how it looks in Excel for example.

LibreOffice details:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c7b5e6566d9b24a0a996c739a945004d9aadee2f
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 1 NISZ LibreOffice Team 2021-09-09 12:56:21 UTC
@Samuel I thought you might be interested in this one.
Comment 2 kabilo 2021-09-09 13:33:41 UTC
Hi, I am adding a proposal for possible improvements (Bug 142761 - optimization of the ergonomics and appearance of the automatic filter menu)
Comment 3 Samuel Mehrbrodt (allotropia) 2021-09-14 07:04:07 UTC
Yep this needs some more attention.
I think Caolan mentioned that he plans to rework the popup anyway?
Comment 4 Heiko Tietze 2021-09-30 08:56:50 UTC
*** Bug 144808 has been marked as a duplicate of this bug. ***
Comment 5 Commit Notification 2021-11-27 19:57:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/062d59faff1702b73c1a21181c484c05d77f957f

Related: tdf#144410 we don't want a gap in a multicol spanning separator

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2021-11-27 20:11:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f28ef77210b1a3cc737689c7a4ae099419cb0493

Related: tdf#144410 we don't want a gap in a multicol spanning separator

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-11-27 21:24:40 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d272bf4f8f3a083b8c37f7b10f89cd2bf76b7d21

Resolves: tdf#144410 show submenu indicator for color filtering options

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2021-11-27 21:24:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/0c6b8585ce6e20f0045628ed209abddada8c2766

Resolves: tdf#144410 show submenu indicator for color filtering options

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2021-11-28 17:44:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/2eefc29b53b01dc07eb62aeb42cd56f178370d1d

Resolves: tdf#144410 show submenu indicator for color filtering options

It will be available in 7.2.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Adolfo Jayme Barrientos 2021-11-29 07:19:24 UTC
Created attachment 176558 [details]
screenshot of fix on Ubuntu

Verified with:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: b2c56ac95b15b675b9fabed889e7f9709bdc793f
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: es-MX (es_MX.UTF-8); UI: en-US
Calc: threaded
Comment 11 BogdanB 2021-12-02 20:18:49 UTC
Created attachment 176658 [details]
video

Not working well on Linux. See the video.

I tried again with a fresh user profile and no change. itțs because of gtk3?

Version: 7.3.0.0.beta1+ / LibreOffice Community
Build ID: 81b26582ed62db40e2be701ddefede7d8230d0d2
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 12 Caolán McNamara 2021-12-02 20:31:13 UTC
it works fine under gtk3 on wayland, but there is a glitch under x11. I have a follow up patch for this in gerrit, but the outage there has delayed pushing it: https://gerrit.libreoffice.org/c/core/+/126203 wait a bit until I can push that
Comment 13 Commit Notification 2021-12-02 21:47:14 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/3a59d0504de22aee5bdb2d61e482fa8d87cd48ff

Related: tdf#144410 submenu indicator misplaced under x11 gtk

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-12-02 22:06:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/66e4ffd27fae894ae67ee7337a490aab18e56562

Related: tdf#144410 submenu indicator misplaced under x11 gtk

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Christian Lohmaier 2021-12-06 13:29:54 UTC
7.2.4 was a hotfix release, updating target in status-whiteboard
Comment 16 Commit Notification 2021-12-08 17:11:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/4f081b94a47acd8f4b59d305a6a272174a342ac3

Related: tdf#144410 excessive "resize" triggered

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2021-12-08 17:11:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4586a09c8b12e5a185f022b059f2b9b1ba79d5bb

Related: tdf#144410 excessive "resize" triggered

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 BogdanB 2021-12-13 19:06:11 UTC
Nice.
Working now.
Great job!

Version: 7.3.0.0.beta1+ / LibreOffice Community
Build ID: ecfb83d7463bed7c89baeccc03286c1ac9956d70
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded