Bug 144425 - UI In Email merged document dialog it’s possible to select 0 as range
Summary: UI In Email merged document dialog it’s possible to select 0 as range
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Gabor Kelemen (allotropia)
URL:
Whiteboard: target:7.3.0 target:7.2.2
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Mail-Merge
  Show dependency treegraph
 
Reported: 2021-09-10 07:59 UTC by NISZ LibreOffice Team
Modified: 2021-09-14 09:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example mail merge document from Writer 7.3 master (14.00 KB, application/vnd.oasis.opendocument.text)
2021-09-10 07:59 UTC, NISZ LibreOffice Team
Details
Example data source from Calc (13.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-09-10 07:59 UTC, NISZ LibreOffice Team
Details
Screenshot of the problematic minimum value in Writer (33.23 KB, image/png)
2021-09-10 08:00 UTC, NISZ LibreOffice Team
Details
Screenshot of the hanging send process in Writer. (72.89 KB, image/png)
2021-09-10 08:00 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NISZ LibreOffice Team 2021-09-10 07:59:28 UTC
Created attachment 174941 [details]
Example mail merge document from Writer 7.3 master

In the Email merged document dialog it is possible to set the mails to be sent as From or to 0th record, which causes a hang during the send process.

Steps to reproduce:
    1. Set up a mail merge document with the attached files
    2. In the Mail Merge toolbar press the Send Email Messages button
    3. In the Email merged document dialog observe that the default value of the From field is 0 and the To field can be set to 0 as well

Actual results:
If you try to send the merged mails with the Send all documents option or with the From option having 0 value, the send process will hang with sending mail 0 from 4. The documents (3 for the 3 records) are merged for sending correctly.

Expected results:
The mails should be sent correctly.

LibreOffice details:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: c7b5e6566d9b24a0a996c739a945004d9aadee2f
CPU threads: 4; OS: Windows 10.0 Build 18363; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL


Additional Information:
This regressed into unusability in several steps:
In 7.2 the default Send all documents option started to cause this hang after 

commit	ec44f87d5b99a3299322d0b79abc4c6808877865	[log]
author	Balazs Varga <balazs.varga991@gmail.com>	Mon Mar 22 13:34:37 2021 +0100
committer	László Németh <nemeth@numbertext.org>	Wed Mar 31 12:24:22 2021 +0200

tdf#117212 sw mailmerge: merge only the selected range

In 7.1 the default value of the From field became 0 instead of 1 on non-GTK3 vclplugs with:

author	Caolán McNamara <caolanm@redhat.com>	2020-05-26 19:43:12 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2020-05-27 17:42:19 +0200
commit	d9fa826769cd570814f3556d53493a78d2869873 (patch)

tdf#133396 FormattedField comes with differrent defaults than GtkSpinButton

Before that in 6.2 the From and to boxes became spinboxes, thus making it a bit easier to set 0, but it was possible to enter 0 in 6.1 and before too.
Note: the other two dialogs, Print merged document and Save merged document do not allow setting 0 in the From and To spinboxes since they got welded in 6.2.

author	Caolán McNamara <caolanm@redhat.com>	2018-10-18 09:52:28 +0100
committer	Caolán McNamara <caolanm@redhat.com>	2018-10-18 15:09:12 +0200
commit	f1ca64800074530d95e507f93c764a687310b9eb (patch)

weld SwMMResultEmailDialog
Comment 1 NISZ LibreOffice Team 2021-09-10 07:59:53 UTC
Created attachment 174942 [details]
Example data source from Calc
Comment 2 NISZ LibreOffice Team 2021-09-10 08:00:12 UTC
Created attachment 174943 [details]
Screenshot of the problematic minimum value in Writer
Comment 3 NISZ LibreOffice Team 2021-09-10 08:00:44 UTC
Created attachment 174944 [details]
Screenshot of the hanging send process in Writer.

Note that it tries to send 4 mails with only 3 records in the data source.
Comment 4 Commit Notification 2021-09-10 08:15:57 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e85aaaecb5479660aa0cf600564ee3caa470aa3d

tdf#144425 Set sane lower bounds (1) for MM e-mail output ranges

It will be available in 7.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2021-09-13 06:22:14 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/3d60adcece5add26f0db59fc6c1e3c87472f697f

tdf#144425 Set sane lower bounds (1) for MM e-mail output ranges

It will be available in 7.2.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 NISZ LibreOffice Team 2021-09-14 09:41:54 UTC
Verified in: 

Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 80a47aae1419842f4496f02028e2b49763aea25b
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded