Bug 145929 - Crash swlo!sw::MetaFieldManager::getDocumentProperties+0x886c (like related to SwFntCache)
Summary: Crash swlo!sw::MetaFieldManager::getDocumentProperties+0x886c (like related t...
Status: RESOLVED DUPLICATE of bug 145321
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, haveBacktrace, regression
Depends on:
Blocks: Crash
  Show dependency treegraph
 
Reported: 2021-11-28 12:01 UTC by Telesto
Modified: 2022-04-04 08:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
BT without symbols (30.19 KB, text/plain)
2021-11-28 12:02 UTC, Telesto
Details
Example file (2.94 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2021-11-28 12:21 UTC, Telesto
Details
bt with debug symbols (9.78 KB, text/plain)
2021-11-28 12:39 UTC, Julien Nabet
Details
bt with debug symbols (10.28 KB, text/plain)
2021-12-16 19:57 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2021-11-28 12:01:29 UTC
Description:
Crash swlo!sw::MetaFieldManager::getDocumentProperties+0x886c

Steps to Reproduce:
1. Open the attached file (DOCX export of bug 135092)
2. Edit -> Track Changes -> Accept all
3. Press and hold page down to bottom (can crash here)
4. Press page up (does crash)

Actual Results:
Crash

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: ddc57169ac8d1de00403dbb09fef5221beaa0f3d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2021-11-28 12:02:38 UTC
Created attachment 176547 [details]
BT without symbols
Comment 2 Roman Kuznetsov 2021-11-28 12:09:29 UTC
Telesto, there is no the DOCX file in attach. Please add it
Comment 3 Telesto 2021-11-28 12:21:26 UTC
Created attachment 176550 [details]
Example file
Comment 4 Telesto 2021-11-28 12:22:12 UTC
Same crash type for bug 145930
Comment 5 Julien Nabet 2021-11-28 12:39:23 UTC
Created attachment 176551 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today + gen rendering I could reproduce this.

Roman: I exported the odt file from the other bugtracker in docx and used the docx here.
Comment 6 Telesto 2021-12-16 15:56:51 UTC
No crash for me with
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: deea3b7471c3dab0220eca6146c225a2d47681a2
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 7 Julien Nabet 2021-12-16 19:57:08 UTC
Created attachment 176973 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I got an assertion.
Comment 8 Julien Nabet 2021-12-16 20:08:07 UTC
László: thought you might be interested in this one. (see last bt retrieved).
(build with 42448f48bb48a13d6618a181b12840db6d85c574)
Comment 9 Xisco Faulí 2022-01-14 16:05:22 UTC
Not reproducible in

Version: 7.0.0.0.alpha1+
Build ID: 574c57090642347980d2395e1e183cc7b5c171ad
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded
Comment 10 Xisco Faulí 2022-01-14 16:13:32 UTC
Actually this looks pretty similar to bug 145321

*** This bug has been marked as a duplicate of bug 145321 ***