Bug 147954 - Use a subtle gradient with darker colors for the application background (behind the page "sheets")
Summary: Use a subtle gradient with darker colors for the application background (behi...
Status: RESOLVED DUPLICATE of bug 125217
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: UI-Theming UI
  Show dependency treegraph
 
Reported: 2022-03-13 04:13 UTC by Jeff Fortin Tam
Modified: 2022-03-16 12:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
side-by-side screenshots mockup (275.31 KB, image/png)
2022-03-13 04:13 UTC, Jeff Fortin Tam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Fortin Tam 2022-03-13 04:13:54 UTC
Created attachment 178853 [details]
side-by-side screenshots mockup

See attached screenshot, which will explain better than a thousand words. Side by side: current default look (left), vs proposed variant 1 (center) or variant 2 (right).

In short: the current thite "application background" color, that sits behind the white page in LibreOffice Writer (and other applications like Impress) is unpleasant to look at, and lacks some visual refinement. The problems:

* Not enough contrast vs the white page. White on white, with a barely visible shadow around the page.
* A large white surface, especially when the page is zoomed out (instead of "fit to width") rips my eyes out at nighttime.
* A gradient instead of a solid color would look more elegant and refined.

I know, I know, people will compare that to the "other office suite", but even if they hadn't done that a decade ago, I would have suggested this anyway.

Attached is my simulation of a gradient-based application background, for the light theme. I haven't bothered simulating such gradients for a "dark theme" of LibreOffice, but I could if you actually care.

The gradients are meant to be subtle / low-contrast, and span the entire height. Not pure white to pure black, but gray to gray (if I went too dark with this, you wouldn't see the page shadows nor the ruler/tab-stop elements).

Advantages of this:

* Better contrast between the application background and the page
* Slightly easier on the eyes at night
* Looks more "intentional" as a design; solid colors don't work really well there on such a huge surface and make the app look dated. Gradients give it some illusion of "depth".
* Better contouring of the toolbars, even if they were to have some border/shadows by themselves (see also bug #141147 for the feature request around that), as they would stand out more from the app background. Whether or not they can paint such shadows may influence the direction of the app background's gradient, thus variant 1 or variant 2.

It's not a pure dark background in terms of eye relief (you might want to have a variant of the chosen gradient for LibreOffice's dark/night theme), but it's certainly better than pure white or solid gray when it comes to the light theme!
Comment 1 Jeff Fortin Tam 2022-03-13 04:22:32 UTC
Note that thumbnail-sized images are deceiving; you need to zoom attachment #178853 [details] to full size to avoid the impression that the gradients would look "too strong" (which is the impression you get from afar at thumbnail sizes)...
Comment 2 Mike Kaganski 2022-03-13 05:50:18 UTC
Note how bug 127508 removed gradients from Calc's UI elements.
Comment 3 Jeff Fortin Tam 2022-03-13 13:20:47 UTC
Indeed, and I would have advocated for the same thing regarding the spreadsheet's headers; I did not see value in that fake "glossy" shine effect that was on the spreadsheet headers, because it was executed as an in-your-face hard gloss effect and it was disturbing the ability to read the text of those headers (through reduced contrast between the font color and the background). Maybe if those headers had used a _subtle_ smooth gradient to give a rounded, more "button-like" feel, I could have preferred that to fully flat, but fully flat still works OK in that case anyway.

The proposed gradient for the application background area, however, is not the same thing, and does not exhibit the same problem. The application background does not have text whose legibility it could harm, is not a confined space (so gradients have a LOT of "length" to dissipate smoothly) and it is a very large empty area that emits a lot of light from the screen, yet from my experience just setting it as a solid dark gray or black makes the UI look very odd and unrefined (in part because there are no visible shadows from the page and toolbars then). Gradients here also let you use tones of gray that are still compatible with the notion of of page shadows emerging from them, instead of blending into them entirely.
Comment 4 V Stuart Foote 2022-03-13 13:56:29 UTC
-1, the 'Application background' will already pick up an appropriate color from os/DE theme when set 'automatic'.

It can be adjusted to user preference from normal color picker with any color theme user chooses.

And, we now provide both a default 'LibreOffice' and 'LibreOffice Dark' color scheme as well as ability for use to save their own custom color scheme(s).

UI with gradients are highly subjective as to appeal--project is better served by UI with simple area color fills.

So, IMHO just no.
Comment 5 Adolfo Jayme Barrientos 2022-03-14 04:46:08 UTC
I’d like to propose a middle ground between Jean-François’ and Stuart’s positions: a very subtle version of Variation 1. I don’t think it would be out of place in a world that thankfully is starting to wake up from the mistake Flat Design was.

BTW, this reminds me of this old whiteboard: https://wiki.documentfoundation.org/Design/Whiteboards/DocumentBackground#Item_.22Application_Background.2C_Gradient.22
Comment 6 Heiko Tietze 2022-03-14 07:47:40 UTC
My take: allow customization with gradients, tiled bitmaps, hatches etc. via "Personalization", see bug 125217, but by default we should remain plain and boring.

I'm not aware of any serious application with special designs and you will become tired of looking at the gradient.

But what we should do is to use a realistic shadow for the document canvas.
Comment 7 Mike Kaganski 2022-03-14 08:10:58 UTC
(In reply to Heiko Tietze from comment #6)
+1 (personally I don't care about realistic shadows, but it is not a problem if someone wants to improve that aspect)
Comment 8 Heiko Tietze 2022-03-15 10:04:48 UTC
To summarize, the idea was not accepted but would be an option for personalization. Making it a duplicate.

*** This bug has been marked as a duplicate of bug 125217 ***
Comment 9 Adolfo Jayme Barrientos 2022-03-16 12:39:39 UTC
I don’t see how this https://wiki.documentfoundation.org/images/4/4a/2011-04-02_DocumentBorder_Idea_1_Plain_DocumentShadow_ApplBackground-Gradient.png goes against the principle of a vanilla interface, nor how it has to do with the “Personas” system