Bug 148115 - Tooltips are being rendered with artifacts (flashing, blinking, zooming...)
Summary: Tooltips are being rendered with artifacts (flashing, blinking, zooming...)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.3
Keywords:
Depends on:
Blocks: KDE Tooltip
  Show dependency treegraph
 
Reported: 2022-03-21 15:05 UTC by Rafael Lima
Modified: 2022-04-19 13:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video showing the bug (1.12 MB, video/mp4)
2022-03-21 15:05 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2022-03-21 15:05:40 UTC
Created attachment 179009 [details]
Video showing the bug

Hi, I have been having several issues when LibreOffice has to render tooltips.

In the attached video, I show an example where I hover the mouse over the comments in the Navigator, which would show me the tooltips with the text in the comment box. However, rendering the tooltips results in all kinds of artifacts. Some of them remain blinking, whereas some get a zoom (or stretch) effect. Some never disappear from the screen.

Note that this rendering issue occurs in any tooltip and is most visible when I enable "extended tooltips".

I have been having this problem for a long time, at least since 7.0, but just now I decided to report it. I experience this issue in multiple computers, but all of them using KDE.

Can anyone else confirm this issue?

System info:
Version: 7.3.1.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.3.1~rc3-0ubuntu0.21.10.1~lo2
Calc: threaded
Comment 1 Rafael Lima 2022-04-11 19:24:03 UTC
@Jan-Marek I believe this issue may be Qt-related. I do not see it happening in "gen" or in "gtk3". Would you mind taking a look?

This happens when the user hover over many widgets very quickly, and some tooltips simply forget to disappear, or they start blinking.

This issue is easier to reproduce with "Extended tips" on (Tools - Options - LibreOffice - General - Extended tips).
Comment 2 Jan-Marek Glogowski 2022-04-11 23:02:04 UTC
I could reproduce the problem with very fast mouse movements, like in the video. Handling tooltips delayed via the main event loop seem to work better.
Comment 3 Michael Weghorn 2022-04-12 07:14:33 UTC
Can reproduce with Qt's xcb platform integration, but doesn't seem to be a problem with the wayland one (where tooltips misbehave differently though, e.g. often open at a wrong location, which doesn't seem to be LO-specific, though, since I see the same e.g. in Okular).

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 657de2818468253aae65f49e5f37f5dcd3fc0938
CPU threads: 12; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 657de2818468253aae65f49e5f37f5dcd3fc0938
CPU threads: 12; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 4 Commit Notification 2022-04-12 12:09:20 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/af6dd54d53eee0d0de1164bff0a77c6b433b3935

tdf#148115 Qt handle tooltips via event loop

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Rafael Lima 2022-04-12 16:56:39 UTC
Nice fix, thanks! Verified with:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 2b44f9490853c9de5a0e92c41fdc1279b6c91e06
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: CL
Comment 6 steve 2022-04-13 10:55:18 UTC
*** Bug 105433 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2022-04-13 20:32:11 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/7fc871299080427587307932c505d3ae93d6a357

tdf#148115 Qt handle tooltips via event loop

It will be available in 7.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-04-19 10:59:40 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-7-3-3":

https://git.libreoffice.org/core/commit/421abb60875e88432f5d0c6ad4d6dbd8e483647f

tdf#148115 Qt handle tooltips via event loop

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.