Bug 105433 - UI - Tooltip flickers annoyingly in dialogs when overlaid over another hierarchically superior dialog
Summary: UI - Tooltip flickers annoyingly in dialogs when overlaid over another hierar...
Status: REOPENED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 107596 121240 (view as bug list)
Depends on:
Blocks: Flickering-UI
  Show dependency treegraph
 
Reported: 2017-01-19 07:53 UTC by Alex Thurgood
Modified: 2021-02-18 11:15 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
flashing tooltip (1.08 MB, image/gif)
2020-02-18 02:16 UTC, So
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2017-01-19 07:53:29 UTC
Description:
The tooltip "List the existing macros and dialogs" flickers rapidly and annoyingly (my guess is at the refresh rate of the screen) when the Basic Macro Organizer dialog is overlaid over the Basic Macros dialog. As this is the default when the dialog is opened, it is particularly distracting and annoying. 

Steps to Reproduce:
1. Start LibreOffice, open a Writer document.
2. Tools > Macros > Organize Macros > LibreOffice Basic
3. Click on the Organizer button

Actual Results:  
As the mouse cursor moves over any of the libraries, the tooltip is displayed and it flickers annoyingly. The flicker disappears if the dialog window is moved outside of the Basic Macros dialog window

Expected Results:
The tooltip should not flicker.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Alex Thurgood 2017-01-19 10:35:18 UTC
Also present in 

Version: 5.1.6.2
Build ID: 07ac168c60a517dba0f0d7bc7540f5afa45f0909
Threads CPU : 2; Version de l'OS :Mac OS X 10.12.2; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group


I might have forgotten to mention that you need to enable Tooltips under Preferences on OSX (or Tools>Options on other OSes)
Comment 2 Alex Thurgood 2017-01-19 10:40:33 UTC
I can also reproduce this behaviour in the Spelling and Grammar dialog, by opening the Options dialog window over the top of the Spelling and Grammar dialog.

Changed title accordingly. Affects dialogs where the the sub-dialog is overlaid over the hierarchically superior dialog.
Comment 3 Alex Thurgood 2017-01-19 10:44:42 UTC
Also reproducible in 

Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 4 Alex Thurgood 2017-01-19 10:51:00 UTC
Problem also present in 

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

Inherited from OOo
Comment 5 Yousuf Philips (jay) (retired) 2017-01-19 11:02:46 UTC
In addition to having 'extended tooltips' enabled you also need to have help installed. :D

So i tested 5.0, which i have help installed for, and dont see the issue, so its possibly an osx only issue.

Version: 5.0.3.2
Build ID: 1:5.0.3~rc2-0ubuntu1~trusty2
Locale: en-US (en_US.UTF-8)

@Steve: Can you check this out to confirm?

@Alex: Could this be a OSX version issue on a newer release?
Comment 6 Cor Nouws 2017-01-19 14:34:28 UTC
(In reply to Alex Thurgood from comment #0)

> Actual Results:  
> As the mouse cursor moves over any of the libraries, the tooltip is
> displayed and it flickers annoyingly. The flicker disappears if the dialog
> window is moved outside of the Basic Macros dialog window

One must have Extended Tooltips activated (Tools > Options > LibreOffice > General)

In my version (Ubuntu Linux, 5.4 master) the tooltip is poping up irregular, but no constant annoying flickering.
Comment 7 steve 2017-01-19 16:14:04 UTC
confirmed and yes this is annoying.

Version: 5.4.0.0.alpha0+
Build ID: 9e7526044c8fa6b006b0cb791d15f2476c96ebf2
CPU Threads: 4; OS Version: Mac OS X 10.12.2; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-01-14_04:23:59
Locale: de-DE (de_DE.UTF-8); Calc: group

→ NEW
Comment 8 Yousuf Philips (jay) (retired) 2017-02-04 13:58:02 UTC
@Alex, @Steve: If you can do a screencast, that would be great.
Comment 9 steve 2017-02-05 22:14:58 UTC
workforme w Version: 5.4.0.0.alpha0+
Build ID: 789ed159fb03eef26c991f361380d0eb7b509cd9
CPU Threads: 4; OS Version: Mac OS X 10.12.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-02-03_01:08:49
Locale: de-DE (de_DE.UTF-8); Calc: group

@Alex: please verify and re-open if I am mistaken.
Comment 10 Alex Thurgood 2017-02-06 11:15:44 UTC
I can still reproduce this in

Version: 5.4.0.0.alpha0+
Build ID: 6c4310cc176c02624f5fa94fb50fec6050ce904b
CPU Threads: 2; OS Version: Mac OS X 10.12.2; UI Render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group


My test version is possibly just slightly older than yours (by a day or so). Will rebuild and test again.
Comment 11 Alex Thurgood 2017-02-06 12:34:56 UTC
For repro steps, tooltips need to be activated.
Comment 12 Alex Thurgood 2017-05-03 13:42:07 UTC
*** Bug 107596 has been marked as a duplicate of this bug. ***
Comment 13 Alex Thurgood 2017-07-24 08:09:03 UTC
This behaviour is still happening in 5342
Comment 14 Alex Thurgood 2017-09-15 11:35:50 UTC
Still present in 

Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: fr-FR (fr_FR.UTF-8); Calc: group
Comment 15 Alex Thurgood 2018-11-07 15:05:17 UTC
Still present in

Version: 6.2.0.0.alpha1+
Build ID: 740b99783b5480fcd1e5fce7c1beb5967d015041
CPU threads: 8; OS: Mac OS X 10.14; UI render: default; VCL: osx; 
Locale: fr-FR (fr_FR.UTF-8); Calc: threaded
Comment 16 Alex Thurgood 2018-11-07 15:05:38 UTC
*** Bug 121240 has been marked as a duplicate of this bug. ***
Comment 17 QA Administrators 2019-11-08 03:37:57 UTC Comment hidden (obsolete)
Comment 18 Roman Kuznetsov 2019-11-17 12:30:04 UTC
I don't see any toolips in that dialog in


Version: 6.5.0.0.alpha0+
Build ID: d04eef858250f97690f32dba17f42d157a8767fc
CPU threads: 4; OS: Mac OS X 10.15.1; UI render: default; VCL: osx; 
Locale: ru-RU (ru_RU.UTF-8); UI-Language: en-US
Calc: threaded

Alex, can you retest it in latest master?
Comment 19 Alex Thurgood 2019-12-02 12:45:06 UTC
No repro any more with

Version: 6.3.3.2
Build ID: a64200df03143b798afd1ec74a12ab50359878ed
Threads CPU : 8; OS : Mac OS X 10.14.6; UI Render : par défaut; VCL: osx; 
Locale : fr-FR (fr_FR.UTF-8); Langue IHM : fr-FR
Calc: threaded
Comment 20 Alex Thurgood 2019-12-02 12:46:48 UTC
(In reply to Roman Kuznetsov from comment #18)
> I don't see any toolips in that dialog in
> 
> 

Indeed the tooltip appears to have been removed, or deactivated.
Comment 21 So 2020-02-18 02:16:34 UTC
Created attachment 157964 [details]
flashing tooltip

Reproduced same problem in toolbar with

Version: 7.0.0.0.alpha0+
Build ID: 4caa7b790cf99eebbe47fc2e6a56124c42f1f3fc
CPU threads: 4; OS: Mac OS X 10.14.6; UI render: default; VCL: osx; 
Locale: ja-JP (ja_JP.UTF-8); UI-Language: en-US
Calc: threaded
Comment 22 Alex Thurgood 2021-02-18 11:15:05 UTC
Sorry, no repro for me with

Version: 7.1.0.3 / LibreOffice Community
Build ID: f6099ecf3d29644b5008cc8f48f42f4a40986e4c
CPU threads: 8; OS: Mac OS X 10.16; UI render: default; VCL: osx
Locale: fr-FR (fr_FR.UTF-8); UI: en-US
Calc: threaded

Even in the toolbar as exemplified by the animated gif that was attached.