Bug 148118 - FILESAVE: PPT: Columns in textbox are gone after RT
Summary: FILESAVE: PPT: Columns in textbox are gone after RT
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:ppt, regression
Depends on:
Blocks:
 
Reported: 2022-03-21 16:40 UTC by Xisco Faulí
Modified: 2022-03-21 16:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How the document looks after RT (8.91 KB, image/png)
2022-03-21 16:40 UTC, Xisco Faulí
Details
The bugdoc saved from PowerPoint 2016 (93.50 KB, application/vnd.ms-powerpoint)
2022-03-21 16:56 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-03-21 16:40:07 UTC
Created attachment 179014 [details]
How the document looks after RT

Steps to reproduce:
1. Open attachment 145086 [details] from bug 120028
2. Save it to PPT
3. Open the new generated file

-> The columns are gone

Reproduced in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: cfd82e7a2cc2b45b738eb0efa0827196d2de61a4
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2022-03-21 16:41:13 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=486a11ad6fdae1714200229462b69f328be06b5a

author	Mike Kaganski <mike.kaganski@collabora.com>	2021-06-05 00:19:06 +0300
committer	Mike Kaganski <mike.kaganski@collabora.com>	2021-06-08 14:51:57 +0200
commit 486a11ad6fdae1714200229462b69f328be06b5a (patch)
tree 592469c652c8919cc1e864d20ea10f5d5b8b167a
parent d0a1616ccad0dd5f5a02c1b0204f537b57d0b4b5 (diff)
editengine-columns: PPTX support (tdf#118458)

Bisected with: bibisect-linux64-7.2

Adding Cc: to Mike Kaganski
Comment 2 Mike Kaganski 2022-03-21 16:52:39 UTC
This is not a bug.

Columns only appeared in MS Office in OOXML format; it is not available in legacy binary formats. It is expected that any features are lost when they are unsupported in saved format.

Saving the bugdoc to PPT from PowerPoint 2016, though, creates a document with columns in the shape. The export is accompanied with a warning that the text will be uneditable. Fun fact is that it is editable in the same PowerPoint. But opening the PPT in LO shows it as a raster image.

Possibly PowerPoint saves some OOXML data in the legacy PPT format; that is unsupported so far, and that would be a different issue (AFAIK it's also undocumented).
Comment 3 Mike Kaganski 2022-03-21 16:56:45 UTC
Created attachment 179015 [details]
The bugdoc saved from PowerPoint 2016

Just a note that I forgot: the columns were saved previously just because they were imported not as columns, but as a table, which was possible to save. The conversion happened on import.

It could be possible to try to do something similar on export in PPT filter. But I suppose it's not useful, since our normal handling of unsupported features is simply drop them (even in older versions of our native file format).