Bug 31023 - Link to OOo website is opened after installation
Summary: Link to OOo website is opened after installation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard:
Keywords:
: 31348 33502 34029 36296 36537 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-20 23:59 UTC by André Schnabel
Modified: 2011-04-24 00:31 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (134.54 KB, image/x-png)
2011-02-27 13:06 UTC, k-j
Details

Note You need to log in before you can comment on or make changes to this bug.
Description André Schnabel 2010-10-20 23:59:42 UTC
After installation (and of the windows installer procedure) the following link is opened:
http://update.services.openoffice.org/ooo/index_de.html?cid=920900

seems we still hafe this in the installer.
Comment 1 Muthu 2010-10-21 01:27:27 UTC
One for fridrich?
Comment 2 Thorsten Behrens (CIB) 2010-12-03 06:06:53 UTC
*** Bug 31348 has been marked as a duplicate of this bug. ***
Comment 3 Thorsten Behrens (CIB) 2010-12-03 06:09:58 UTC
Fixed for RC1.
Comment 4 sophie 2011-01-13 01:04:43 UTC
Closing - Sophie
Comment 5 Don't use this account, use tml@iki.fi 2011-02-08 05:51:46 UTC
This still is said to happen in 3.3.0 final.
Comment 6 Don't use this account, use tml@iki.fi 2011-02-08 05:52:11 UTC
*** Bug 34029 has been marked as a duplicate of this bug. ***
Comment 7 Don't use this account, use tml@iki.fi 2011-02-08 05:52:47 UTC
*** Bug 33502 has been marked as a duplicate of this bug. ***
Comment 8 Don't use this account, use tml@iki.fi 2011-02-08 06:17:35 UTC
So is one common theme for the people reporting this that they were using a non-English localisation of OOo 3.2 or 3.2.1?
Comment 9 Don't use this account, use tml@iki.fi 2011-02-08 06:18:03 UTC
Thorsten, what fix was supposed to fix this?
Comment 10 Robert L. 2011-02-08 06:35:04 UTC
@Tor: For me, yes. I had a German OOo 3.2.x installed.
Comment 11 Don't use this account, use tml@iki.fi 2011-02-08 06:54:13 UTC
Still not able to reproduce. Installed the German OOo 3.2.1 with JRE in Windows XP. No mention of update.services in the Registry. Installed LibreOffice 3.3 final. No web page opened.

What is the magic additional thing requires to trigger this? What Windows version are the reporters using? What extensions have they installed?
Comment 12 Don't use this account, use tml@iki.fi 2011-02-08 07:07:03 UTC
One more question: is it necessary to have the "automatic updates" feature in OOo turned on, and should that have done its work at least once (3.2 -> 3.2.1 then presumably)? Did that happen for the people who see this?
Comment 13 Don't use this account, use tml@iki.fi 2011-02-08 08:30:56 UTC
Now I saw it myself, after installing OOo 3.2(.0), then having that upgrade itself to 3.2.1, and then installing LO 3.3(.0). Hmm. Not that it makes me any wiser what causes it and how to avoid it.
Comment 14 Don't use this account, use tml@iki.fi 2011-02-08 08:48:28 UTC
After just installing OOo 3.2(.0) and then LibreOffice 3.3(.0), I don't see it. So apparently having done the upgrade from OOo 3.2 to 3.2.1 is relevant to see it.
Comment 15 Don't use this account, use tml@iki.fi 2011-02-08 09:28:42 UTC
Hmm, of course I am not able to reproduce it a second time. It seems that some quite exact sequence of steps is needed. Will continue trying.
Comment 16 Chris M 2011-02-17 09:38:49 UTC
I just installed LibreOffice 3.3 on Windows XP and it opened http://update.services.openoffice.org/ooo/231.html?cid=920900 in my browser after completing the install.
Comment 17 k-j 2011-02-27 13:05:50 UTC
I get the website everytime I install a new version of LibreOffice (also the RCs) on different windows systems (WIn7 64bit and XP 32bit).
Now I have made some different things:
See the mail archive:

http://go.mail-archive.com/5dOVga_VCPKXGFnkb9oWM8lXDVM=
I have deinstalled OOo and LibreOffice, clear the registry automatically and manual. While the new installation I get the website.

http://go.mail-archive.com/exgCiS-jCKcRzJvvZJIRo_-hlpY=

After Rainer asked me I checked:
Repairing installation: no website
Changing installation: no website
Deinstall and reinstall: website
The website starts a short time before installation of the Addons.
Maybe this helps.
Comment 18 k-j 2011-02-27 13:06:52 UTC
Created attachment 43900 [details]
Screenshot
Comment 19 Rainer Bielefeld Retired 2011-02-27 21:57:41 UTC
In WIN7 > Sy<stem > Programs I still see links to OOo in program information columns Help Link, Support Link, Update link
I see the same links for OOo3.4-dev and similar ones for OOo1.1.4
Comment 20 k-j 2011-03-10 23:42:21 UTC
I get the same website with LibreOffice 3.3.2 OOO330m19 (Build:201) tag libreoffice-3.3.2.1
Comment 21 Jochen 2011-03-25 15:49:07 UTC
I can confirm the problem. Current version 3.3.2 of 2011-25-03.
OS: Windows XP
Comment 22 k-j 2011-04-07 13:36:42 UTC
Now I found a folder called "sun" in Users\Public\Documents. There is a link "releasnote1" with the url "http://update.services.openoffice.org/ooo/index_de.html?cid=920899".
Now I deinstalled LibO, renamed the folder "sun" to "bun" and installed LibO 3.3.2 again. There was no opening ooo side now (WIN764bit).
Comment 23 Jochen 2011-04-07 14:16:25 UTC
Interesting Note. But IMHO for normal user not practicable. Installation routine changeable?
Comment 24 Don't use this account, use tml@iki.fi 2011-04-08 00:20:02 UTC
Thorsten, re comment #3, what was supposed to fix this?
Comment 25 Don't use this account, use tml@iki.fi 2011-04-08 00:24:35 UTC
k-j: Thanks for the hint in comment #22, even if you misspelled "releasenote1". But anyway, searching for the keyword points to this:

http://opengrok.libreoffice.org/xref/components/setup_native/source/win32/customactions/relnotes/relnotes.cxx#144

so now I hope we know what causes the behaviour reported here, and we can kill it.

(Thankfully the word has that digit one appended, searching for just "releasenote" would have been less useful) 

Jochen: what are you trying to say? Bugzilla is not a help forum.
Comment 26 Don't use this account, use tml@iki.fi 2011-04-08 01:26:18 UTC
Should be fixed now in the libreoffice-3-4 branch (from which it will be merged into master). I tried to remove all traces of the custom action(s) in question. 

Commits: in bootstrap: a5ac2d7055eb16b511a9e3053113a439816774c5, bb4a8d8c49baf3b1e4ef6ab8aa5548902df9e639

in components: 74a80997f2d80c48dc3a6eb88e32ce24d84dfd65

in postprocess: 1f038f261fac0c275a54e0c100169aa192d98aac

Need one review and approval for cherry-pick to the libreoffice-3-3 branch, too.
Comment 27 Jochen 2011-04-08 06:27:48 UTC
> what are you trying to say?

Tor:  knowing that Bugzilla is not a help forum I wanted to say that
1) there is bug
2) k-j  has shown a workaround
3) this workaround is not a solution for the normal user (" not practicable")
4) Request, whether programming can be changed ("Installation
routine changeable").

Summary: there is a bug - but IMHO not serious. I wanted to ask the question, whether the programmers see a need to eliminate this bug.
Comment 28 Björn Michaelsen 2011-04-08 08:03:55 UTC
(In reply to comment #26)
> Need one review and approval for cherry-pick to the libreoffice-3-3 branch,
> too.

Looks good to me.
Comment 29 Don't use this account, use tml@iki.fi 2011-04-17 01:11:52 UTC
*** Bug 36296 has been marked as a duplicate of this bug. ***
Comment 30 Rainer Bielefeld Retired 2011-04-17 01:16:46 UTC
Modified Version due to report date.

Where has the fix been integrated? Due to 
Bug 36296 - [EasyHacks] "Thank you" web page opened after installation process completed, points to OpenOffice.org
it seems that a part of the problem still might exist (or problem reappeared).
Comment 31 alex 2011-04-17 01:25:09 UTC
The problem still in 3.2.2: 

OS details: 
Windows Vista Home Premium, SP2. 

Product details: 
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2

Installer was in Finnish language. 

Regards, 
Alex
Comment 32 Rainer Bielefeld Retired 2011-04-17 08:59:18 UTC
@alex:
What information concerning integration of the fix do you have for reopening this bug? In Comment 26 I read concerning integration into 3.4 branch, so it wouldn't be unexpected at all that you still see the bug in 3.2.
Comment 33 alex 2011-04-17 09:00:43 UTC
ok, then needs to be verified in 3.4.x build.
A.


On Sun, Apr 17, 2011 at 6:59 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=31023
>
> --- Comment #32 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de>
> 2011-04-17 08:59:18 PDT ---
> @alex:
> What information concerning integration of the fix do you have for
> reopening
> this bug? In Comment 26 I read concerning integration into 3.4 branch, so
> it
> wouldn't be unexpected at all that you still see the bug in 3.2.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
>
Comment 34 Rainer Bielefeld Retired 2011-04-17 09:21:16 UTC
I think so, too. But I believe some high spirits are required to test 3.4Beta1 with WIN ;-)
<https://bugs.freedesktop.org/buglist.cgi?op_sys=Windows (All)&query_format=advanced&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&bug_status=RESOLVED&bug_status=VERIFIED&bug_status=CLOSED&version=LibO 3.3.4 Beta1&product=LibreOffice>
Comment 35 Don't use this account, use tml@iki.fi 2011-04-18 00:03:56 UTC
The fix has been integrated in the 3.3 branch, too. It will be in 3.3.3.
Comment 36 Don't use this account, use tml@iki.fi 2011-04-24 00:31:51 UTC
*** Bug 36537 has been marked as a duplicate of this bug. ***