Bug 32397 - Repeatedly crashes (freezes/hangs) on saving the file (changes)
Summary: Repeatedly crashes (freezes/hangs) on saving the file (changes)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: x86 (IA32) Windows (All)
: high blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-14 12:47 UTC by goldfish
Modified: 2015-04-06 21:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (32.59 KB, text/plain)
2010-12-16 09:11 UTC, reportingbugs
Details
Screenshot of it freezing (189.07 KB, image/png)
2010-12-19 03:09 UTC, goldfish
Details
soffice.bin using up 98% of CPU resources (274.29 KB, image/png)
2010-12-19 03:16 UTC, goldfish
Details
System Monitor's 'Open Files' (215.25 KB, image/png)
2010-12-19 03:29 UTC, goldfish
Details
Part 2 of files opened by LO (System Monitor screenshot during crash) (265.05 KB, image/png)
2010-12-19 03:31 UTC, goldfish
Details
Part 3 of files opened by LO (System Monitor screenshot during crash) (188.90 KB, image/png)
2010-12-19 03:33 UTC, goldfish
Details
LibreOffice error log (58.34 KB, text/x-log)
2011-01-17 11:55 UTC, goldfish
Details
LibreOffice error log Part 2 (59.55 KB, text/x-log)
2011-01-17 11:57 UTC, goldfish
Details
LibreOffice error log Part 3 (63.12 KB, text/x-log)
2011-01-17 11:58 UTC, goldfish
Details
LibreOffice error log Part 4 (62.97 KB, text/x-log)
2011-01-17 12:00 UTC, goldfish
Details
LibreOffice error log Part 6 (74.23 KB, text/x-log)
2011-01-17 12:00 UTC, goldfish
Details
LibreOffice error log Part 5 (68.67 KB, text/x-log)
2011-01-17 12:02 UTC, goldfish
Details
error log Part 7 (32.59 KB, text/x-log)
2011-01-17 12:20 UTC, goldfish
Details

Note You need to log in before you can comment on or make changes to this bug.
Description goldfish 2010-12-14 12:47:34 UTC
FILESAFE


OS:
Ubuntu 10.10 (Maverick)
Kernel Linux 2.6.35-23-generic 
GNOME 2.32.0

LibreOffice version:
LibreOffice 3.3.0 
OOO330m17 (Build:3)
libreoffice-build 3.3.0.1

Meaningful Summary:
LibreOffice repeatedly crashes randomly when I click the save button or use the keyboard shortcut for 'Save' (Control + S)

Steps to reproduce the problem:
Cannot reproduce it on will but crashes very frequently when I click the save button or use the keyboard shortcut for 'Save' (Control + S)
I tried to get strace log (on Linux)to work but because I not an IT guy I find it difficult to follow this.

This is when LibreOffice is using Iced Tea (the free Java that comes with Ubuntu or something)
Comment 1 Cédric Bosdonnat 2010-12-16 01:13:38 UTC
Without any more information, we can't do anything but close this bug.
Could you please read http://wiki.documentfoundation.org/BugReport and provide a gdb backtrace of the crash when it happens and the faulty document?
Comment 2 goldfish 2010-12-16 05:27:20 UTC
Hi Cedric,

I will try to send you a 'gdb backtrace' and hope to do so if it is not too difficult (if it is technically feasible for me).

Regards,
Paul

(In reply to comment #1)
> Without any more information, we can't do anything but close this bug.
> Could you please read http://wiki.documentfoundation.org/BugReport and provide
> a gdb backtrace of the crash when it happens and the faulty document?
Comment 3 goldfish 2010-12-16 05:34:38 UTC
Hi,

I read http://wiki.documentfoundation.org/BugReport but it did not state how I could install backtrace ( libreoffice*-debuginfo) on Ubuntu.

Please can someone help me with information on how to install backtrace on Ubuntu?

Regards,
Paul


(In reply to comment #1)
> Without any more information, we can't do anything but close this bug.
> Could you please read http://wiki.documentfoundation.org/BugReport and provide
> a gdb backtrace of the crash when it happens and the faulty document?
Comment 4 reportingbugs 2010-12-16 09:11:53 UTC
Created attachment 41178 [details]
Backtrace

Hello,

I have the same problem. I cannot save any document file because LibreOffice is freezing. 

I have created a backtrace about this problem. I hope this helps.

Greetings
Matthias
Comment 5 goldfish 2010-12-16 09:42:01 UTC
Thanks Matthias,

Appreciate your help.

Regards,
Paul

(In reply to comment #4)
> Created an attachment (id=41178) [details]
> Backtrace 
> 
> Hello,
> 
> I have the same problem. I cannot save any document file because LibreOffice is
> freezing. 
> 
> I have created a backtrace about this problem. I hope this helps.
> 
> Greetings
> Matthias
Comment 6 Lubos Lunak 2010-12-17 05:57:21 UTC
It is not the same problem. The backtrace from comment #4 suggests LibreOffice is run in the KDE3 desktop (and probably the file dialog is used), while the original reporter uses GNOME and clicks 'save' directly (which I assume means avoiding the file dialog).

So the second problem needs a separate bugreport (with all necessary information too) and the original problem still needs more information.
Comment 7 goldfish 2010-12-19 03:09:19 UTC
Created attachment 41248 [details]
Screenshot of it freezing
Comment 8 goldfish 2010-12-19 03:12:05 UTC
Hi Lubos Lunak,

I am trying to get this problem on backtrace. Hope to post it soon. I find it tough as I am not a software guy.

In the meanwhile here are some screenshots of the problem, not sure if it will help.

(In reply to comment #6)
> It is not the same problem. The backtrace from comment #4 suggests LibreOffice
> is run in the KDE3 desktop (and probably the file dialog is used), while the
> original reporter uses GNOME and clicks 'save' directly (which I assume means
> avoiding the file dialog).
> 
> So the second problem needs a separate bugreport (with all necessary
> information too) and the original problem still needs more information.
Comment 9 goldfish 2010-12-19 03:16:59 UTC
Created attachment 41249 [details]
soffice.bin using up 98% of CPU resources

soffice.bin using up 98% of CPU resources is very odd. On my computer with several programs running together with LibreOffice the processor usage is under 10%. This high usage of CPU only happens when LibreOffice crashes.

Please help.
Comment 10 goldfish 2010-12-19 03:29:00 UTC
Created attachment 41250 [details]
System Monitor's 'Open Files' 

This screenshot was what was shown when LO had crashed. It is so long it is in 3 parts.
Comment 11 goldfish 2010-12-19 03:31:39 UTC
Created attachment 41251 [details]
Part 2 of files opened by LO (System Monitor screenshot during crash)
Comment 12 goldfish 2010-12-19 03:33:31 UTC
Created attachment 41252 [details]
Part 3 of files opened by LO (System Monitor screenshot during crash)
Comment 13 Jan Holesovsky 2010-12-20 21:00:07 UTC
goldfish: http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29

Unfortunately, the screenshots do not give us the needed information :-(  If you do not know how to install the *debuginfo packages, skip that step.
Comment 14 goldfish 2010-12-26 10:39:24 UTC
Hi,

Hope you all had a wonderful Christmas & here is wishing you all a Happy & prosperous new year.

I have completely uninstalled LibreOffice RC1 and have now installed the RC2 of LibreOffice. 

I am using it and if the problem of the random crashes occur in this version I will report it (I will do my best to get the problem on Backtrace). If all works out well I will ask for this bug to be closed.

Thanks.
Regards,
Paul

(In reply to comment #13)
> goldfish:
> http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
> 
> Unfortunately, the screenshots do not give us the needed information :-(  If
> you do not know how to install the *debuginfo packages, skip that step.
Comment 15 goldfish 2010-12-31 23:38:33 UTC
Happy New Year everyone!!!

I am sorry to say that the RC2 version of LibreOffice has crashed and I have not been able to get that crash on Backtrace yet.

I would like to point out that OpenOffice 3.2 also installed(comes standard with Ubuntu 10.10)& its Quickstarter is enabled. Will this conflict with LibreOffice?

Thanks.



(In reply to comment #14)
> Hi,
> 
> Hope you all had a wonderful Christmas & here is wishing you all a Happy &
> prosperous new year.
> 
> I have completely uninstalled LibreOffice RC1 and have now installed the RC2 of
> LibreOffice. 
> 
> I am using it and if the problem of the random crashes occur in this version I
> will report it (I will do my best to get the problem on Backtrace). If all
> works out well I will ask for this bug to be closed.
> 
> Thanks.
> Regards,
> Paul
> 
> (In reply to comment #13)
> > goldfish:
> > http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
> > 
> > Unfortunately, the screenshots do not give us the needed information :-(  If
> > you do not know how to install the *debuginfo packages, skip that step.
Comment 16 goldfish 2011-01-17 11:50:42 UTC
Got some error logs

Please let me know if it is helpful.

(In reply to comment #15)
> Happy New Year everyone!!!
> 
> I am sorry to say that the RC2 version of LibreOffice has crashed and I have
> not been able to get that crash on Backtrace yet.
> 
> I would like to point out that OpenOffice 3.2 also installed(comes standard
> with Ubuntu 10.10)& its Quickstarter is enabled. Will this conflict with
> LibreOffice?
> 
> Thanks.
> 
> 
> 
> (In reply to comment #14)
> > Hi,
> > 
> > Hope you all had a wonderful Christmas & here is wishing you all a Happy &
> > prosperous new year.
> > 
> > I have completely uninstalled LibreOffice RC1 and have now installed the RC2 of
> > LibreOffice. 
> > 
> > I am using it and if the problem of the random crashes occur in this version I
> > will report it (I will do my best to get the problem on Backtrace). If all
> > works out well I will ask for this bug to be closed.
> > 
> > Thanks.
> > Regards,
> > Paul
> > 
> > (In reply to comment #13)
> > > goldfish:
> > > http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
> > > 
> > > Unfortunately, the screenshots do not give us the needed information :-(  If
> > > you do not know how to install the *debuginfo packages, skip that step.
Comment 17 goldfish 2011-01-17 11:55:57 UTC
Created attachment 42128 [details]
LibreOffice error log
Comment 18 goldfish 2011-01-17 11:57:50 UTC
Created attachment 42129 [details]
LibreOffice error log Part 2
Comment 19 goldfish 2011-01-17 11:58:46 UTC
Created attachment 42130 [details]
LibreOffice error log Part 3
Comment 20 goldfish 2011-01-17 12:00:11 UTC
Created attachment 42131 [details]
LibreOffice error log Part 4

Please let me know if these error logs helped.
Comment 21 goldfish 2011-01-17 12:00:55 UTC
Created attachment 42132 [details]
LibreOffice error log Part 6
Comment 22 goldfish 2011-01-17 12:02:36 UTC
Created attachment 42133 [details]
LibreOffice error log Part 5
Comment 23 goldfish 2011-01-17 12:20:59 UTC
Created attachment 42134 [details]
error log Part 7
Comment 24 goldfish 2011-01-17 23:50:37 UTC
I have completely uninstalled LibreOffice RC 2 & installed LibreOffice RC 3.

Unfortunately, that version too (RC 3) crashed while I tried to save a document. 

I will try & post that Error log next time.

Thanks,
Paul


(In reply to comment #23)
> Created an attachment (id=42134) [details]
> error log Part 7
Comment 25 Zack 2011-02-19 14:00:19 UTC
I believe this bug has been resolved in 3.3.1, correct?
Comment 26 xihh 2011-03-03 22:17:08 UTC
Maybe this bug is related to https://bugs.freedesktop.org/show_bug.cgi?id=34996
Comment 27 Zack 2011-03-31 08:58:09 UTC
Marking as resolved as this bug seems like it was strongly related to bug 32797, bug 33368, and bug 34587, all of which have been resolved.
Comment 28 Björn Michaelsen 2011-12-22 05:35:38 UTC
Remove infoprovider from closed and resolved bugs.
Comment 29 Björn Michaelsen 2011-12-22 05:51:53 UTC
RESOLVED, FIXED or CLOSED bugs cant be KEYWORD NEEDINFO.
Comment 30 Engelbert Huber 2014-05-13 09:44:04 UTC
Writer, Calc freezes on Save Command, TaskManager sign "LibreOffice non respond"
Then continue with Save Dialog as File
After one Character freezes , and continue after a average ten Seconds to save it.
This appears with lasts Versions 2014
Comment 31 Engelbert Huber 2014-05-13 09:46:14 UTC
This appears in all components
Comment 32 Joel Madero 2014-11-02 16:00:37 UTC
Reopened is saved for bugs that are (1) marked as FIXED; (2) assigned to a developer. This bug was never confirmed so UNCONFIRMED is appropriate status. Thanks!
Comment 33 Buovjaga 2014-11-15 13:47:43 UTC
(In reply to Engelbert Huber from comment #30)
> Writer, Calc freezes on Save Command, TaskManager sign "LibreOffice non
> respond"
> Then continue with Save Dialog as File
> After one Character freezes , and continue after a average ten Seconds to
> save it.
> This appears with lasts Versions 2014

What is the Windows version? What is the LibreOffice version exactly?

Change back to UNCONFIRMED after you have provided the information.
Comment 34 Julien Nabet 2015-04-06 21:28:11 UTC
Let's put this one to WFM.

Indeed, if Engelbert encounters some bug, it can't be the same as the original one since it appeared with last version of mid 2014 whereas original bug has been on 3.3

Engelbert: if you still reproduce crashes with recent LO version (4.4.2) + brand new profile (see https://wiki.documentfoundation.org/UserProfile#Windows), please open a new bugtracker.
Indeed, this bug, with more than 30 comments which go from 2010 to 2015, is less easy to manage.