Bug 32781 - Extraneous spaces in outline mode.
Summary: Extraneous spaces in outline mode.
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 RC2
Hardware: Other All
: medium normal
Assignee: André Schnabel
QA Contact:
URL:
Whiteboard:
Keywords: easyHack
: 34698 61927 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-02 09:00 UTC by Darryl L. Pierce
Modified: 2016-02-18 16:37 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Document showing the error. (9.40 KB, application/vnd.oasis.opendocument.text)
2011-01-04 02:52 UTC, Darryl L. Pierce
Details
Screenshot of document with error. (60.15 KB, image/png)
2011-01-04 02:52 UTC, Darryl L. Pierce
Details
Same document with outline changed; error goes away. (9.36 KB, application/vnd.oasis.opendocument.text)
2011-01-04 02:53 UTC, Darryl L. Pierce
Details
Screenshot of document without error. (73.66 KB, image/png)
2011-01-04 02:53 UTC, Darryl L. Pierce
Details
comprehensive bullets (10.64 KB, application/vnd.oasis.opendocument.text)
2011-01-04 19:09 UTC, Yifan Jiang
Details
Screenshot showing the value to change (34.60 KB, image/png)
2011-02-28 00:55 UTC, Cédric Bosdonnat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darryl L. Pierce 2011-01-02 09:00:21 UTC
In an outline, wherever the sequence "III" appears as part of the numbering itself, the text of the outline is indented a number of spaces.

For example, where "III" or "VIII" or "XIII" appear, the text is indented the same number of spaces.

If, however, the outline is changed to not use "III" then the indenting goes away.
Comment 1 Yifan Jiang 2011-01-04 02:08:47 UTC
(In reply to comment #0)
> In an outline, wherever the sequence "III" appears as part of the numbering
> itself, the text of the outline is indented a number of spaces.
> 
> For example, where "III" or "VIII" or "XIII" appear, the text is indented the
> same number of spaces.
> 
> If, however, the outline is changed to not use "III" then the indenting goes
> away.

Hello Darryl, I didn't really see the problem from my understanding (tried Tools->Outline Numbering and Paragraph numbering).

Would you help attach a sample document? More descriptive step by step reproducing instruction would also be welcome. In addition, it is also nice to have a screen snapshot of the problem. Thank you!
Comment 2 Darryl L. Pierce 2011-01-04 02:51:38 UTC
The attachment named "With.odt" shows the error, an With.png is a screenshot of it. The outline scheme selected is I.A.i.a).
Comment 3 Darryl L. Pierce 2011-01-04 02:52:06 UTC
Created attachment 41611 [details]
Document showing the error.
Comment 4 Darryl L. Pierce 2011-01-04 02:52:29 UTC
Created attachment 41612 [details]
Screenshot of document with error.
Comment 5 Darryl L. Pierce 2011-01-04 02:53:05 UTC
Created attachment 41613 [details]
Same document with outline changed; error goes away.
Comment 6 Darryl L. Pierce 2011-01-04 02:53:24 UTC
Created attachment 41614 [details]
Screenshot of document without error.
Comment 7 Yifan Jiang 2011-01-04 19:09:43 UTC
Created attachment 41658 [details]
comprehensive bullets

Thanks Daryl for the samples.

Confirmed reproducible on 3.3 rc2.

Meanwhile it is a more general problem of number/alphabetic bullet items drawing and happens not only in roman numbers. I attached a comprehensive bullets document (comprehensive-bullet.odt) revealing more problems in the relevant area.
Comment 8 Yifan Jiang 2011-01-04 19:10:24 UTC
For Cedric's review.
Comment 9 Cédric Bosdonnat 2011-02-15 05:23:33 UTC
The bigger spaces in With.odt and comprehensive-bullets.odt are due to a too small indent after the numbering.

If the whole numbering text (with prefix and suffix included) is larger than the tabstop defined for the numbering level, then the tab uses the next tabstop of the paragraph. This problem would be fixed by changing the default tabstop to something that fits your use.

Closing as not a bug
Comment 10 Cédric Bosdonnat 2011-02-25 03:17:41 UTC
*** Bug 34698 has been marked as a duplicate of this bug. ***
Comment 11 carsrcoffins23 2011-02-27 15:00:23 UTC
(In reply to comment #9)
> If the whole numbering text (with prefix and suffix included) is larger than
> the tabstop defined for the numbering level, then the tab uses the next tabstop
> of the paragraph. This problem would be fixed by changing the default tabstop
> to something that fits your use.

It seems that what you were saying was to increase the value of the default tabstop. Changing anything there just made things worse. So I tried the opposite direction. I set the default tabstop to the smallest amount I could get it to take-- 0.20"-- and it still did not correct the problem for the third item of the first level (III.). It did help some other levels, but that one could not be fixed.

Furthermore, I cannot entirely understand the logic of having the outline defined by, or influenced by, the default tabstop. It seems intuitive to me that one would modify tab settings within Bullets and Numbering and would expect this to override the default tabstop.

That being said, even if it's not a bug, I don't think it makes much sense, and I would request a change from this behavior.
Comment 12 Cédric Bosdonnat 2011-02-28 00:55:50 UTC
Created attachment 43915 [details]
Screenshot showing the value to change

This may even be an interesting easy hack.

The default numbering are provided by this code:
http://opengrok.libreoffice.org/xref/libs-gui/i18npool/source/defaultnumberingprovider/defaultnumberingprovider.cxx
Comment 13 Cédric Bosdonnat 2011-02-28 00:56:32 UTC
Returning to the pool as it's an easy hack
Comment 14 André Schnabel 2011-09-02 10:18:40 UTC
did some research, outline definitions are in
http://opengrok.libreoffice.org/xref/core/i18npool/source/localedata/data/
Comment 15 Florian Reisinger 2012-05-18 09:31:02 UTC
Deleted "Easyhack" from summary.
Comment 16 Regina Henschel 2013-04-18 22:38:37 UTC
*** Bug 61927 has been marked as a duplicate of this bug. ***
Comment 17 Björn Michaelsen 2013-10-04 18:46:35 UTC
adding LibreOffice developer list as CC to unresolved EasyHacks for better visibility.

see e.g. http://nabble.documentfoundation.org/minutes-of-ESC-call-td4076214.html for details
Comment 18 Jean-Baptiste Faure 2014-05-02 21:09:04 UTC
Closing again as NotABug because changing the tabstop (not the default tabstop) as shown in attachment #43915 [details] solves the problem.

Best regards. JBF
Comment 19 Robinson Tryon (qubit) 2015-12-18 09:57:35 UTC
Migrating Whiteboard tags to Keywords: (EasyHack)
[NinjaEdit]
Comment 20 Robinson Tryon (qubit) 2016-02-18 16:37:11 UTC
Remove LibreOffice Dev List from CC on EasyHacks
(curtailing excessive email to list)
[NinjaEdit]