Download it now!
Bug 33156 - Missing information that Movie / Sound will be linked, not embedded
Summary: Missing information that Movie / Sound will be linked, not embedded
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All All
: low normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-15 08:18 UTC by vohe
Modified: 2013-04-24 11:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
audio file mp3 example. (35.11 KB, audio/mpeg)
2011-12-31 18:56 UTC, gmolleda
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vohe 2011-01-15 08:18:19 UTC
Hi,

I figure out the following:
Create a new Impress File (Saved later at: \userspace\myfiles\impress\new.odp)
Insert a new movie file   (stored on the PC at \userspace\myvideo\new.ogg)
Insert a second movie file (stored on a USB Drive \usbdrive\video\new1.avi)

Save your work and start presenation.
It works fine.

Now carry your work on a stick (or send it via email) to another PC. 
Open presentation.
There are no movies to watch. You'll see a great questionmark.

Ok. Although i thought i've "insert" the movies, may they are just linked?
Next step:
Store the movie files byside the presentation on the stick and try again on the second PC.
Just as little as before it doesn't work.

You can see the movies just as they are stored in the same folder as on the first PC. But you never see a hint or question that this is the problem.

So i take a look in the content.xml of my presentation and i see this :

- <draw:plugin xlink:href="file:///E:/usbdrive/video/new1.avi" xlink:type="simple" xlink:show="embed" xlink:actuate="onLoad" draw:mime-type="application/vnd.sun.star.media">
 
I thing, there should be a user - hint that media (movie) files are only linked to the document AND that it would be easyier to put them in the same folder with the presentation - before using it.

Much better it will be, if impress dosen't find the linked content, it looks out for it in the same folder along the stored pesentation file.
And if there isn't the required file then the questionmark is changed to a little text e.g.: the file \usbdrive\video\new1.avi is missing .

Regards,
Volker
Comment 1 Rainer Bielefeld Retired 2011-02-05 00:58:23 UTC
[Reproducible] with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]"

Steps to reproduce:
0. copy paste a sample movie to your test folder. I used WIN exemple movie
   "Natur.wmv" 
1. create and save (in test folder)  a new Document 
  (It seems it does not matter whether presentation, text document, ... .
   I Used a text document.
2. Menu 'Insert > Movie and Sound' (I use LibO dialogs)
   As expected dialog opens
   UNEXPECTEDLY without checkbox "Link"
3. finish insertion of movie and try, you should be able to play the
   movie
4. Save and close document
5. Rename test folder
6. Reopen LibO test document
   Movie preview will be shown and you should be able to play the movie,
   what indicates that it might be linked with relative path (that are my
   settings in menu 'Tools > Options > Load/Save > General') or embedded
7. Close document again.
8. Move LibO sample document to an other folder
9. Reopen LibO test document
   Movie preview will NOT be shown, only placeholder. That shows, that movie 
   is not embedded, but linked

It's an acceptable behaviour to link such objects, but there is an unacceptable inconsistence, for other objects you have a checkbox in the insert dialog where you can select whether you want to embed or link.
Additionally I was not able to find information in the sample document what movie (name, path) is missing after step 9 

My suggestions:
- There should be information that the movie only will be linked
- Help should mention that Movies only will be linked (currently it does not)
- Information what movie is missing should be available (Bug 32581)
- I believe it should also be possible to embed movies (Bug 33928 - Allow 
  embedding of movies and sounds)
Comment 2 gmolleda 2011-06-06 01:59:49 UTC
Embed files is very important for expand the use of LibreOffice, I receive e-mails all days with presentations Powerpoint with audio embedded.

In presentations for classroom in veterinary, medical, ... is very usual insert video files in presentations, in congress, ...

My suggestions:

- If the file size is a problem for LibreOffice, you could add a new option in the menu Tools - Options: 
Max size to embed multimedia files: 10000 Kbs

I think that is possible use this characteristic in Impress and Word, somebody could use Word to create a web-page, insert video and save as html.

Bye.
Comment 3 Andrej Vilfan 2011-12-01 07:53:28 UTC
As of 3.3.1 (OOO330m19, from OpenSuse 11.4), the embedded movies are rather annoying. You can leave the "Link" checkbox unticked and it will embed a movie, but the movie will not play in the presentation, just in the media player. However, even if you delete it, the movie will stay in the .odp file and potentially make it huge in size. 

Steps to reproduce:

- create an empty presentation
- insert a movie without linking it
- delete the movie
- save the presentation in an .odp file
- open the .odp file with ark and you will see the whole movie under media

Summary:
- embedded videos don't play properly in the presentation
- they stay in the file when deleted
Comment 4 Björn Michaelsen 2011-12-23 11:42:55 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 gmolleda 2011-12-31 18:56:06 UTC
Created attachment 55014 [details]
audio file mp3 example.
Comment 6 gmolleda 2011-12-31 18:57:39 UTC
Same behaviour in 3.5 beta 2.
Comment 7 gmolleda 2012-01-10 02:50:20 UTC
The importance should be changed to high because this is the main reason .ppt is the de facto standard, the millions of emails with slide shows accompanied by music.

This issue exist since 2003 in OpenOffice (number 16937), How much years and users will lost?
Comment 8 sasha.libreoffice 2012-04-17 03:42:03 UTC
in 3.5.2 we can embed audio and video into odp file. Uncheck option "Link" while inserting file.
Edit->Links still not works
Comment 9 gmolleda 2012-05-11 06:45:18 UTC
I have probed the new option for embed video or sound.

It need:
a) Edit links impossible
https://bugs.freedesktop.org/show_bug.cgi?id=48294

b) Possible inconsistent:
https://bugs.freedesktop.org/show_bug.cgi?id=33928

c) I need have the same option to embed sound in menu Slide Show - Slide Transition and in this panel, the option "Sound: Other Sound..." can't allow embed sound in Media directory in .odp file (embedded).

Bye.
Comment 10 Jean-Baptiste Faure 2012-11-19 20:25:36 UTC
Filed this RFE : bug 57291.

Best regards. JBF
Comment 11 Samuel Mehrbrodt (CIB) 2013-04-23 22:02:41 UTC
Seems this bug is fixed now.
For the remaining issues there are other bugs.
Comment 12 sasha.libreoffice 2013-04-24 11:17:38 UTC
Currently it embeds by default. We can count it as fix.
Option "Link" also seen in native and KDE integrated filepicker 
tested in 4.0.2