Bug 57291 - Embedding audio files used for transitions
Summary: Embedding audio files used for transitions
Status: RESOLVED DUPLICATE of bug 67544
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, skillCpp
Depends on:
Blocks:
 
Reported: 2012-11-19 20:17 UTC by Jean-Baptiste Faure
Modified: 2015-12-16 00:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2012-11-19 20:17:06 UTC
When inserting an audio or video file in a slide, we have the possibility to choose between linking or embedding the file. There is a checkbox in the filepicker for that.

It would be very interesting and consistent with the above functionality to have the same possibility when choosing a sound file for a transition : task panel > transitions > sound : other sound -> filepicker.

Best regards. JBF
Comment 1 Rob Snelders 2012-11-19 22:11:57 UTC
I see what it is what you want. Seems like a good request to me.
Comment 2 pierre-yves samyn 2012-11-20 08:42:25 UTC
Hello

(In reply to comment #0)
> It would be very interesting and consistent with the above functionality to
> have the same possibility when choosing a sound file for a transition

+1

Regards
Pierre-Yves
Comment 3 Samuel Mehrbrodt (CIB) 2013-04-23 17:09:42 UTC
This should be quite easy to do as you can copy the code from other Dialogs that offer this function.

Here's the actual dialog code: http://opengrok.libreoffice.org/xref/core/sd/source/ui/animations/CustomAnimationDialog.cxx#1735

Here you can see how the Impress/Draw dialog "Insert Movie and Sound" adds the "Link" option: http://opengrok.libreoffice.org/xref/core/avmedia/source/viewer/mediawindow.cxx#244

And here's how media is embedded in the document structure: http://opengrok.libreoffice.org/xref/core/sd/source/ui/view/sdview4.cxx#278
Comment 4 Marc 2013-08-02 20:44:55 UTC
I agree that this is a very desirable feature, particularly because using a sound file for transition is the only way you can place a sound-track in a presentation so that it will run throughout the whole presentation. For example, I created a presentation for which the whole purpose was to display the words of a song, with saved timings so the slides would change at the right points in the song, but when I copied the presentation to the computer it is to be shown on - no song!

Thanks,

Marc
Comment 5 George Masters 2013-08-05 02:19:33 UTC
On v. 4.1.0 release, I can get the sound to play and advance the slide automatically correctly. However, the second slide has a different sound which doesn't always play and the auto advance timer doesn't automatically advance the slide.

This is easily replicated by:
1. setting a transition such as fade to black
2. inserting own personal sound as an mp3 (i recorded my voice)
3. set the timer to advance the slide automatically to say 10 sec.

4. for the next slide, use the same trnsition, for example, fade to black
5. Use a different sound file in mp3 format
6. set the slide advance to 13 seconds (just so its different from the first slide)

The problem appears to be consistent on my windows machine regardless of JRE used. I have the latest Oracle JRE. Also tried it with an earllier Sun JRE and got the same result. I ran this on a Windows 7 laptop.
Comment 6 Samuel Mehrbrodt (CIB) 2013-10-01 21:50:16 UTC
Marking as Duplicate.

George, can you please report a new bug for your problem?

*** This bug has been marked as a duplicate of bug 67544 ***
Comment 7 Robinson Tryon (qubit) 2015-12-16 00:04:13 UTC
Migrating Whiteboard tags to Keywords: (EasyHack,SkillCpp,DifficultyBeginner)
[NinjaEdit]