Bug Hunting Session
Bug 33684 - autocompletion does not longer work by pressing TAB
Summary: autocompletion does not longer work by pressing TAB
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 34317 (view as bug list)
Depends on:
Blocks: AutoCorrect-Complete Tab-Character
  Show dependency treegraph
 
Reported: 2011-01-29 03:12 UTC by Christoph Thielecke
Modified: 2018-01-17 17:13 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Thielecke 2011-01-29 03:12:36 UTC
The autocompletion does not longer work in cells by pressing tab on offer.

How to get the bug:

- enter the text in the following cells:
A1: WG1
A2: WG2
A3: WG3

- now enter 'W' into A4, you will get 'W[mark]G1[endmark]' (text between mark  and endmark is inverted)

- now press tab key

What happens:
text will be set to WG1 and cell B4 will be selected

What should happen:
text will changed to 'W[mark]G2[endmark]' and the cell A4 is still the active cell. You can toggle to other possiblities (like WG3) too.

OOo 3.2.0 is working fine.
Comment 1 Rainer Bielefeld Retired 2011-02-05 05:05:25 UTC
[Reproducible] with "LibreOffice 3.3.0 RC4 - WIN7  Home Premium (64bit) German UI  [OOO330m19 (build 6 / tag 3.3.0.4)]". Now to other autofill contents can be scrolled with <ctl>+<tab>.

German Help says TAB will scroll, also English Help for AutoInput does not match with actual behaviour.

In OOo3.4-dev still TAB is used for scrolling to next possible autofill contents.

I believe it will be the same for all OS.

Bug or feature?
Wrong Help or Wrong behaviour?

WIKIHELP <http://help.libreoffice.org/Calc/AutoInput>
also does not match with actual behaviour
Comment 2 Kohei Yoshida 2011-02-07 18:13:57 UTC
This is a feature, and the help needs updating for this.
Comment 3 Rainer Bielefeld Retired 2011-02-07 22:28:16 UTC
I filed
Bug 34019 - WIKIHELP does not match with actual behavior for AutoInput
and close this issue due to Comment 2
Comment 4 Christoph Thielecke 2011-02-07 23:21:27 UTC Comment hidden (no-value)
Comment 5 Christoph Thielecke 2011-02-07 23:21:57 UTC Comment hidden (no-value, obsolete)
Comment 6 Don't use this account, use tml@iki.fi 2011-02-08 00:02:47 UTC Comment hidden (no-value)
Comment 7 Christoph Thielecke 2011-02-08 00:05:37 UTC Comment hidden (no-value)
Comment 8 Don't use this account, use tml@iki.fi 2011-02-08 00:09:29 UTC Comment hidden (no-value)
Comment 9 Christoph Thielecke 2011-02-08 00:20:54 UTC Comment hidden (no-value)
Comment 10 Rainer Bielefeld Retired 2011-02-08 00:28:40 UTC Comment hidden (no-value)
Comment 11 GerardF 2011-02-09 02:33:25 UTC
@ Kohei
Could this be added in OpenOffice Legacy key binding ?
Comment 12 Kohei Yoshida 2011-02-09 05:24:54 UTC
(In reply to comment #11)
> @ Kohei
> Could this be added in OpenOffice Legacy key binding ?

I'm afraid not, as this one is unfortunately hard-coded.
Comment 13 Rainer Bielefeld Retired 2011-02-17 22:31:43 UTC
What shell we do with this issue? I don't see any simple solution.

The lots of 3-key combinations we currently have are not very user friendly, but may be the only way to get a more or less consistent UI for all OS.

May be we need some "shortkey.cfg" (or .oxt) that will allow to define all shortcuts by user, and may be predefined files available via download that will allow to install a "use MSWORD4.5 shortcuts" easily?
Comment 14 Kohei Yoshida 2011-02-18 07:17:07 UTC
Unfortunately the normal shortcut key scheme doesn't apply in this case, because these key inputs are handled as direct key input i.e. like typing 'a', 'b', 'c, etc into a cell, and you can't assign a shortcut key to direct key inputs.

Of course it's not impossible to make this configurable, but it may create more problems and makes the code less maintainable (the code that handles direct key inputs is very fragile).  And quite frankly I don't know if it's worth the risk.

But I guess we can't close this bug since if we do, it will get re-opened anyway. ;-)  So, let's leave this open for now, but set it to lower priority.
Comment 15 Kohei Yoshida 2011-02-18 08:17:55 UTC
I'll keep this bug for the time being.
Comment 16 Christoph Thielecke 2011-04-22 07:52:52 UTC
Its still not fixed in libreoffice 3.3.2.
Comment 17 Kohei Yoshida 2011-04-22 07:57:42 UTC
I don't want to be the assignee.
Comment 18 Midiar 2011-07-03 00:47:22 UTC
Using LibO_3.4.1_MacOS_x86_install_en-US, neither Tab nor ctrl+Tab lets me scroll through the alternatives. (I also tried the other ctrl/option/cmd+Tab combinations I could come up with, to no avail.) I started noticing this changed behaviour in 3.4.0, I think.

The help also mentioned cmd+D to get a list of all the alternatives. That was new to me, but it didn't work anyway.

So is this a bug, or have I overlooked something really obvious?
Comment 19 Rudolf Kollien 2011-07-08 06:51:16 UTC
Same to me on Mac OS X, German Translation. Neither Ctrl-Tab, nor any other combination works. The CMD-D as mentioned above doesn't work, too. It's frustrating that a) the default behavior was changed and b) there is no working alternative. So we still have to continue using OOo on our Macs. And even on the Linux and Win-Desktops, as we can't force our users to use different key combinations on different platforms. Very sadly that one little thing makes the biggest trouble. But being unable to rotate to the AutoInput makes the Calc nearly unusable for us.
Comment 20 Rudolf Kollien 2011-07-08 06:53:57 UTC
Forgot to say: we use LibreOffice 3.4.0 on Intel Mac.
Comment 21 Martin Srebotnjak 2012-07-21 12:08:38 UTC
This is still present, even in 360RC2 and, Kohei, it is definitely a bug: on OSX you cannot browse through suggestions nor move to another, next suggestion. It is a broken feature, even if its keyboard shortcut was changed in beetween for other OS where it might work.

AutoInput is used a lot in spreadsheet use cases, i.e. in companies and NGO which might have a negative impact on perception of LO as a truly full-featured office suite, as well as this makes a function in OSX unaccessible, which makes this feature non-existing.

So, to ask clearly: what is the correct shortcut for all OS:
- accessing the list of all possible autoformat suggestions
- jumping to the next autoformat suggestion

This is why I chenged it from enhancement to a normal priority bug. Slovenian enterprise users are crying to get this back working as before.

Thanks, m.
Comment 22 Rudolf Kollien 2012-07-23 06:04:04 UTC
After more than 18 months nothing changed. 
This bug is the reason, why we and many others still run on OOo.
Comment 23 ralf 2014-06-25 12:33:20 UTC
Any updates?
Comment 24 oscar valenzuela 2014-10-26 19:10:37 UTC
Confirmed in LibreOffice (Dev) 4.4.0 alpha1 under Mac OS X 10.10 (Yosemite) x86-64
Comment 25 Joel Madero 2014-11-03 04:46:19 UTC
Status should be NEW not REOPENED.
Comment 26 QA Administrators 2015-12-20 16:13:58 UTC Comment hidden (obsolete)
Comment 27 ralf 2016-01-04 14:37:04 UTC
Libreoffice 5.0.4.2 OS X - The bug is still there. It is still not possible to effectively navigate through autocompletion alternatives with TAB/Ctrl-TAB.
Comment 28 Rudolf Kollien 2016-01-07 10:06:18 UTC
Version: 5.0.4.2
Build-ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Mac OSX 10.11.2

I agree with comment#27: still not working.
Comment 29 QA Administrators 2017-03-06 14:15:23 UTC Comment hidden (obsolete)
Comment 30 ralf 2017-03-06 14:40:25 UTC
Libreoffice 5.2.5.1 OS X - The bug is still there. It is still not possible to effectively navigate through autocompletion alternatives with TAB/Ctrl-TAB.
Comment 31 Rudolf Kollien 2017-03-07 08:29:45 UTC
Can confirm comment 30 for version 5.3.0.3. Still not possible to navigate through alternative cell content.
Comment 32 Alex Thurgood 2017-05-11 07:23:43 UTC
The Alt-Tab-Down arrow combination works to open the list of previously entered strings, but neither Ctrl-Tab, nor Tab, do anything.
Comment 33 Alex Thurgood 2017-05-11 07:25:49 UTC
Tested on

Version: 5.2.7.2
Build ID: 2b7f1e640c46ceb28adf43ee075a6e8b8439ed10
Threads CPU : 2; Version de l'OS :Mac OS X 10.12.4; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 34 Markus Mohrhard 2017-06-28 00:24:57 UTC
CTRL+TAB, CTRL+SHIFT+TAB, ALT+DOWN + Navigation with the up and down key all work here. I'll close this bug as this seems to work as intended.

Kohei already made clear that this was a deliberate change.
Comment 35 Christoph Thielecke 2017-06-28 18:57:07 UTC
I can't accept this. Kohei wrote something 2011 which is long time ago and does not fix the bug.
Comment 36 tommy27 2017-06-29 04:48:34 UTC
(In reply to Kohei Yoshida from comment #14)
> Unfortunately the normal shortcut key scheme doesn't apply in this case,
> because these key inputs are handled as direct key input i.e. like typing
> 'a', 'b', 'c, etc into a cell, and you can't assign a shortcut key to direct
> key inputs.
> 
> Of course it's not impossible to make this configurable, but it may create
> more problems and makes the code less maintainable (the code that handles
> direct key inputs is very fragile).  And quite frankly I don't know if it's
> worth the risk.

it seems that this bug qualifies for a WONTFIX status.
as Kohei said, a fix would probably create more serious side effects and would not be worth it.
Comment 37 Alex Thurgood 2017-07-26 10:18:15 UTC
(In reply to Markus Mohrhard from comment #34)
> CTRL+TAB, CTRL+SHIFT+TAB, ALT+DOWN + Navigation with the up and down key all
> work here. I'll close this bug as this seems to work as intended.
> 
> Kohei already made clear that this was a deliberate change.


Tested against:
Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
Threads CPU : 4; Version de l'OS :Mac OS X 10.12.6; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group


Ctrl-Tab is a reserved combo on OSX for switching between workspaces.

Ctrl-Shift-Tab does nothing whatsoever.

Alt-Down displays the list of available strings, with navigation in the list possible using further up/down presses.

If I replace the Ctrl key with the Cmd key:

Cmd-Tab is a reserved combo on OSX for calling up and switching between a list of active applications from left to right

Cmd-Shift-Tab does the same thing as Cmd-Tab in revers order (right to left)

So these do not work as intended, unless there is some other keyboard combo definition which does work and of which I am unaware.
Comment 38 eisa01 2017-09-01 20:35:39 UTC
*** Bug 34317 has been marked as a duplicate of this bug. ***
Comment 39 Xisco Faulí 2018-01-17 17:10:53 UTC
Putting it back to RESOLVED NOTABUG as Markus did.
Comment 40 Martin Srebotnjak 2018-01-17 17:13:33 UTC
Let's mark all issues as notabug and then LO will have no bugs whatsoever!