Bug 34317 - autocompletion: ctrl tab or its mac equivalent does not work
Summary: autocompletion: ctrl tab or its mac equivalent does not work
Status: RESOLVED DUPLICATE of bug 33684
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoCorrect-Complete
  Show dependency treegraph
 
Reported: 2011-02-15 18:51 UTC by Yannick Chiron
Modified: 2017-09-01 20:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yannick Chiron 2011-02-15 18:51:09 UTC
Let's say I have in the same column several words beginning with the same letter, for instance "train" in the first row and then "training" in the second row.  Under OOo-Calc, if I type in the third row the letter "t", then I can use the tab key to choose the autocompletion between "train" and "training", which comes very handy.

With LibO 3.3.0 final under windows 7, a similar behavior can be obtained by typing ctrl+tab (not as handy as the OOo simpler tab key). Anyway, this does not work at all under Mac OS 10.6.6, either trying ctrl+tab, or command+tab, or option+tab, or tab.

While waiting for a fix, one can use an other combination of keys, but not very practical and not the same behavior: shift+command+D.  It will give you a menu to choose from.

Thanks for fixing this behavior problem.

PS: switching in the Key combinations Preferences of Calc from "Default" to "OpenOffice.org Heritage" does not help.
Comment 1 Jean-Baptiste Faure 2011-02-15 22:34:32 UTC
Added "autocompletion" to the summary to make it more informative.
Comment 2 Yannick Chiron 2011-02-23 09:23:51 UTC
updated the version to "LibO 3.3.1 final" since it's still affected by the bug.
Comment 3 Alex Thurgood 2011-02-24 23:03:43 UTC
Confirming.


Alex
Comment 4 Cédric Bosdonnat 2011-02-25 03:13:20 UTC
thorsten, isn't this on yet another troubles of the keyboard layout on macos? Is it a duplicate of bug 34704 in some way?
Comment 5 Yannick Chiron 2011-03-22 09:16:02 UTC
updated the version to "LibO 3.3.2l" since it's still affected by the bug.
Comment 6 Yannick Chiron 2011-05-14 17:36:26 UTC
updated the version to "LibO 3.4beta5" since it's still affected by the bug.
Does anybody know which version could be the target for a fix to this problem?
Just to help with expectations…
Thanks.
Comment 7 Rainer Bielefeld Retired 2011-06-10 02:57:43 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 8 Yannick Chiron 2011-08-03 16:03:22 UTC
Just tried today the new LibO 3.4.2 final. There is something new!! Thanks a lot developers.

Now, under Mac OS X, one can use the keys "option+down" (held together) to get a drop menu, and have the choice between the various entries of the column which start with the same letter.  And if you then release the option key, the down key allows you to choose the one you want.  Thanks again.  

Do we have now to close this bug as solved?  

Yannick
Comment 9 Thorsten Behrens (CIB) 2011-08-15 07:04:02 UTC
Sure, if it's fixed for you.
Comment 10 Yannick Chiron 2011-08-15 20:35:14 UTC
One more thought though: there is a problem in Calc Help.  The description of the AutoInput (or in French AutoSaisie) behavior is with the use of TAB or SHIFT+TAB.  So this is not consistent with how LibreOffice Mac works, nor the way it works under Windows for that matter (which is ctrl+TAB if it didn't change).

This could really confuse people.
Comment 11 Yannick Chiron 2011-08-24 05:11:52 UTC
I'm sorry I rejoiced to quickly.  In addition to the incoherence with Calc Help, there is another problem.

While the feature "option+down" (held together) to get a drop menu and have the choice between the various entries of the column is nice and helpful when you have only a few entries in the column, it is useless in the case you have many entries because the drop menu give you then the choice between all the entries (in my case, hundreds), and not the choice between the entries starting with the same letter.

i hope we can reintroduce the original feature so convenient with tab like it is on OpenOffice.org, or at least like it is on LibO Windows with ctrl+tab.

This is a feature I miss a lot because I use intensively Calc, and probably I'm not the only one missing it.

I reopened the bug.
Comment 12 Alex Thurgood 2011-08-24 07:27:02 UTC
Hi all,

The behaviour in Calc is also inconsistent with that of Writer, at least in LO 3.3.4.

In Writer, on Mac you can use Option-Tab to cycle through the various choices.

In Calc, I too have found no way to cycle simply through the various choices.

As Yannick has mentioned, the Shift-Cmd-D key combo is not a trivial maneuver, and additionally, you then have to select the word from the list using the up/down keys and validate, which for me is a real usability issue compared to the old OOo behaviour.

Alex
Comment 13 Yannick Chiron 2011-12-23 14:54:54 UTC
Bug (or dropped feature if some people prefers to call it this way) is still present under LibO 3.5.0Beta1 and 3.4.4.

The Help in both LibO3.5.0.Beta1 and 3.4.4 is still inconsistent with this behavior.  In the Help, search for "AutoInput" ("AutoSaisie" in French) and you get the description of the tab feature.

Note : the feature "option+down" to get a drop menu and have the choice between the various entries of the column is not as useless as I previously wrote in the case you have a lot of entries in the column, because then if you type the first letter of the word you are looking for (having released "option"), the first word starting with this letter will be highlighted in the drop menu, so the word you are looking for is not far using the down key. 

While better than nothing, it is in my view so complicated to explain or find on your own that it should be considered as a hidden feature.

Wishing we can get back the old convenient feature using tab.
Comment 14 Björn Michaelsen 2011-12-23 14:58:55 UTC
NEW, unassigned bug: replace "infoprovider" with move to state "NEEDINFO".
Comment 15 Yannick Chiron 2011-12-23 21:23:56 UTC
I just checked and LibO 3.5.0 Beta 2 is also affected.
Comment 16 Jean-Baptiste Faure 2011-12-26 12:54:23 UTC
Changing version back to 3.3.0.
Please do not change version number: it gives the first version in which the default has been found and allows to filter bugs on this info. We can assume that if nobody close the bug report, that means the bug is present in the current version. 
That said it is intersesting when you add a comment showing that you tested a new version against this bug.

Best regards. JBF
Comment 17 QA Administrators 2014-10-24 03:18:24 UTC Comment hidden (obsolete)
Comment 18 Yannick Chiron 2014-10-24 12:44:33 UTC
ok I just checked with my MacBook Pro running Mac OS X 10.9.5.

Bug still present in LibreOffice 4.3.2.2.

Bug is not present in Apache OpenOffice 4.1.1 which is, regarding this matter, far more intuitive and easy.

Bring back the old behavior with TAB!  Please!!
Comment 19 QA Administrators 2015-12-20 16:09:00 UTC Comment hidden (obsolete)
Comment 20 QA Administrators 2017-01-03 19:47:02 UTC Comment hidden (obsolete)
Comment 21 Yannick Chiron 2017-01-04 00:01:07 UTC
LibreOffice 5.2.4.2, Mac OS X 10.11.6, MacBook Pro 2,3 GHz Intel Core i7 (late 2013):

Bug still present, and comments #1 and #11 still valid.

Apache OpenOffice 4.1.3 (current version) still offers the convenient TAB key to cycle through the different entries in a row starting with the same letter.

If this TAB behavior is not possible for LibreOffice, an acceptable alternative could be "option+right" to cycle through the different entries starting with the same letter (keeping "option+down" to offer the drop menu with all the entries of the row).

Happy New Year, and the best to all of you and to LibreOffice project.
Comment 22 eisa01 2017-09-01 20:35:39 UTC
This is the same bug as bug 33684

*** This bug has been marked as a duplicate of bug 33684 ***