Download it now!
Bug 33798 - In certain partial installation scenarios just one "module" gets installed
Summary: In certain partial installation scenarios just one "module" gets installed
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Andras Timar
URL:
Whiteboard: target:4.2.0 target:4.1.4 target:4.0.7
Keywords:
: 52061 53537 60105 (view as bug list)
Depends on:
Blocks: Win-Installer-MAB Scenarios
  Show dependency treegraph
 
Reported: 2011-02-01 02:20 UTC by mailofloki
Modified: 2017-09-03 19:10 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mailofloki 2011-02-01 02:20:51 UTC
I'm Japanese.
If there is a grammatical mistake, I'm sorry.

When I want to install only calc and writer.
It changes to the setting that doesn't install LibreOffice Program Module.
It changes to the setting that installs only CALC and writer.
Then, calc is not installed.

Regards.
Comment 1 Rainer Bielefeld Retired 2011-02-01 04:31:44 UTC
@mailofloki@yahoo.co.jp
Please do not report speculations, but facts that you observe! So do not write things like "calc is not installed", but "... New > Spreadsheet Document not listed in menu 'File'" or "Double click on xyz.ods does not open LibO Calc, but ...".

Please report with status UNCONFIRMED if you are not absolutely sure that your problem will be reproducible.

May be you should discuss your problem in a japanese mailing list from
<http://wiki.documentfoundation.org/Local_Mailing_Lists#Japanese>?
Comment 2 jhnxsmth 2011-02-27 13:58:13 UTC
(In reply to comment #1)
> @mailofloki@yahoo.co.jp
> Please do not report speculations, but facts that you observe! So do not write
> things like "calc is not installed", but "... New > Spreadsheet Document not
> listed in menu 'File'" or "Double click on xyz.ods does not open LibO Calc, but
> ...".
> 
> Please report with status UNCONFIRMED if you are not absolutely sure that your
> problem will be reproducible.
> 
> May be you should discuss your problem in a japanese mailing list from
> <http://wiki.documentfoundation.org/Local_Mailing_Lists#Japanese>?

I think I'm having the same problem.  Windows 7 x64.  I select to install Calc only, or Word and Calc only (have tried both with identical results).

There is no way to open calc.  There are no shorcuts for calc anywhere.  Spreadsheets of all types are unopenable.  I cannot find any .exe file for calc.
Comment 3 mailofloki 2011-03-06 07:02:04 UTC
Thank your for your reply.

> Rainer Bielefeld
I can't speak English. I'm sorry for not transmitting.

> jhnxsmth
Thank you for understanding my poor English. I also am using Windows 7 x64.

When the check of LibreOffice Program Module is removed and only Calc and Writer are selected, it becomes it.
When the check of [Draw Impress Base Math] are removed and installed, The problem doesn't happen.
However, the frequency of the click increases in this.
If we want to install only Calc or Calc and Writer, The above-mentioned method will be adopted.
Perhaps, it is trouble of the installer. Please correct it.
Comment 4 Don't use this account, use tml@iki.fi 2011-03-07 00:03:22 UTC
Not reproducible when installing LibreOffice 3.3.1 in a Swedish Windows XP:

- Start the installer
- Choose a custom installation
- Unselect Draw, Impress, Base and Math
- Otherwise just click Next

Now in the Start Menu, I see under "LibreOffice 3.3" three items: "LibreOffice" (starts just the "Start Center"), "LibreOffice Calc" and "LibreOffice Writer". As expected.

Please note that Calc, Impress, Writer etc are not separate programs. They are just different "aspects" of the same program. If you have Calc and Writer open at the same time, you are still running just one LibreOffice process (soffice.bin). This is different than Microsoft Office, where Excel, PowerPoint and Word etc are separate programs.

There are separate exe files to start LibreOffice as Calc, Writer etc in the installation directory's "program" subdirectory, called scalc.exe, swriter.exe etc. After the installation above, I do see scalc.exe and swriter.exe there.
Comment 5 mailofloki 2011-03-07 03:45:46 UTC
Thank you for your reply.

The problem doesn't happen in this procedure.

> - Start the installer
> - Choose a custom installation
> - Unselect Draw, Impress, Base and Math
> - Otherwise just click Next

The following are procedures with the problem.

- Start the installer
- Choose a custom installation
- Unselect LibreOffice Program Module
- Select Calc and Writer
- Otherwise just click Next

I also have a (Japanese) Windows XP (x32).
LibreOffice version is 3.3.1.
The problem can be reproduced on XP and 7.
Comment 6 Don't use this account, use tml@iki.fi 2011-03-07 04:46:19 UTC
Ah, indeed, doing it like that I can reproduce. After unselecting the upper Depending on which one one re-selects first, Writer or Calc, the menu entry for the other doesn't show up under Start Menu>LibreOffice 3.3. Also the other wrapper .exe (like swriter.exe) in <installdir>\program isn't there.

In my personal opinion, if there is some complex code in the installer that can have uninteded side-effects like this, we should just remove the possibility to install only part of LibreOffice. We don't want to have to debug problems like this. Too much optionality is bad.
Comment 7 Urmas 2012-08-31 18:16:18 UTC
*** Bug 53537 has been marked as a duplicate of this bug. ***
Comment 8 Andras Timar 2013-02-18 20:01:10 UTC
*** Bug 60105 has been marked as a duplicate of this bug. ***
Comment 9 Timur 2013-03-06 11:40:37 UTC
*** Bug 52061 has been marked as a duplicate of this bug. ***
Comment 10 Urmas 2013-07-21 08:27:22 UTC
*** Bug 67130 has been marked as a duplicate of this bug. ***
Comment 11 Harald Koester 2013-10-10 10:35:01 UTC
In order to check if this bug is a dupe to bug 67130 I performed some tests according this bug. Result: No dupe to 67130! Explanation see bug 67130.

This bug still exists in LibreOffice versions 4.0.0.3 and 4.1.2.3. With version 4.1.2.3 this bug is covered by bug 67130 in some special cases.

The bug only occurs if you first deselect a whole category of install options ("LibreOffice Programm Modules": bug 33798 and bug 53537; "Additional user interface languages": bug 52061 and bug 60105). Then only the first selected option of this category will be installed. I did not check the bug according the category "Optional Components".

Examples:
(1) Deselect "LibreOffice Programm Modules" > Select "LibreOffice Writer" > Select "LibreOffice Calc" installs only Writer.
(2) Deselect "LibreOffice Programm Modules" > Select "LibreOffice Calc" > Select "LibreOffice Writer" installs only Calc.
(3) Deselect "Additional user interface languages" > Select German > Select Englisch > Select French > Select Dutch: Only German will be installed.

Example (2) is an example for the special case mentioned above. 

I raised the Importance to Major, hence one or more LibreOffice components are not available and it is not obvious where the problem is. An experienced PC user will manage it somehow to install the right commponens, but an unexperienced user may be unable to cope it.
Comment 12 Andras Timar 2013-10-12 17:05:00 UTC
gm_Prg has gm_p_Wrt, gm_p_Calc, etc. children. gm_p_Wrt also has children, but they are hidden: gm_p_Wrt_Bin, gm_Brand_p_Wrt, gm_p_Wrt_MSO_Reg. 

Documentation says:

"To guarantee that the child feature's state always follows the state of its parent, even when the child and parent are initially set to absent in the SelectionTree Control, you must include both msidbFeatureAttributesFollowParent and msidbFeatureAttributesUIDisallowAbsent in the attributes of the child feature.

Note that if you set msidbFeatureAttributesFollowParent without setting msidbFeatureAttributesUIDisallowAbsent, the installer cannot force the child feature out of the absent state. In this case, the child feature matches the parent's installation state only if the child is set to something other than absent.

Set msidbFeatureAttributesFollowParent and msidbFeatureAttributesUIDisallowAbsent to ensure a child feature follows the state of the parent feature."

So the solution of this bug in my opinion will be, that we set msidbFeatureAttributesUIDisallowAbsent bit for the hidden features.
Comment 13 Commit Notification 2013-10-12 17:31:21 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=914fbb57bdd4038d0a3e1e2cad45ff81672fc748

fdo#33798 msidbFeatureAttributesUIDisallowAbsent for hidden feat.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2013-10-29 12:26:09 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5f4fa9754f6bb55204d4381cdfea1606d61b13b5&h=libreoffice-4-1

fdo#33798 msidbFeatureAttributesUIDisallowAbsent for hidden feat.


It will be available in LibreOffice 4.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2013-10-29 12:27:28 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9404457a19178b42ea40ebd710725520a83c85ef&h=libreoffice-4-0

fdo#33798 msidbFeatureAttributesUIDisallowAbsent for hidden feat.


It will be available in LibreOffice 4.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Harald Koester 2014-06-18 09:49:01 UTC
Verified with version 4.2.4.2 and Win 7. Installation works as expected. Hence status set to CLOSED.