Bug 34016 - Keyboard not working with ibus when using KDE4 integration
Summary: Keyboard not working with ibus when using KDE4 integration
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL: https://bugzilla.novell.com/show_bug....
Whiteboard: kde4
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators KDE
  Show dependency treegraph
 
Reported: 2011-02-07 18:40 UTC by darehanl
Modified: 2018-12-21 18:13 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darehanl 2011-02-07 18:40:40 UTC
LibreOffice on KDE4 seems to cause trouble with ibus input. If I run with KDE integration (by using KDE4 as a desktop environment, or by specifing the environment variable OOO_FORCE_DESKTOP to "kde4", without quotes), ibus keyboard events fail (no keyboard input in the input area, no keyboard shortcuts like CTRL+I). If I run *without* KDE integration (by specifying OOO_FORCE_DESKTOP to "gnome"), I can type normally and use keyboard shortcuts properly.

Steps to reproduce:
0. Make sure ibus-daemon is running.
1. Open a terminal and set environment variable OOO_FORCE_DESKTOP to "kde4" (without quotes).
2. Launch LibreOffice from the command line (i.e. lowriter).
3. Try to use the keyboard.

Actual Results:
Keyboard events are ignored.

Expected Results:
Keyboard should work

Workaround:
Set the environment variable OOO_FORCE_DESKTOP to "gnome" (i.e. in $HOME/.xprofile)

Package Version(s):
Arch Linux
libreoffice 3.3.0.4-2
ibus 1.3.9-2
KDE 4.6.0-1
Comment 1 Luca Beltrame 2011-02-18 05:34:45 UTC
The same happens on openSUSE 11.3 using LibreOffice 3.3.0.  It must be noted that if ibus is restarted after LibreOffice is running, keyboard input will be accepted normally.
Comment 2 Kohei Yoshida 2011-02-18 07:23:52 UTC
Linking it with the downstream bugzilla.
Comment 3 Luboš Luňák 2012-01-16 10:05:25 UTC
Please expand step 0 in the steps to reproduce. I don't even really know what ibus is besides what google says, let alone know how to configure or use it.

Also, LibreOffice 3.3.0 is quite old and I think I might have already fixed this problem. Please try with a more recent version.
Comment 4 darehanl 2012-01-16 14:24:27 UTC
iBus is an input method used for many Asian languages, but other than that I'm not too sure of the details on how it's implemented. Usually after installing iBus along with some input method (i.e. ibus-hangul) you specify the following environment variables:

export XMODIFIERS=@im=ibus
export GTK_IM_MODULE="ibus"
export QT_IM_MODULE="ibus"

One method of doing this is to put the above lines in the file ~/.xprofile

ibus-daemon, if it is not automatically launched, can be launched from the command line like so:

ibus-daemon -d

You should see a tray icon that has a keyboard with a globe in the bottom left corner.

Inside a text box of an application (say kwrite) you can "enable" iBus mode by some configurable shortcut like ctrl+space. Assuming ibus-hangul is enabled, if you type "gksrmf" you should see "한글".



Regarding the LibreOffice version, at the moment I'm unable to get iBus enabled with 3.4.4, even with OOO_FORCE_DESKTOP set as "gnome." I see only latin characters. I haven't had to type in non-latin recently, so I'm not sure if it's due to the version of KDE I have (KDE 4.8 RC) or due to the newer LibreOffice build. I'll try to check.
Comment 5 darehanl 2012-01-26 16:33:55 UTC
Sorry for the delay; I found out what was going wrong. IBus works if my installation of LibreOffice includes Gnome integration (plus KDE integration, since we're talking about using LO in KDE here). It did not work a couple weeks ago since I had only KDE integration installed, but not Gnome. Maybe this is because ibus by default is a gtk3 application? I'm not sure why.


In short, iBus WORKS in KDE if libreoffice-gnome is (also) installed.
Comment 6 bfoman (inactive) 2013-08-14 21:56:20 UTC
RESOLVED WORKSFORME per comment 5.
Do not hesitate to reopen in case of mistriage.
Comment 7 Michiel van der Wulp 2015-01-15 20:09:48 UTC
Installing the libreoffice-gnome on my KDE OpenSuse installation indeed solves the problem.
But this has a lot of impact on the looks of LibreOffice.

I do not think that this is the right solution for 2 reasons:

1. If the libreoffice-kde package requires the libreoffice-gnome package to work correctly, then the libreoffice-kde should depend on libreoffice-gnome and it should be installed automatically.

2. Installation of libreoffice-gnome should not be necessary in the first place.

This is a serious bug! I can not type accented characters!
Typing ë or é with the dead keys on my azerty keyboard gives a simple e.
My locale is en_GB.UTF-8.

Others describe the problem similarly, see e.g.:
http://codeverge.com/opensuse.org.help.applications/ibus-don-t-work-in-libreoffice/1919824
https://forums.opensuse.org/showthread.php/497767-Dead-keys-on-LibreOffice
Comment 8 tommy27 2015-08-01 16:44:31 UTC
please give an update of the bug status with current LibO 4.4.5.2 release.

if bug persists, set status to NEW
if bug is gone, set status to RESOLVED WORKSFORME
Comment 9 You-Cheng Hsieh 2016-06-22 06:14:18 UTC
This bug is reproducible on openMandriva cooker:
libreoffice-kde4-5.1.3
fcitx-4.2.9.1
(fcitx is another input method framework like ibus.)

Install libreoffice-gnome and remove libreoffice-kde4 also resolve the issue, like previous comments stated.
Comment 10 Xisco Faulí 2017-07-13 12:18:15 UTC
Setting Assignee back to default. Please assign it back to yourself if you're
still working on this issue
Comment 11 QA Administrators 2018-07-14 02:45:59 UTC Comment hidden (obsolete)
Comment 12 Roman Kuznetsov 2018-11-05 17:04:13 UTC
may be it's already WONTFIX? Because in ReleaseNotes 6.2 someone wrote "The KDE4 VCL backend is deprecated and will be removed in the next version."
Comment 13 Xisco Faulí 2018-12-21 18:13:40 UTC
KDE4 support was removed in master in the following commit:

author	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-09-05 02:53:07 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2018-12-17 18:33:13 +0100
commit	410bf59de02192c2daf1158b9de76ec0ebab4c56 (patch)
tree	be010e92b862f169076de979796075c925c3e576
parent	6a53832080cf201e960113de8e1887d99e857606 (diff)
kde5: remove older kde/tde plugins, and references to that
KDE4 is out of maintenance upstream since Nov. 2014, and binaries
provided by TDF have switched to KDE5 as the official backend.

Closing as RESOLVED WONTFIX