Bug 34094 - Select Column creating formula
Summary: Select Column creating formula
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: All All
: medium enhancement
Assignee: Dennis Francis
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
: 92439 93937 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-09 08:44 UTC by Tim
Modified: 2016-10-25 19:11 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Example for column select (11.75 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-02-10 01:46 UTC, Tim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim 2011-02-09 08:44:49 UTC
Would be very helpful to be able to select multiple columns or rows when creating a formula.

For Example =SUM(E)

Or in a VLookup =VLOOKUP(B1,Sheet1.A:B), rather than having to select the individual cells.

Cheers,
Tim
Comment 1 Thorsten Behrens (CIB) 2011-02-09 11:37:33 UTC
Please be more specific with your description - provide a step-by-step explanation (http://wiki.documentfoundation.org/BugReport#What_to_include_in_bug_reports)
Comment 2 Tim 2011-02-10 01:46:16 UTC
Created attachment 43192 [details]
Example for column select
Comment 3 Tim 2011-02-10 01:51:38 UTC
Attached above is an example file, check Sheet2 out for example.

Step by Step:
When creating a VLOOKUP, rather than selecting Sheet1.A1:B1048576, to select all of columns A & B, would be a lot easier to just click on the column headers, and have the formula as Sheet1.A:B.


Start typing Formula, =VLOOKUP(
Go to the sheet where you are doing the lookup
Click and drag on the column headers to select which columns you would like to do the VLOOKUP
Formula becomes Sheet1.A:B when selecting columns A & B.

At the moment you cannot select a Column, you have to select the cells to be used in the formula.
Comment 4 Björn Michaelsen 2011-12-23 11:45:44 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Björn Michaelsen 2011-12-23 16:59:53 UTC
needinfo keyword redundant by needinfo status.
Comment 6 Tim 2011-12-28 01:54:38 UTC
Confirmed as still not working in 3.5.0 Beta2 on OS X 10.6.8
Comment 7 Winfried Donkers 2013-07-04 08:54:18 UTC
There is a workaround for this matter:
You can give names to ranges:
-select column A
-menu insert-names-define
-give a name to the range (e.g. A)
and use those names in formulas:
-enter in cell =SUM( A ) to get the sum of all cell values in column A

I hope this helps (as long as the requested enhancement is not realised).
Comment 8 Joel Madero 2015-10-10 16:25:05 UTC
*** Bug 93937 has been marked as a duplicate of this bug. ***
Comment 9 Dennis Francis 2015-11-21 00:02:22 UTC
Submitted a patch for review at https://gerrit.libreoffice.org/#/c/20102/
Comment 10 Eike Rathke 2015-11-30 11:27:28 UTC
*** Bug 92439 has been marked as a duplicate of this bug. ***
Comment 11 Óvári 2015-11-30 20:35:45 UTC
Added CC from Bug 92439
Comment 12 Commit Notification 2015-12-14 17:08:46 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0b93ef5712264f78b8876993e718ccaad2c1216

tdf#34094 : Allow column and row selections while creating a formula

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Ari Latvala 2015-12-14 17:44:25 UTC
Great news, I'd really love to see this already on 5.1 though. Using a lot of that feature.
Comment 14 Óvári 2015-12-15 20:28:38 UTC
(In reply to Commit Notification from comment #12)
> Affected users are encouraged to test the fix and report feedback.

Please see bug 96523.

Thank you
Comment 15 Óvári 2015-12-15 21:02:09 UTC
(In reply to Commit Notification from comment #12)
> Affected users are encouraged to test the fix and report feedback.

Please see bug 96524.

Thank you
Comment 16 Óvári 2016-01-09 10:10:51 UTC
(In reply to Commit Notification from comment #12)
> Affected users are encouraged to test the fix and report feedback.

Please see bug 96981.

Thank you
Comment 17 Óvári 2016-01-12 22:22:00 UTC
Added bug 97084
Comment 18 Óvári 2016-01-14 23:05:24 UTC
(In reply to Commit Notification from comment #12)
> Affected users are encouraged to test the fix and report feedback.

Select Column {Ctrl+Space} (bug 92453); Row {Shift+Space} (bug 92452); Sheet {Ctrl+Shift+Space} (bug 96969) {using keyboard shortcuts} creating formula.

Thank you