Download it now!
Bug 93937 - Calc Input line with automatic conversion to entire row/entire column
Summary: Calc Input line with automatic conversion to entire row/entire column
Status: RESOLVED DUPLICATE of bug 34094
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-05 05:02 UTC by Óvári
Modified: 2015-10-10 16:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2015-09-05 05:02:07 UTC
Version: 5.0.1.2 (x64)
Build ID: 81898c9f5c0d43f3473ba111d7b351050be20261

1. Open LibreOffice Calc
2. In cell A1 type: =SUM(
3. Press the RightArrow on the keyboard once.
   The Input line should show: =SUM(B1
4. Press Ctrl+Shift+DownArrow
   a) The Input line incorrectly shows: =SUM(B1:B1048576
   b) The Input line should show: =SUM(B:B
5. Press Enter
6. Click on cell A1
7. The formula was automatically converted to entire column notation: =SUM(B:B)

Please enable the 'Input line' to feature automatic conversion to entire column/entire row notation during formulae creation.

Thank you
Comment 1 Jean-Baptiste Faure 2015-09-06 11:01:34 UTC
After step 5 I get =sum(B:B)

So closing as WorksForMe. Please feel free to reopen and argue if you disagree.

Best regards. JBF
Comment 2 Óvári 2015-09-06 14:34:23 UTC
1. Assist in reducing the difficulty when creating complex formulae (nested, multiple arguments, etc) as it will fit more easily in the Input Line. Increases usability and reduces the number of small annoyances (even though this corner case may occur rarely in the casual/home users segment; however, this may occurs more frequently in the enterprise/government). Eg.

=SUM(A1:A1048576,C1:C1048576,E1:E1048576,G1:G1048576,I1:I1048576,K1:K1048576)/COUNT(A1:A1048576,C1:C1048576,E1:E1048576,G1:G1048576,I1:I1048576,K1:K1048576)

=SUM(A:A,C:C,E:E,G:G,I:I,K:K)/COUNT(A:A,C:C,E:E,G:G,I:I,K:K)

2. Would assist Calc to be be WYSIWYG (What You See Is What You Get). At the moment you see one formula and when Enter is pressed the cell changes and the the formula that was entered also changes without showing the operator (unless they return to the cell).

3. This bug may assist in the implementation bug 92439 "Creating entire column/s or entire row/s ranges in formulae by clicking on column/row heading/s" as the Input Line will default to 'B:B' not 'B1:B1048576'

4. Increases usability and reduces the number of small annoyances for enterprise/government operators.

5. MS XL caters for this bug (Input Line is called the Formula Bar).

6. This would increase "Calc's blend of performance and features makes it an enterprise-ready, heavy duty spreadsheet application capable of handling all kinds of workload for an impressive range of use cases."
https://www.libreoffice.org/discover/new-features/

Thank you
Comment 3 Buovjaga 2015-10-09 18:42:23 UTC
Bug does not meet the criteria for Status 'REOPENED'
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/REOPENED#Criteria
Status -> UNCONFIRMED
Comment 4 Jean-Baptiste Faure 2015-10-10 06:07:30 UTC
Hi  Óvári,

The input line shows =sum(B:B) just after having pressed Enter key.
I think that the current behaviour is better for users who are not familiar with entire column/entire row notation. You get the best of both, you see exactly which cells are involved in the formula, and when the Enter is pressed, you get a compact expression.

Why do you want that the conversion in sum(b:b) occurs _before_ pressing Enter key?


Best regards. JBF
Comment 5 Óvári 2015-10-10 09:57:14 UTC
@JBF:

1. Please re-read comment 2 to answer your question as to "Why do you want that the conversion in sum(b:b) occurs _before_ pressing Enter key?". This was not an extensive list, as other points do come to mind.

2. You would agree that users who are unfamiliar with the entire column/entire row notation could learn this feature very quickly.
Comment 6 Joel Madero 2015-10-10 16:25:05 UTC
We are well aware of this and it's a duplicate of bug 34094. The bugs aren't exactly the same but you'd get what you want if that's implemented. Marking as such.

NOTE: Enhancements are pretty much entirely taken up by volunteers. A volunteer would have to find this to be interesting and manageable (given their technical skills). That being said, while the issue is known, we do not give estimates or guarantees that the enhancement will be implemented.

*** This bug has been marked as a duplicate of bug 34094 ***