Bug 34564 - request functionality: comfortable way to represent shortcuts
Summary: request functionality: comfortable way to represent shortcuts
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2011-02-22 04:43 UTC by sasha.libreoffice
Modified: 2017-05-24 18:20 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-02-22 04:43:08 UTC
Knowing shortcuts (hotkeys) are important for effective work. But we need to see were the key of shortcuts are placed and learn them. For example by printing shortcuts on printer and put paper with them near workplace.
For assigning new shortcut we need to see, where are unused keys on keyboard to place functions there.

Please, add dialog to demonstrate all assigned shortcut this way:

1234567890-+
QWERTYUIOP[]
ASDFGHJKL;'
ZXCVBNM,./

and user can see shortcuts visual and quick learn them. When assigning new key users can see, where are free or nonimportant key and how handy it is.

Also, add ability to print assigned shortcuts or ability to automatically generate document with visual representation of assigned shortcuts.
Comment 1 Don't use this account, use tml@iki.fi 2011-05-31 08:35:00 UTC
We appreciate you attempts at showing how offended you are (if that is what it is), but don't think your enhancement requests are useless just because nobody comes running to implement them.
Comment 2 sasha.libreoffice 2011-05-31 08:54:31 UTC
At this time it is many more interesting bugs. This functionality can be done using Basic, IMHO.
Comment 3 Joel Madero 2014-11-04 02:48:52 UTC
Seems like this was never looked at by QA team. Moving to UNCONFIRMED as REOPENED is incorrect.
Comment 4 tommy27 2014-12-14 13:57:48 UTC
basically sasha asked to implement a "print current shortcut configuration as a list" thing.

it looks to me a legitimate enhancement request.
I don't understand the sarcasm in comment 2.

status NEW.
Comment 5 Yousuf Philips (jay) (retired) 2017-05-24 18:20:59 UTC
This list should be published likely in the wiki and not something that users should need to print out from within LO, so closing. @Heiko, @Stuart, @Cor: If you disagree, please reopen.