Bug 34669 - [EasyHack] When quickstart is enabled, the reboot/shutdown not work in Ubuntu.
Summary: [EasyHack] When quickstart is enabled, the reboot/shutdown not work in Ubuntu.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords: difficultyInteresting, easyHack, skillCpp
: 33383 36654 40836 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-24 07:55 UTC by Cristiano Nunes
Modified: 2015-12-16 00:20 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cristiano Nunes 2011-02-24 07:55:11 UTC
I use LibreOffice 3.3.0 release and Ubuntu 10.10 (kernel 2.6.35-25).
When I enable the option of quickstart (in Memory preferences) the reboot and shutdown options in my OS not work.
Comment 1 Don't use this account, use tml@iki.fi 2011-03-07 07:31:07 UTC
Assigning to Bjoern, assuming this is Ubuntu-specific.
Comment 2 Thierry Munoz 2011-04-01 13:42:58 UTC
I have the same problem. OS : Ubuntu 10.10 and LibreOffice 3.3.2 (official version non-ubuntu).
Comment 3 Zack 2011-04-10 10:51:48 UTC
Confirmed running LO 3.3.2 and Ubuntu 11.04 Beta 1.  I believe this same bug exists with OOo as well.
Comment 4 Rainer Bielefeld Retired 2011-04-29 03:29:23 UTC
*** Bug 36654 has been marked as a duplicate of this bug. ***
Comment 5 Drew Parsons 2011-07-06 17:05:33 UTC
It's not just pure Ubuntu, the problem happens in Debian too. 
(I'm currently on Debian unstable, LibreOffice 1:3.3.3-4+b1, but the problem has been there for months now, and happened under OpenOffice.org)
Comment 6 Drew Parsons 2011-07-06 17:09:37 UTC
An additional point of reference: the problem happens when trying to shutdown using the Gnome GUI dialog.  From the command line ("shutdown -h now"), shutdown works fine. The problem is only with the Gnome graphical mechanism, not shutdown in general (I haven't tried KDE or other desktop environments).
Comment 7 Christopher M. Penalver 2011-09-13 09:46:27 UTC
WORKAROUND: Close quickstarter before shutdown.
Comment 8 tester8 2011-09-20 11:35:43 UTC
*** Bug 40836 has been marked as a duplicate of this bug. ***
Comment 9 John C 2011-11-10 08:16:40 UTC
I have the exact same problem on Ubuntu 11.10 64bit. In Gnome shell, classic, unity, and unity 2d I cannot log out, shutdown, etc. while the quicktray starter is on.
Only when I shut it off can I log out, etc.
Also, in Unity-2d (and I think gnome classic, i can't remember) an error message would come up when trying to open libreoffice from a shortcut while the quickstarter is on, that multiple processes of libreoffice are active.
Comment 10 John C 2011-11-10 08:18:23 UTC
I use Kernel 3.0.0-13 on Ubuntu and Libreoffice 3.4.4
The problem was there on version 3.4.3 as well.
Comment 11 Christopher M. Penalver 2011-11-10 14:01:36 UTC
John C, please do not toggle the Version field. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 12 John C 2011-11-10 14:06:57 UTC
I see. Sorry about that.
Comment 13 Björn Michaelsen 2011-11-22 06:35:02 UTC
Making this an EasyHack with interesting difficulty:
Code pointers:
http://opengrok.libreoffice.org/xref/core/vcl/unx/generic/app/sm.cxx handles the Unix Session management
http://opengrok.libreoffice.org/xref/core/sfx2/source/appl/shutdowniconunx.cxx is the quickstarter

The quickstarter vetos each and every request to kill the instance, but we want it to do that only when it is not the session manager that wants to kill the instance.

I will mentor this one, so ping me, if you have questions.
Comment 14 Björn Michaelsen 2011-12-23 11:48:55 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 15 Björn Michaelsen 2011-12-23 12:57:07 UTC
An EasyHack should have been checked by developers and thus is confirmed regardless of age. Moving back to NEW from NEEDINFO again. Sorry for the hassle.
Comment 17 Björn Michaelsen 2012-02-28 10:24:32 UTC
*** Bug 33383 has been marked as a duplicate of this bug. ***
Comment 18 Robinson Tryon (qubit) 2015-12-16 00:20:58 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyInteresting SkillCpp)
[NinjaEdit]