Bug Hunting Session
Bug 35588 - Shortcuts to user-defined styles no longer work after renaming style
Summary: Shortcuts to user-defined styles no longer work after renaming style
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: lowest minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators Styles
  Show dependency treegraph
 
Reported: 2011-03-23 03:33 UTC by doubiman
Modified: 2019-06-09 08:33 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description doubiman 2011-03-23 03:33:46 UTC
This leads to the following problem:

1. Assign a Style to a (unused/non-default) key combination, e.g. Alt+Shift+L
2. Test
  -> Can apply Style fine
2. Change name of Style in Styles dialogue.
3. Try to apply Style with shortcut.
  -> Nothing happens.

I can see in the Customize Keyboard dialogue that the Style 'name' that the user sees is used in the Uno code to identify the Style.

This leads to a similar problem when linking Numbering Styles to Paragraph Styles:

1. Define Numbering Style.
2. Assign Numbering Style to a Paragraph Style.
3. Test
  -> Should apply Paragraph Style with appropriate numbering.
4. Change name of Numbering Style.
5. Test applying Paragraph Style from before
  -> Numbering doesn't work.

However, I have noticed that if one applies a Character Style within a Numbering Style, and then changes the name of the Character Style, it /is/ updated and still works in the Number Style.

This suggests that there is some internal unique identifier by which Styles can be referenced and which would solve the problem of 'broken links' to Styles when the user changes their visible name.

If I'm wrong on this last point, I would submit that there should be such an internal, immutable identifier.
Comment 1 Björn Michaelsen 2011-12-23 11:43:18 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 13:57:31 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 13:58:51 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:03:24 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:05:39 UTC Comment hidden (obsolete)
Comment 6 sasha.libreoffice 2012-08-30 09:23:21 UTC
reproduced in 3.6.1 on Fedora 64 bit
after renaming style shortcut becomes not working
I do not know if it is a bug or so should be
Comment 7 Joel Madero 2012-10-19 20:41:16 UTC
This is definitely a bug, although a minor one. Marking as such.

Confirmed: 3.6.1.2 
Distro: Bodhi

Minor -- makes creating professional quality work under very specific situations slightly more difficult

Lowest -- Easy work around (reassign key), and only happens if someone renames the style (not too common at all)
Comment 8 QA Administrators 2015-01-05 17:51:06 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2015-01-21 08:44:32 UTC
Still reproduced.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 07e84cae983c08afdba03018413a19d01abb3006
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-19_06:15:38
Comment 10 QA Administrators 2016-02-21 08:34:42 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-03-06 14:58:48 UTC Comment hidden (obsolete)
Comment 12 Yousuf Philips (jay) (retired) 2017-06-11 01:50:11 UTC
To me this isnt a bug, as you cant modify a built-in style's name which has an internal name, so this would be limited to user-defined styles which dont have an internal name that the shortcut can be associated with.

About the other issue of renaming a numbering style which is associated with a paragraph style, that seems like a bug that should be reported in another bug and fixed.

Maxim, Stuart, Cor, Heiko: What's your take?
Comment 13 Heiko Tietze 2017-06-11 07:42:38 UTC
It's a bug when the object' caption that is meant to identify an object to the user is abused for other functions.
Comment 14 QA Administrators 2018-06-12 02:33:46 UTC Comment hidden (obsolete)
Comment 15 Cor Nouws 2019-06-09 08:33:12 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #12)
> To me this isnt a bug, as you cant modify a built-in style's name which has
> an internal name, so this would be limited to user-defined styles which dont
> have an internal name that the shortcut can be associated with.
This is logic. Could of course be solved, but at what price .. > Wont'Fix