Download it now!
Bug 37170 - Delete key does not work in BASIC IDE
Summary: Delete key does not work in BASIC IDE
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 37783 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-13 03:52 UTC by Rainer Bielefeld Retired
Modified: 2011-05-31 07:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-13 03:52:25 UTC
Steps how to reproduce  with "LibreOffice 3.4Beta5  – WIN7  Home Premium  (64bit) English UI [DEV300m103 (Build:5)]":
1. Open WRITER document containing a Starbasic macrl
2. Open Macro source in IDE
3. Click anywhere into the source text
4. press <Del>
   expected: character behind caret will be deleted
   actual: nothing
Comment 1 Rainer Bielefeld Retired 2011-05-15 01:02:05 UTC
@clio:
Thank you for confirming. But this one is far away from hight/critical, someone programming Starbasic will learn to live with backspace for a whild.
Comment 2 clio 2011-05-15 01:08:28 UTC
@Rainer Bielefeld: OK, returned to "medium".
Comment 3 Noel Power 2011-05-17 09:46:12 UTC
patch mentioned in issue #=37211
https://bugs.freedesktop.org/attachment.cgi?id=46831 should fix this bug
Comment 4 clio 2011-05-18 13:40:33 UTC
Seems to be resolved along with Bug 37210 and Bug 36832 by that patch.
Comment 5 clio 2011-05-18 13:42:40 UTC
(In reply to comment #4)
> Seems to be resolved along with Bug 37210 ...

Sorry, Bug 37211
Comment 6 vitriol 2011-05-31 02:48:54 UTC
*** Bug 37783 has been marked as a duplicate of this bug. ***
Comment 7 Uwe Altmann 2011-05-31 04:16:06 UTC
Still present in LO 3.4. RC 2
Comment 8 clio 2011-05-31 07:15:15 UTC
The fix is going to be in 3.4.1 if not accepted as stopper. See http://nabble.documentfoundation.org/REVIEW-for-fix-37211-td2953176.html