Download it now!
Bug 37192 - Unable to see wmf image from .doc
Summary: Unable to see wmf image from .doc
Status: RESOLVED DUPLICATE of bug 39327
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-14 01:11 UTC by itilo
Modified: 2011-07-24 11:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
a document with wmf (2.36 MB, application/msword)
2011-07-24 08:36 UTC, itilo
Details
PFd from OO of the same file (1023.54 KB, application/pdf)
2011-07-24 09:34 UTC, itilo
Details
screen copy and pdf export from LO (569.59 KB, application/zip)
2011-07-24 11:06 UTC, itilo
Details
Screen copy and pdf export from LibreOffice 3.4.1 OOO340m1 (Build:103) (384.62 KB, application/zip)
2011-07-24 11:32 UTC, itilo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description itilo 2011-05-14 01:11:40 UTC
The document seems empty, but we can select an object. When I try to save this object it appears to be a wmf file.
All is OK with openoffice 3.2
Comment 1 itilo 2011-05-14 01:23:23 UTC
Unable to attach a too big file. You can find examples at this address:
http://www.ups-tlse.fr/02017389/0/fiche___pagelibre/&RH=1237797620218&RF=1237801992902
and select (for example) "Génie mécanique en aéronautique" on the right side of the page.
http://www.ups-tlse.fr/servlet/com.univ.collaboratif.utils.LectureFichiergw?CODE_FICHIER=1301478147586&ID_FICHE=108300
Comment 2 Rainer Bielefeld Retired 2011-07-24 08:09:54 UTC
@itilo:
I can't open those documents.
Here now you can upload 3MB, please try again and make sure that your sample documents no not require special permissions.

Please read <http://wiki.documentfoundation.org/BugReport>, there you will find information concerning an alternative upload using the Wiki for documents bigger than 3 MB

Additionally please check reports concerning similar problems:
Bug 39327 - WMF object not visible in .doc with LibO   (looks very similar)
Bug 32170 - FILEOPEN Opened DOCX-file is empty
Bug 36862 - Docx file displays nothing
Bug 33072 - .docx import - graphics missing (JPEG), wordart messed up
Bug 31036 - docx import: Imported images (png) not shown
Comment 3 itilo 2011-07-24 08:36:56 UTC
Created attachment 49470 [details]
a document with wmf
Comment 4 itilo 2011-07-24 08:38:52 UTC
Yes it seems to be the same that Bug 39327.
OpenOffice is able to read the file
Thank you
Comment 5 Rainer Bielefeld Retired 2011-07-24 08:56:18 UTC
Looks like a complete document for me with WIN. The doc indeed contains several .wmf objects,  also the "Linux only" is like Bug 39327. Because that one is already assigned I will mar this one as a DUP.

@itilo
for the sake of completeness - can you please also attach a PDF export showing how it looks for you with OOo (and delete NEEDINFO when you have attached?
It would be kind if you will check after Fix for Bug 39327 whether the fix really also fixed your problem reported here.

Please feel free to reopen this Bug if you find evidence that we have an independent issue here. 

Thank you for your attention!

*** This bug has been marked as a duplicate of bug 39327 ***
Comment 6 itilo 2011-07-24 09:34:12 UTC
Created attachment 49471 [details]
PFd from OO of the same file

PDF export from OOo  3.2.1
Comment 7 Rainer Bielefeld Retired 2011-07-24 10:40:17 UTC
Hm, that PDF does not look perfect, but except some smaller problems it looks very similar to the result in MS WORD Viewer (and my LibO). That is not an "Empty Document", so without comments it helps nothing.

Please keep in mind that you can not be sure that someone else with an other system will see the same problems like you. 

- How is your result with the LibO version you use?
- What problems do you see in the PDF?
- Can it be that PDF export works fine, but View in LibO is wrong?

Questions, questions, questions ...
Comment 8 itilo 2011-07-24 11:06:19 UTC
Created attachment 49474 [details]
screen copy and pdf export from LO
Comment 9 itilo 2011-07-24 11:30:28 UTC
The zip file contains screen copies of the same . doc file in LO, and the pdf export from LO 3.3
Comment 10 itilo 2011-07-24 11:32:20 UTC
Created attachment 49475 [details]
Screen copy and pdf export from  LibreOffice 3.4.1  OOO340m1 (Build:103)

Screen copy and pdf export from  LibreOffice 3.4.1  OOO340m1 (Build:103)