Download it now!
Bug 37499 - Find and Replace Values does not work
Summary: Find and Replace Values does not work
Status: RESOLVED DUPLICATE of bug 33593
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Jan Holesovsky
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-23 05:58 UTC by Rainer Bielefeld Retired
Modified: 2011-10-29 08:43 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample document, pls see original report! (8.33 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-05-23 06:14 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-23 05:58:08 UTC
See that with "LibreOffice 3.4.0RC1  - WIN7  Home Premium (64bit) Spanish UI [OOO340m1 (Build:11)]".

Steps to reproduce, first something working (before all tests first click 'A1'):
1. open attached "mytest" 
2. click "Find & Replace" Icon
3. Type "my" into Find pane
4. Additional 'Options > Search Values'  
5. OK
   Expected: word will be found in A3
   Actual: as expected
10. Redo from 2, but Additional 'Options > Search Formulas'  
    As expected, nothing will be found.
    You can try several times switching that option, always 'Search Values' will
    be successful, 'Search Formulas' will be not

Now the problem
21 <ctrl+f> for find pane
22. Type "my" into Find pane, Enter
    Result: "Search key not found", it seems Find only finds values, 
            not matches in formulas
23. Now do again tests starting with step 2
    Expected: results as from above
    Actual: No chance, search will always fail

It does not help to close the document, you have to close LibO to heal the problem (until next use of Find bar).
   
This one might have the same roots as
"Bug 33379 - Searching in all sheets will not work after using the Find toolbar"
"Bug 33593 - FindBar use breaks the normal 'Find and replace' by columns"
"Bug 37179 - [UX] options set in Find&Replace dialogue, influence how Find tool bar works" (but now reverse effect)

To me that seems to be a blocker, but I know I am hypersensitive.

@Jan
one for you?
Comment 1 Rainer Bielefeld Retired 2011-05-23 06:14:21 UTC
Created attachment 47043 [details]
Sample document, pls see original report!

Pls. do tests in sheet "Formulas"
Comment 2 Frédéric Vuillod 2011-05-25 03:03:42 UTC
I confirm this

OOO340m1 (Build:11) FR Win7-32
Comment 3 Rainer Bielefeld Retired 2011-05-25 04:18:35 UTC
NEW due to Comment 2

@Jan:
Might be related to new Find bar function?
Please feel free to reassign if it's not your area!
Comment 4 LeMoyne Castle 2011-06-15 17:05:15 UTC
Has same form/symptom as Bug 36800 - [Easyhack] [Calc] "Find & replace" does not search single cell - reported on 3.3.2 release with: 
(before all tests first click 'A1') -- and -- Result: "Search key not found"
Comment 5 Jan Holesovsky 2011-07-26 15:15:17 UTC

*** This bug has been marked as a duplicate of bug 33593 ***