Bug 38065 - PDF Export with OS or LibO Appearance background color
Summary: PDF Export with OS or LibO Appearance background color
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: All Windows (All)
: medium minor
Assignee: Thorsten Behrens (CIB)
URL:
Whiteboard:
Keywords:
: 38708 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-08 00:00 UTC by Marek
Modified: 2013-06-28 12:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek 2011-06-08 00:00:36 UTC
With document color set to any other colour than automatic (white by default) LibreOffice exports the document under DRAW and IMPRESS module to the PDF file with the set document colour while CALC and WRITER do it correctly (ignore the set document colour and export it with white background). While this is not a major bug in some circumstances it might occur annoying.
Comment 1 Rainer Bielefeld Retired 2011-06-27 04:08:11 UTC
*** Bug 38708 has been marked as a duplicate of this bug. ***
Comment 2 Rainer Bielefeld Retired 2011-06-27 04:31:45 UTC
Still [Reproducible] with "LibreOffice 3.4.1RC1 - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:103)]" 

Original report here is concerning Menu 
'Tools > Options > LibO > Appearance > General - Document Background'

Same effect with background from OS theme (reproducible for me with a.m. LibO) is reported in "Bug 38708 - Draw: exporting to PDF inherits window background color".

Printing is ok (I tested with Background from LibO settings).

Also known in OOo, where it seems to be a very old bug, last version where it worked correct for me is OOo 1.1.4.
OOo 3.1.1 And 3.4-dev (obsolete) show same behavior as LibO
Comment 3 Rainer Bielefeld Retired 2011-06-27 05:13:32 UTC
@Thorsten:
Please feel free to reassign if it’s not your area!
Comment 4 Rainer Bielefeld Retired 2011-09-05 06:05:32 UTC
It's hard to understand why an old minor/trivial bug should be listed in "Most Annoying Bugs". That task is for "Major" or more, and mostly new bugs.

I remove it.
Comment 5 rpr 2011-09-06 00:24:03 UTC
Well, for me it is a really annoying bug.

It's a pity that the PDF export, which works correctly in Calc and Writer, has bugs in Draw and Impress. This bug is now 2+ years old and it's time to be fixed.
Comment 6 Reuben Thomas 2011-10-07 14:41:56 UTC
(In reply to comment #4)
> It's hard to understand why an old minor/trivial bug should be listed in "Most
> Annoying Bugs". That task is for "Major" or more, and mostly new bugs.

Then the task should be called "Most annoying major new bugs". This bug is annoying, and the fact that it's old makes it more annoying, not less annoying.
Comment 7 Björn Michaelsen 2011-12-23 13:24:47 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 8 ign_christian 2013-06-17 07:43:26 UTC
Not reproducible while trying PDF Export with Impress & Draw (LO 4.0.4.2 - Win7 32bit)
Comment 9 rpr 2013-06-20 08:51:57 UTC
Also not reproducible with LO Draw 4.0.3.3 on MS Windows 7 64-bit
and with LO Draw 4.1.0.0bata2 on MS Windows XP 32-bit.
Comment 10 Marek 2013-06-28 12:35:29 UTC
I have been able to reproduce the bug in. LO 4.0.4.2 undert both Win XP and Win 7 (draw and impress).
Comment 11 ign_christian 2013-06-28 12:42:59 UTC
Please try resetting user profile:
https://wiki.documentfoundation.org/UserProfile

If after doing that problem still occur, please REOPENED this bug along with your sample file.